Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

OpenVPN-Verbindung blockiert sonstige Dienste

Frage Netzwerke

Mitglied: istike2

istike2 (Level 2) - Jetzt verbinden

28.02.2011 um 19:22 Uhr, 4610 Aufrufe, 7 Kommentare

Hallo,

ih experimentiere mit OpenVPN herum.

Es ist mir heute aufgefallen, dass verschiedene Programme blockiert sind, wenn die VPN-Verbindung steht.

Auf meinem Notebook verliert z. B. das VoIP-Phone "PhonerLite" sofort die Verbindung bzw. auf dem Server (SBS 2003) geht das Drucken nicht (Xerox-MF-Netzwerkdrucker)

Weiß jemand woran es liegen kann?

Danke für die Idee.

Gr. I.
Mitglied: john-doe
28.02.2011 um 20:49 Uhr
Hi

Möglicherweise wird durch das aufbauen des Tunnels der GW in der Routingtable verändert.
Was jedoch nicht ganz klar ist, warum der Drucker die Verbindung verliert. Kann es sein das
der Drucker bzw. Server in einem gerouteten LAN ist??

Kannst du eventuell mal die Routing Table posten?
(cmd --> route print)

Einmal mit VPN, einmal ohne.

LG
Bitte warten ..
Mitglied: istike2
28.02.2011 um 21:01 Uhr
Hallo,

hier ist es ohne Verbindung:


IPv4-Routentabelle
Schnittstellenliste
0x1 ........................... MS TCP Loopback interface
0x2 ...00 ff 8e 25 94 14 ...... TAP-Win32 Adapter V9
0x3 ...00 23 c3 f5 ac 61 ...... Hamachi Network Interface
0x10005 ...00 04 23 b7 e8 aa ...... Intel(R) PRO/1000 CT Network Connection
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Metrik
0.0.0.0 0.0.0.0 192.168.1.250 192.168.1.200 1
5.0.0.0 255.0.0.0 5.245.172.97 5.245.172.97 20
5.245.172.97 255.255.255.255 127.0.0.1 127.0.0.1 20
5.255.255.255 255.255.255.255 5.245.172.97 5.245.172.97 20
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
172.16.2.0 255.255.255.252 172.16.2.1 172.16.2.1 30
172.16.2.1 255.255.255.255 127.0.0.1 127.0.0.1 30
172.16.255.255 255.255.255.255 172.16.2.1 172.16.2.1 30
192.168.1.0 255.255.255.0 192.168.1.200 192.168.1.200 20
192.168.1.200 255.255.255.255 127.0.0.1 127.0.0.1 20
192.168.1.255 255.255.255.255 192.168.1.200 192.168.1.200 20
224.0.0.0 240.0.0.0 5.245.172.97 5.245.172.97 20
224.0.0.0 240.0.0.0 172.16.2.1 172.16.2.1 30
224.0.0.0 240.0.0.0 192.168.1.200 192.168.1.200 20
255.255.255.255 255.255.255.255 5.245.172.97 5.245.172.97 1
255.255.255.255 255.255.255.255 172.16.2.1 172.16.2.1 1
255.255.255.255 255.255.255.255 192.168.1.200 192.168.1.200 1
Standardgateway: 192.168.1.250
St„ndige Routen:
Keine

und hier ist es mit VPN-Verbindung:


IPv4-Routentabelle
Schnittstellenliste
0x1 ........................... MS TCP Loopback interface
0x2 ...00 ff 8e 25 94 14 ...... TAP-Win32 Adapter V9
0x3 ...00 23 c3 f5 ac 61 ...... Hamachi Network Interface
0x10005 ...00 04 23 b7 e8 aa ...... Intel(R) PRO/1000 CT Network Connection
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Metrik
0.0.0.0 0.0.0.0 192.168.1.250 192.168.1.200 1
5.0.0.0 255.0.0.0 5.245.172.97 5.245.172.97 20
5.245.172.97 255.255.255.255 127.0.0.1 127.0.0.1 20
5.255.255.255 255.255.255.255 5.245.172.97 5.245.172.97 20
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
172.16.2.0 255.255.255.252 172.16.2.1 172.16.2.1 30
172.16.2.1 255.255.255.255 127.0.0.1 127.0.0.1 30
172.16.255.255 255.255.255.255 172.16.2.1 172.16.2.1 30
192.168.1.0 255.255.255.0 192.168.1.200 192.168.1.200 20
192.168.1.200 255.255.255.255 127.0.0.1 127.0.0.1 20
192.168.1.255 255.255.255.255 192.168.1.200 192.168.1.200 20
224.0.0.0 240.0.0.0 5.245.172.97 5.245.172.97 20
224.0.0.0 240.0.0.0 172.16.2.1 172.16.2.1 30
224.0.0.0 240.0.0.0 192.168.1.200 192.168.1.200 20
255.255.255.255 255.255.255.255 5.245.172.97 5.245.172.97 1
255.255.255.255 255.255.255.255 172.16.2.1 172.16.2.1 1
255.255.255.255 255.255.255.255 192.168.1.200 192.168.1.200 1
Standardgateway: 192.168.1.250
St„ndige Routen:
Keine

Ich sehe keinen Unterschied.

Gr. I.
Bitte warten ..
Mitglied: john-doe
28.02.2011 um 21:22 Uhr
Also da is irgendwo der Hund drin

Kann es sein das du 2x die gleiche Routing Table rein kopiert hast?

Es sollte doch mindestens eine Route mit dem Remote-Netzwerk bei aufgebauten VPN vorhanden sein.
Hast du die IP des openVPN Adapter manuell vergeben?

Nutzt du die aktuellste Stable Version von OpenVPN?

Verwendest du einen UTM-Gateway mit openVPN oder hast du den openVPN Server so am laufen?
Wie hast du die config.ovpn erstellt?
Bitte warten ..
Mitglied: istike2
28.02.2011 um 21:33 Uhr
Ok. Ich habe es erneut gemacht:


IPv4-Routentabelle
Schnittstellenliste
0x1 ........................... MS TCP Loopback interface
0x2 ...00 ff 8e 25 94 14 ...... TAP-Win32 Adapter V9
0x3 ...00 23 c3 f5 ac 61 ...... Hamachi Network Interface
0x10005 ...00 04 23 b7 e8 aa ...... Intel(R) PRO/1000 CT Network Connection
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Metrik
0.0.0.0 0.0.0.0 192.168.1.250 192.168.1.200 1
5.0.0.0 255.0.0.0 5.245.172.97 5.245.172.97 20
5.245.172.97 255.255.255.255 127.0.0.1 127.0.0.1 20
5.255.255.255 255.255.255.255 5.245.172.97 5.245.172.97 20
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
172.16.2.0 255.255.255.252 172.16.2.1 172.16.2.1 30
172.16.2.1 255.255.255.255 127.0.0.1 127.0.0.1 30
172.16.255.255 255.255.255.255 172.16.2.1 172.16.2.1 30
192.168.1.0 255.255.255.0 192.168.1.200 192.168.1.200 20
192.168.1.200 255.255.255.255 127.0.0.1 127.0.0.1 20
192.168.1.255 255.255.255.255 192.168.1.200 192.168.1.200 20
224.0.0.0 240.0.0.0 5.245.172.97 5.245.172.97 20
224.0.0.0 240.0.0.0 172.16.2.1 172.16.2.1 30
224.0.0.0 240.0.0.0 192.168.1.200 192.168.1.200 20
255.255.255.255 255.255.255.255 5.245.172.97 5.245.172.97 1
255.255.255.255 255.255.255.255 172.16.2.1 172.16.2.1 1
255.255.255.255 255.255.255.255 192.168.1.200 192.168.1.200 1
Standardgateway: 192.168.1.250
St„ndige Routen:
Keine

Die Verbindung besteht definitiv, der Client bekommt die IP 172.16.2.6 per DHCP.

"Wie hast du die config.ovpn erstellt"?

port 1194
proto udp
dev tun0
pkcs12 C:\\Programme\\OpenVPN\\easy-rsa\\keys\\xxxx_Server.p12
dh C:\\Programme\\OpenVPN\\easy-rsa\\keys\\dh1024.pem
mode server
server 172.16.2.0 255.255.255.0
push "route 192.168.1.0 255.255.255.0"
keepalive 10 120
comp-lzo
persist-key
persist-tun
verb 3
"Hast du die IP des openVPN Adapter manuell vergeben?" --> nein

"Nutzt du die aktuellste Stable Version von OpenVPN?" --> Ja, 2.1.4

"Verwendest du einen UTM-Gateway mit openVPN oder hast du den openVPN Server so am laufen?" --> der OVPN-Server läuft auf dem SBS 2003 Server

Gr. I.
Bitte warten ..
Mitglied: john-doe
28.02.2011 um 21:45 Uhr
jetzt muss ich mal blöd fragen,

bist du gerade im gleichen Netzwerk, in welches du die VPN-Verbindung aufbauen willst?

Irgendetwas ist auf jeden fall ein wenig komisch...


Weil eigentlich sollte richtigerweise bei aufgebauter Verbindung folgende Route da sein.

192.168.1.0 255.255.255.0 172.16.2.6 172.16.2.6

sonst wird´s nie richtig funktionieren.
Bitte warten ..
Mitglied: istike2
28.02.2011 um 21:54 Uhr
Hallo,

ich habe mittlerweile kapiert, dass ich den Befehl für Ausdrucken der Routes nicht auf dem Server, sondern auf dem Client ausführen muss:

hier sind als die Routes:

Schnittstellenliste
31...00 ff a0 f7 1c 88 ......TAP-Win32 Adapter V9
13...00 21 86 4c 8c 04 ......Bluetooth-Ger„t (PAN)
11...00 21 5c 4c bb d3 ......Intel(R) Wireless WiFi Link 4965AGN
10...00 21 70 9a f1 a0 ......Broadcom NetXtreme 57xx-Gigabit-Controller
1...........................Software Loopback Interface 1
42...00 00 00 00 00 00 00 e0 Microsoft-6zu4-Adapter
43...00 00 00 00 00 00 00 e0 Microsoft-ISATAP-Adapter #3
44...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface
45...00 00 00 00 00 00 00 e0 Microsoft-ISATAP-Adapter #4
40...00 00 00 00 00 00 00 e0 Microsoft-ISATAP-Adapter #2

IPv4-Routentabelle
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Metrik
0.0.0.0 0.0.0.0 85.216.120.1 xxx.xxx.xxx.xxx 20
xx.216.120.0 255.255.252.0 Auf Verbindung xxx.xxx.xxx.xxx 276
xxx.xxx.xxx.xxx 255.255.255.255 Auf Verbindung xxx.xxx.xxx.xxx 276
xx.216.123.255 255.255.255.255 Auf Verbindung xxx.xxx.xxx.xxx 276
127.0.0.0 255.0.0.0 Auf Verbindung 127.0.0.1 306
127.0.0.1 255.255.255.255 Auf Verbindung 127.0.0.1 306
127.255.255.255 255.255.255.255 Auf Verbindung 127.0.0.1 306
172.16.2.1 255.255.255.255 172.16.2.5 172.16.2.6 30
172.16.2.4 255.255.255.252 Auf Verbindung 172.16.2.6 286
172.16.2.6 255.255.255.255 Auf Verbindung 172.16.2.6 286
172.16.2.7 255.255.255.255 Auf Verbindung 172.16.2.6 286
192.168.1.0 255.255.255.0 172.16.2.5 172.16.2.6 30
224.0.0.0 240.0.0.0 Auf Verbindung 127.0.0.1 306
224.0.0.0 240.0.0.0 Auf Verbindung xxx.xxx.xxx.xxx 276
224.0.0.0 240.0.0.0 Auf Verbindung 172.16.2.6 286
255.255.255.255 255.255.255.255 Auf Verbindung 127.0.0.1 306
255.255.255.255 255.255.255.255 Auf Verbindung xxx.xxx.xxx.xxx 276
255.255.255.255 255.255.255.255 Auf Verbindung 172.16.2.6 286
St„ndige Routen:
Netzwerkadresse Netzmaske Gatewayadresse Metrik
0.0.0.0 0.0.0.0 5.0.0.1 Standard

IPv6-Routentabelle
Aktive Routen:
If Metrik Netzwerkziel Gateway
42 1125 ::/0 2002:c058:6301::1
1 306 ::1/128 Auf Verbindung
42 1025 2002::/16 Auf Verbindung
42 281 2002:55d8:79e5::55d8:79e5/128
Auf Verbindung
10 276 fe80::/64 Auf Verbindung
31 286 fe80::/64 Auf Verbindung
10 276 fe80::58d9:31ce:6735:6b9/128
Auf Verbindung
31 286 fe80::b481:8417:f57b:4e73/128
Auf Verbindung
1 306 ff00::/8 Auf Verbindung
10 276 ff00::/8 Auf Verbindung
31 286 ff00::/8 Auf Verbindung
St„ndige Routen:
Keine
Man sieht also die Umleitung:

192.168.1.0 255.255.255.0 172.16.2.5 172.16.2.6 30

Was bisher klappte:

Ich kann den OVPN-Server 172.16.2.1 per Ping erreichen. Ich kann auch den Server des SBS Netzes anpingen. Ich sehe aber keinen anderen Client in diesem VPN-fremden Netz. Ich möchte dort vor Allem den Netzwerkdrucker 192.18.1.155 "sehen". Es geht nicht.

Und es blieb auch das eigentliche Problem: wenn die VPN-Verbindung zwischen meinem Notebook und dem Server aktiv ist, kann der Netzwerkdrucker im fremden Netz nicht erreiche werden (innerhalb des eigenen Netzes.)

Ein echtes Rätsel...

hier ist die aktuelle Config-Datei des Servers:


port 1194
proto udp
dev tun
tun-mtu 1500
fragment 1300
mssfix
pkcs12 C:\\Programme\\OpenVPN\\easy-rsa\\keys\\Tank_Server.p12
dh C:\\Programme\\OpenVPN\\easy-rsa\\keys\\dh1024.pem
mode server
server 172.16.2.0 255.255.255.0
push "route 192.168.1.0 255.255.255.0"
push "dhcp-option DOMAIN xxxxxxx.local"
push "dhcp-option DNS 192.168.1.200"
push "dhcp-option WINS 192.168.1.200"
tls-server
ifconfig-pool-persist ipp.txt
auth SHA1
cipher AES-256-CBC
keepalive 10 120
comp-lzo
verb 3
Gr. I.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Firewall
gelöst PFSense Squid Proxy über OpenVpn Verbindung nutzen (4)

Frage von horstvogel zum Thema Firewall ...

LAN, WAN, Wireless
gelöst OpenVPN Verbindung kommt nicht zustande (35)

Frage von Xandros zum Thema LAN, WAN, Wireless ...

Router & Routing
gelöst OpenVPN und PPTP Verbindung (3)

Frage von Veritas zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...