Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OpenVZ öffentliche IP vom Host

Frage Linux Linux Netzwerk

Mitglied: EvilMoe

EvilMoe (Level 2) - Jetzt verbinden

01.04.2013, aktualisiert 02.04.2013, 1827 Aufrufe, 4 Kommentare, 1 Danke

Guten Abend,

ich habe ein merkwürdiges Problem. Ich habe ein Debian Host wo auch eine OpenVZ Maschine darauf läuft (auch Debian).

Ein Problem was ich feststellen musste ist, ich lade mir eine Seite per wget auf dem VPS runter. Dort wird aber die IP vom Host und nicht von dem VPS angezeigt. Beide haben eine eigene öffentliche IP.

Der VPS ist von außen auch unter seiner eigenen IP erreichbar, keine Probleme. Nur aus welchem Grund wird wenn ich eine Seite öffne die IP von meinem Host angezeigt?
Jemand ne Idee?


Sven
Mitglied: Epixc0re
01.04.2013 um 22:55 Uhr
N'abend,

poste doch mal die Ausgabe von iptables-save


Stefan
Bitte warten ..
Mitglied: EvilMoe
02.04.2013 um 06:22 Uhr
Moin,

VPS:
01.
root@xxxxx:~#  iptables-save 
02.
# Generated by iptables-save v1.4.8 on Tue Apr  2 06:16:51 2013 
03.
*mangle 
04.
:PREROUTING ACCEPT [807887142:234649123961] 
05.
:INPUT ACCEPT [807887105:234649075761] 
06.
:FORWARD ACCEPT [5:200] 
07.
:OUTPUT ACCEPT [1355962708:1851091433777] 
08.
:POSTROUTING ACCEPT [1355962713:1851091433977] 
09.
COMMIT 
10.
# Completed on Tue Apr  2 06:16:51 2013 
11.
# Generated by iptables-save v1.4.8 on Tue Apr  2 06:16:51 2013 
12.
*filter 
13.
:INPUT ACCEPT [244114:206987118] 
14.
:FORWARD ACCEPT [0:0] 
15.
:OUTPUT ACCEPT [310406:493005409] 
16.
:EASYSCP_INPUT - [0:0] 
17.
:EASYSCP_OUTPUT - [0:0] 
18.
-A INPUT -j EASYSCP_INPUT 
19.
-A OUTPUT -j EASYSCP_OUTPUT 
20.
-A EASYSCP_INPUT -p tcp -m tcp --sport 587 
21.
-A EASYSCP_INPUT -p tcp -m tcp --sport 465 
22.
-A EASYSCP_INPUT -p tcp -m tcp --sport 25 
23.
-A EASYSCP_INPUT -p tcp -m tcp --dport 993 
24.
-A EASYSCP_INPUT -p tcp -m tcp --dport 995 
25.
-A EASYSCP_INPUT -p tcp -m tcp --dport 587 
26.
-A EASYSCP_INPUT -p tcp -m tcp --dport 465 
27.
-A EASYSCP_INPUT -p tcp -m tcp --dport 25 
28.
-A EASYSCP_INPUT -p tcp -m tcp --dport 143 
29.
-A EASYSCP_INPUT -p tcp -m tcp --dport 110 
30.
-A EASYSCP_INPUT -p tcp -m tcp --dport 443 
31.
-A EASYSCP_INPUT -p tcp -m tcp --dport 80 
32.
-A EASYSCP_INPUT -j RETURN 
33.
-A EASYSCP_OUTPUT -p tcp -m tcp --dport 587 
34.
-A EASYSCP_OUTPUT -p tcp -m tcp --dport 465 
35.
-A EASYSCP_OUTPUT -p tcp -m tcp --dport 25 
36.
-A EASYSCP_OUTPUT -p tcp -m tcp --sport 993 
37.
-A EASYSCP_OUTPUT -p tcp -m tcp --sport 995 
38.
-A EASYSCP_OUTPUT -p tcp -m tcp --sport 587 
39.
-A EASYSCP_OUTPUT -p tcp -m tcp --sport 465 
40.
-A EASYSCP_OUTPUT -p tcp -m tcp --sport 25 
41.
-A EASYSCP_OUTPUT -p tcp -m tcp --sport 143 
42.
-A EASYSCP_OUTPUT -p tcp -m tcp --sport 110 
43.
-A EASYSCP_OUTPUT -p tcp -m tcp --sport 443 
44.
-A EASYSCP_OUTPUT -p tcp -m tcp --sport 80 
45.
-A EASYSCP_OUTPUT -j RETURN 
46.
COMMIT 
47.
# Completed on Tue Apr  2 06:16:51 2013
Host:

01.
root@xxxxxx:~# iptables-save 
02.
# Generated by iptables-save v1.4.8 on Tue Apr  2 06:18:14 2013 
03.
*nat 
04.
:PREROUTING ACCEPT [42668895:2347813691] 
05.
:POSTROUTING ACCEPT [44501746:2439064077] 
06.
:OUTPUT ACCEPT [9316263:572445739] 
07.
-A POSTROUTING -o eth0 -j MASQUERADE 
08.
-A POSTROUTING -o eth0 -j MASQUERADE 
09.
-A POSTROUTING -o vmbr0 -j MASQUERADE 
10.
COMMIT 
11.
# Completed on Tue Apr  2 06:18:14 2013 
12.
# Generated by iptables-save v1.4.8 on Tue Apr  2 06:18:14 2013 
13.
*mangle 
14.
:PREROUTING ACCEPT [16825182613:13931772267031] 
15.
:INPUT ACCEPT [3770348760:3227126363336] 
16.
:FORWARD ACCEPT [13053069754:10704515176706] 
17.
:OUTPUT ACCEPT [1970346625:8593106698007] 
18.
:POSTROUTING ACCEPT [15023416379:19297621874713] 
19.
COMMIT 
20.
# Completed on Tue Apr  2 06:18:14 2013 
21.
# Generated by iptables-save v1.4.8 on Tue Apr  2 06:18:14 2013 
22.
*filter 
23.
:INPUT ACCEPT [304156:65778287] 
24.
:FORWARD ACCEPT [22632677:17730761776] 
25.
:OUTPUT ACCEPT [271224:334226129] 
26.
COMMIT 
27.
# Completed on Tue Apr  2 06:18:14 2013

Ich erinnere mich wieder das ich mal etwas an daran geändert habe. Dabei ging es um einen VPN Server der auf dem host laufen sollte.
Ich vermute mal der Fehler liegt an:
01.
-A POSTROUTING -o eth0 -j MASQUERADE etc.
Bitte warten ..
Mitglied: Epixc0re
LÖSUNG 02.04.2013, aktualisiert 08.02.2015
Zitat von EvilMoe:
Ich vermute mal der Fehler liegt an:
01.
-A POSTROUTING -o eth0 -j MASQUERADE etc.


Korrekt, das ist der Fehler - damit Nattest du alles was deinen Host verlässt, also auch den Traffic des Containers.
Es sei denn, dein Öffentliches Interface ist eth1, eth2 oder so, dann musst du die entsprechende Regel löschen.


Stefan
Bitte warten ..
Mitglied: EvilMoe
02.04.2013 um 16:33 Uhr
Hat mein Problem gelöst.


Vielen Dank!
Sven
Bitte warten ..
Neuester Wissensbeitrag
Festplatten, SSD, Raid

12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Ähnliche Inhalte
Router & Routing
Lancom N:N-NAT - öffentliche IP und Firewall

Frage von devil77 zum Thema Router & Routing ...

Router & Routing
gelöst Pfsense, Virtual IP mit NAT und DMZ Host (7)

Frage von LordXearo zum Thema Router & Routing ...

Firewall
gelöst Site-to-Site-VPN und Cisco VPN-Client von gleicher IP (2)

Frage von TripleDouble zum Thema Firewall ...

Windows Server
gelöst HyperV Host CPU Kaufempfehlung (4)

Frage von adrian138 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...