Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Ordner per GPO einer Bibliothek hinzufügen

Frage Microsoft Windows Server

Mitglied: Xaero1982

Xaero1982 (Level 3) - Jetzt verbinden

22.06.2011 um 21:11 Uhr, 10152 Aufrufe, 5 Kommentare

Moin Zusammen,

nachdem mein anderer Beitrag zur Indizierung von Netzlaufwerken ja vollkommen unkommentiert bliebt hier nun noch mal eine andere Frage:

Damit ein Ordner auf dem Client (W7) indiziert wird muss sich dieser in einer Bibliothek befinden.

Nun meine Frage: Wie kann ich per GPO:

a) eine Bibliothek erstellen und einen Ordner hinzufügen
b) nur ein Ordner einer bestehenden Bibliothek hinzufügen
c) ein Netzlaufwerk direkt indizieren lassen, damit die Suche darauf erweitert wird.

Das ganze OHNE Offlinenutzung!

Momentan habe ich eine Bibliothek erstellt und dort den Ordner hinzugefügt. Diese Verknüpfung habe ich dann auf den Server kopiert und lasse sie via Batch auf die Clients kopieren.
Auf dem Server kann ich die Bibliothek noch öffnen mit korrektem Ordner.
Nach dem Kopieren auf den Client ist die Bibliothek leer.

Jemand eine Idee?

VG und Thx!
Mitglied: Logan000
23.06.2011 um 08:40 Uhr
Moin Moin

Das klappt nicht auf dem direkten Weg. Sonder nur über Group Policy Preferences (Einstellungen).

Das Vorgehen ist:
- Schnapp Dir ein Testsystem und Erstelle / Konfiguriere eine Bibliothek nach deinen Vorstellungen.
- Dann snappst Du dir die entsprechende *.library-ms datei (solte unter %AppData%\Microsoft\Windows\Libraries liegen)
- Diese kopierst du dann mittels GPP (oder skript) auf die entsprechenden Rechner

Noch ein Hinweis:
Auf diesem Weg (anders als über die GUI) wird die Bibliothek dann aber nicht indiziert.

Ich hoffe das hilft dir weiter.

Gruß L.
Bitte warten ..
Mitglied: Xaero1982
26.06.2011 um 00:25 Uhr
Zitat von Logan000:
Moin Moin

Das klappt nicht auf dem direkten Weg. Sonder nur über
Group Policy Preferences (Einstellungen).

Das Vorgehen ist:
- Schnapp Dir ein Testsystem und Erstelle / Konfiguriere eine Bibliothek nach deinen Vorstellungen.
- Dann snappst Du dir die entsprechende *.library-ms datei (solte unter %AppData%\Microsoft\Windows\Libraries liegen)
- Diese kopierst du dann mittels GPP (oder skript) auf die entsprechenden Rechner

Noch ein Hinweis:
Auf diesem Weg (anders als über die GUI) wird die Bibliothek dann aber nicht indiziert.

Ich hoffe das hilft dir weiter.

Gruß L.
^
Danke, aber genau das habe ich gemacht und wie ich ja oben schrieb ist die Bibliothek nach dem zurückkopieren auf den Client - leer! Auf dem Server geht sie noch!

VG & Thx dennoch!
Bitte warten ..
Mitglied: Logan000
27.06.2011 um 08:31 Uhr
Moin

Hast Du dem Client mitgegeben das er diesen Ordner auch indizieren soll?
Dies ginge per GPO unter :
Computerkonfiguration / Administrative Vorlagen / Windows-Komponenten / Suche

Damit ein Ordner auf dem Client (W7) indiziert wird muss sich dieser in einer Bibliothek befinden.
Ist das (für Netzlaufwerke) nicht falsch, bzw. andersherum?
Damit ein Ordner in eine Bibliothek aufgenommen werden kann, muss dieser indiziert sein.

Gruß L.
Bitte warten ..
Mitglied: Xaero1982
27.06.2011 um 22:19 Uhr
Zitat von Logan000:
Moin

Hast Du dem Client mitgegeben das er diesen Ordner auch indizieren soll?
Dies ginge per GPO unter :
Computerkonfiguration / Administrative Vorlagen / Windows-Komponenten / Suche

> Damit ein Ordner auf dem Client (W7) indiziert wird muss sich dieser in einer Bibliothek befinden.
Ist das (für Netzlaufwerke) nicht falsch, bzw. andersherum?
Damit ein Ordner in eine Bibliothek aufgenommen werden kann, muss dieser indiziert sein.

Gruß L.

Ehm ist natürlich Murks was ich schrieb

Damit ich die Suche aufs Netzlaufwerk ausweiten kann, muss sich der Ordner in einer Bibliothek befinden.

Ich werd morgen noch mal die genaue Konstellation testen und schreiben.

VG
Bitte warten ..
Mitglied: Xaero1982
28.06.2011 um 09:45 Uhr
Moin,

also noch mal:

Ziel
Es soll ein Netzlaufwerk so eingerichtet werden, dass vom Client aus auf diesem Netzlaufwerk gesucht werden kann, sprich die Windows Search - Funktion von Windows 7 funktioniert.

Problem
Das Netzlaufwerk wird nicht in der Indizierung angezeigt.

Alternative
Das Netzlaufwerk wird in eine Bibliothek aufgenommen.

Problem
Scheinbar lassen sich neue Bibliotheken nicht indizieren. Zumindest werden sie nicht angezeigt.

Alternative
Wenn ich das Netzlaufwerk in eine bestehende Bibliothek aufnehme funktioniert die Suche - ist allerdings nicht im Sinne des Erfinders.

Echt tolle Erfindung die Bibliotheken und die Indizierung.

VG & Thx!
Edit: Also inzwischen hab ich es hinbekommen, dass ich eine neue Bibliothek erstellt habe und diese dann auf den Server kopiere und via Script auf den Client. Dieses mal ist der ursprünglich hinzugefügte Ordner auch vorhanden, aber die Suche funktioniert nicht. Die gesuchten Dateien werden nicht angezeigt.
Edit2: Mit diesem Hotfix: http://support.microsoft.com/kb/2268596/en-us ist es möglich auch in nicht indizierten Bibliotheken zu suchen. Es ist zwar etwas langsamer, aber es funktioniert. Schade, dass MS hier so geschlampt hat
Bitte warten ..
Neuester Wissensbeitrag
Heiß diskutierte Inhalte
Linux
gelöst Boot failed: not a bootable disk (10)

Frage von Fleckmen zum Thema Linux ...

Windows Server
Probleme mit Client Software Zugriff auf Windows Server 2012 (8)

Frage von it-kolli zum Thema Windows Server ...

Router & Routing
Cisco887VAW -VPN NAT-Freigabe (8)

Frage von Serial90 zum Thema Router & Routing ...

Multimedia & Zubehör
gelöst Iphone 6 prob (8)

Frage von jensgebken zum Thema Multimedia & Zubehör ...