Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Ordnerreplikate bei der Exchange Migration von 2007 auf 2010

Frage Microsoft Exchange Server

Mitglied: weltstar

weltstar (Level 1) - Jetzt verbinden

27.06.2012, aktualisiert 09:42 Uhr, 10805 Aufrufe, 20 Kommentare

Ich habe eine Exchange Migration von 2007 auf 2010 durchgeführt, und möchte nun den 2007er deinstallieren. In der Second storage Group befinden sich noch Ordnerreplikate, die ich bisher nicht entfernen konnte.
Ich hänge schon seit 3 Tagen an dieser Problematik und habe haufenweise Ratschläge aus dem Internet befolgt, bisher ohne Erfolg.

Hallo, ich beschreibe erst mal die Ausgangslage:
Exchange 2007 SP3 RU7 auf Server 2003 R2 64bit
Exchange 2010 SP2 RU2 auf Server 2008 R2

Bis auf ein Ordnerrepliakt habe ich alles auf den 2010er migriert. Mein Problem scheint das Ordnerreplikat für
die Frei/Gebucht Informationen zu sein. Wenn ich sowohl auf dem 2007er als auch auf dem 2010er in der EMS
get-publicfolderstatistics ausführe, bekomme ich Foldendes angezeigt:

Exchange 2007:
Name ItemCount
---------
EX:/o=XXX/ou=Exchange Administ 283
rative Group (FYDIBOHF23SPDLT)

Exchange 2010:
Name ItemCount
---------
Default 0
EX:/o=XXX/ou=Exchange Admin... 110
EX:/o=XXX/ou=Exchange Admin... 0
exchangeV1 0
XXX 0
Firmenkontakte 0
OAB Version 2 0
OAB Version 3a 0
OAB Version 4 0
/o=XXX/cn=addrlists/cn=oabs... 0
globalevents 0
internal 0
microsoft 0
OWAScratchPad{B1D84EA0-028D-4285-B323... 0
schema-root 0
StoreEvents{B1D84EA0-028D-4285-B323-6... 0

Zur Info: Wir benutzen bisher keine öffentlichen Ordner! Da ich aber in der nahen Zukunft öO einführen will, habe ich welche zum Testen auf dem 2010er angelegt. Als ich die Replikation für die Frei/Gebucht Informationen aktiviert bzw. deaktiviert habe, veränderten sich die ItemCount Werte. Sonst wüsste ich nicht, wie ich herausfinden kann, um welches Replikat es sich handelt.

Zur Vollständigkeit halber hier die Meldung, wenn ich 2007 deinstallieren will:
Zusammenfassung: 3 Element(e). Erfolgreich: 2, Fehler: 1.
Verstrichene Zeit: 00:00:12

Mailbox-Funktion Voraussetzungen
Fehler

Fehler:
Die Deinstallation kann nicht fortgesetzt werden. Datenbank 'Public Folder Database': Die Öffentliche Ordner-Datenbank 'SRV-02\Second Storage Group\Public Folder Database' enthält Ordnerreplikate. Entfernen Sie die Ordner, oder verschieben Sie die Replikate in eine andere Öffentliche Ordner-Datenbank, bevor Sie die Öffentliche Ordner-Datenbank löschen. Weitere Anweisungen zum Entfernen einer Öffentlichen Ordner-Datenbank finden Sie unter http://go.microsoft.com/fwlink/?linkid=81409..
Empfohlene Aktion: http://go.microsoft.com/fwlink/?linkid=30939&l=de&v=ExBPA.12&am ...

Verstrichene Zeit: 00:00:06

ClientAccess-Funktion Voraussetzungen
Abgeschlossen

Verstrichene Zeit: 00:00:02

Hub-Transport-Funktion Voraussetzungen
Abgeschlossen

Verstrichene Zeit: 00:00:03
Zusätzlich habe ich noch ein Problem mit dem 2007er nach der Installation des neuesten RU7. Das Update habe ich durchgeführt, weil ich mögliche Probleme bei der Deinstallation minimieren wollte. Was ich jedoch nicht bemerkt habe ist, dass ich die Verwaltungskonsole des 2007ers nicht mehr komplett benutzen kann. Beim Öffnen der Serverkonfiguration in der Verwaltungskonsole bekomme ich folgende Fehlermeldung: "meine öffentliche IP" ist kein gültiger Hostname. Parametername: Hostname.
Dies erscheint beim Kontaktieren des Konfiguratuionsdomänencontrollers. In der Ereignisanzeige erscheint Folgendes:
Event ID: 4999
Quelle: MS Exchange common
Der Watson-Bericht steht kurz vor dem Versenden an 'dw20.exe' für die Prozess-ID: 5820, mit den Parametern: E12, c-RTL-AMD64, 08.03.0083.006, mmc, unknown, unknown, System.ArgumentException, 0, unknown. ErrorReportingEnabled: False

Wenn ich das Ordnerreplikat ohne die Konsole entfernen kann, muss ich dieses Problem nicht lösen, da der 2007er ja deinstalliert wird. Wenn ich die Konsole dafür brauche, muss ich es erst lösen... Das RU7 und auch Updates für die .NET Frameworks hatte ich deinstalliert, dies hatte aber keine positive Auswirkung. Auch die erneute Installation brachte nichts...

Ich komme alleine nicht wirklich weiter. Hat jemand eine Idee, was ich machen kann? Ich möchte nur SEHR ungern den ADSI-Editor benutzen.

Vielen Dank für eure Hilfe. Wenn ich etwas vergessen habe, dann sagt Bescheid!!!

Weltstar
Mitglied: Onitnarat
27.06.2012 um 09:55 Uhr
Hi,
wie hast Du die Replikation der öO eingerichtet?
01.
C:\Program Files\Microsoft\Exchange Server\V14\scripts\AddReplicaToPFRecursive.ps1 -TopPublicFolder \ -ServerToAdd ex2010
Entfernung über:
01.
C:\Program Files\Microsoft\Exchange Server\V14\scripts\RemoveReplicaFromPFRecursive.ps1 -TopPublicFolder \ -ServerToRemove ex2007
Da Du ja schreibst, dass in den öO nur "Testdaten" drin sind, könntest Du ja auch bei Null auf dem Exchange 2010 beginnen. Meine Theorie ;) ist, Erfahrungswerte müsste jemand anderes liefern, dass die User bzw. deren Postfächer ihre Frei-/Gebucht-Informationen neu publishen müssen und werden.
Bitte warten ..
Mitglied: weltstar
27.06.2012 um 10:19 Uhr
ich habe eigentlich nur die Öffentlichen Systemordner repliziert. Also den Exchange 2010 eingetragen und dann den 2007er ausgetragen...

Also wenn ich "RemoveReplicaFromPFRecursive.ps1 -TopPublicFolder \ -ServerToRemove srv-15" ausführe kommt folgender Fehler (auch bei remove):
Die Benennung "AddReplicaToPFRecursive.ps1" wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder eines ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern enthalten), und wiederholen Sie den Vorgang.
Bitte warten ..
Mitglied: Onitnarat
27.06.2012, aktualisiert um 10:24 Uhr
Existieren bei Dir denn die Dateien (AddReplicaToPFRecursive.ps1 und RemoveReplicaFromPFRecursive.ps1) in dem angegebenen Ordner? In welchen Pfad hast Du den Exchange installiert?
Bitte warten ..
Mitglied: weltstar
27.06.2012 um 10:29 Uhr
Exchange ist hier installiert: E:\Programme\Exchange Server\V14\Scripts
In diesem Ordner befinde ich mich auch in der Shell, wenn ich den Befehl ausführe und die Dateien sind im Verzeichnis!!
Bitte warten ..
Mitglied: Onitnarat
27.06.2012 um 10:33 Uhr
Wenn Du im Ordner in der Shell bist, musst Du ein ".\" voranstellen, also:
01.
.\AddReplicaToPFRecursive.ps1 -TopPublicFolder \ -ServerToAdd ex2010
bzw.
01.
.\RemoveReplicaFromPFRecursive.ps1 -TopPublicFolder \ -ServerToRemove ex2007
Bitte warten ..
Mitglied: weltstar
27.06.2012 um 10:38 Uhr
Ich kann die Befehle auf dem 2007er ausführen!! Wie langs muss ich warten, bis die Replikate vom 2007er weg sein sollten?
Oder muss ich jetzt noch etwas Anderes machen?
Bitte warten ..
Mitglied: Onitnarat
27.06.2012, aktualisiert um 10:47 Uhr
Ich würde sagen, die magische Viertelstunde ;)

Prüfen kannst Du es mit:
01.
Get-publicfolder -recurse |fl name,replicas
Edit: Schau Dir mal die Anleitung an, kurz aber gut: http://portal.msxforum.de/modules/smartfaq/faq.php?faqid=159
Bitte warten ..
Mitglied: weltstar
27.06.2012 um 10:56 Uhr
Also ich bekomme auf beiden Servern folgende Ausgabe:

[PS] C:\Programme\Microsoft\Exchange Server\Scripts>Get-publicfolder -recurse |fl name,replicas


Name : IPM_SUBTREE
Replicas : {}

Name : XXX
Replicas : {Public Folder DB}

Name : Firmenkontakte
Replicas : {Public Folder DB}

Die "Public Folder DB" liegt auf dem neuen 2010er! Ich verstehe das nur mit dem IPM_Subtree nicht. Da schlag ich mich schon die ganze Zeit mit herum. Wenn ich auf dem 2007er "get-publicfolder" ausführe, bekomme ich auch Folgende Ausgabe:

Name
IPM_SUBTREE
Bitte warten ..
Mitglied: Onitnarat
27.06.2012 um 11:01 Uhr
Also im IPM_SUBTREE sind die Ordner die für die Benutzer sichtbar sind also bei dir "XXX" und "Firmenkontakte", dass der Ordner selbst keine Replikate hat, kannst Du meiner Meinung nach ignorieren.

Was passiert denn nun, wenn Du den Exchange 2007 deinstallieren willst?
Bitte warten ..
Mitglied: weltstar
27.06.2012 um 11:09 Uhr
Dann kommt die besagte Fehlermeldung vom 1. Post!

Mailbox-Funktion Voraussetzungen
Fehler

Fehler:
Die Deinstallation kann nicht fortgesetzt werden. Datenbank 'Public Folder Database': Die Öffentliche Ordner-Datenbank 'SRV-02\Second Storage Group\Public Folder Database' enthält Ordnerreplikate. Entfernen Sie die Ordner, oder verschieben Sie die Replikate in eine andere Öffentliche Ordner-Datenbank, bevor Sie die Öffentliche Ordner-Datenbank löschen. Weitere Anweisungen zum Entfernen einer Öffentlichen Ordner-Datenbank finden Sie unter http://go.microsoft.com/fwlink/?linkid=81 .....


Ich verstehs leider nicht...
Bitte warten ..
Mitglied: weltstar
27.06.2012 um 13:07 Uhr
So, jetzt brauche ich noch mal Hilfe. Ist es normal, dass ich die Frei/Gebucht Informationen über die "Öffentliche Ordner Verwaltungskonsole" auf beiden Servern nicht löschen kann???

Folgende Fehlermeldung erscheint:

Microsoft Exchange Fehler
Die Aktion 'Inhalt aktualisieren' konnte für Objekt 'EX:/o=XXX/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)' nicht ausgeführt werden.

EX:/o=XXX/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)
Fehler
Fehler:
Der angegebene Server 'SRV-02' beinhaltet kein Replikat des Öffentlichen Ordners '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=XXX/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)'. Ein Synchronisieren des Inhalts des Öffentlichen Ordners kann nur von einem Server aus erfolgen, auf dem sich ein Replikat dieses Öffentlichen Ordners befindet.




OK
Bitte warten ..
Mitglied: weltstar
27.06.2012, aktualisiert um 13:18 Uhr
Ich vermute, dass der Public Folder corrupt ist und ich doch den ADSI-Editor benutzen muss. Bekomme nun folgende Fehlermeldung beim Versuch, die Frei/Gebucht Informationen zu entfernen:
MapiExceptionPartialCompletion: Unable to delete folder. (hr=0x40680, ec=0)

In Foren habe ich gefunden, dass viele es mit dem ADSI-Editor gelöst haben. Muss ich dann nur "Public Folder Database in folgendem Pfad löschen? Was passiert dann?

CN=Public Folder Database,CN=Second Storage Group,CN=InformationStore,CN=NT-SRV-02,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=XXX,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=XXX,DC=local
Bitte warten ..
Mitglied: Onitnarat
27.06.2012 um 14:01 Uhr
Ohje, das hört sich böse an. Hier muss ich mich aber leider ausklinken, mit ADSI im Bereich Exchange habe ich zum Glück keine Erfahrungen.
Aus dem Bauch heraus würde ich sagen, dass je weniger Du entfernst desto besser. Auch hilft es sicher, wenn Du alles was du löschst sauber dokumentierst, damit Du es im schlimmsten Fall manuell wieder erstellen kannst.
Auch ein Backup des AD könnte hilfreich sein.
Bitte warten ..
Mitglied: weltstar
27.06.2012 um 14:15 Uhr
Puuuhhhh, mit 200 Puls hab ich den besagten Eintrag mit dem ADSI-Editor gelöscht. Deinstallation von Exchange 2007 erfolgreich und alles läuft soweit!

Vielen Dank Onitnarat!!! Wenn man so etwas alleine macht, ist man ja schon unsicher, was man da verbockt. Da warst du ne sehr gute Hilfe!!
Bitte warten ..
Mitglied: Onitnarat
27.06.2012 um 14:23 Uhr
Mhhh, viel geholfen hab ich nicht gerade...trotzdem freut es mich, dass es geklappt hat.
Bitte warten ..
Mitglied: weltstar
27.06.2012 um 15:12 Uhr
Doch schon! Ich hab gemerkt, dass ich doch auf dem richtigen Weg bin. Manchmal muss es nur bestätigt werden!
Bitte warten ..
Mitglied: Onitnarat
27.06.2012 um 15:27 Uhr
Na gut, dann: Gern geschehen!
Und Du kannst den Laden hier ja mit einem "Frage ist gelöst" dicht machen. ;)
Bitte warten ..
Mitglied: Chibisuke
27.06.2012 um 22:15 Uhr
N'Abend,

hätt ich den Thread etwas früher gesehen hätte ich dir deinen 200er-Puls vielleicht ersparen können...
Wir hatten das Theater mit der Deinstallation von Ex2007 nach einer Migration auf 2010 (ebenfalls mit 2003R2 und 2008R2) Anfang des Jahres bei einem Kunden, und ich bin auch schier verzweifelt.
Da es schon etwas her ist kann ich mich nur noch wage dran erinnern, aber ich meine bei der Recherche raus bekommen zu haben dass das mehr oder weniger ein bekannter Fehler in Ex2007 ist. Muss morgen mal schauen ob ich die Links dazu noch finde... Auf jeden Fall war auch bei uns die einzige Lösung der Eingriff mit ADSI-Edit. Anders scheint es nicht zu gehen.

Naja, immerhin ging's gut aus
Bitte warten ..
Mitglied: weltstar
27.06.2012 um 22:49 Uhr
Ja, gott sei dank ist alles gut. Wär da etwas schief gegabgeb, hätte ich ein etwas größeres problem gehabt. Aber ein gutes hat die sache aber doch. Ivh kann jetzt sehr viel besser mit der powershell umgehen...

Wäre super, wenn du noch ein paar infos hast!!!

(Sorry, wegen der fehlenden groß und kleinschreibung, ich schreibe vom smartphone aus..
Bitte warten ..
Mitglied: Chibisuke
28.06.2012 um 08:46 Uhr
Moin,

hab die Tabs sogar noch offen (*hust*TabMessie*hust* müsste mal wieder aufräumen...)
Hatte damals erst mal die offiziellen Quellen von MS abgegrast, aber das brachte keinen Erfolg. Über ein anderes Thema hier Probleme bei Migration von Exchange 2007 nach 2010, Öffentliche Ordner... bin ich auf den telnetport25-Blog gestoßen der dann die Tips mit ADSI-Edit hatte.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Exchange Server
gelöst Exchange Migration 2007 auf 2013 (2)

Frage von quattrophilip zum Thema Exchange Server ...

Exchange Server
Exchange 2013, Outlook 2010 Standard-Absendeadresse ändern (4)

Frage von ingoue zum Thema Exchange Server ...

Outlook & Mail
Freigegebenes Postfach - Exchange 2013 - Office 2010-2013-2016 (6)

Frage von ATLaptop zum Thema Outlook & Mail ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...