Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Ordnertiefe mit mehr als 100 Ordnern... Wie löschen?

Frage Microsoft Windows Tools

Mitglied: FRAD

FRAD (Level 1) - Jetzt verbinden

18.01.2011 um 16:55 Uhr, 11297 Aufrufe, 11 Kommentare

Ordnertiefe mit mehr als 100 Ordnern... Wie löschen?

Hallo,

ich habe mir mittels Robocopy aus Versehen einen Ordner kopiert, welcher jetzt ca. 1400 Unterordner hat...

Auf Laufwerk F: habe ich einen Ordner namens "Neuer Ordner", darunter sind dann diese Ordner:


NEUERO~1\test\DOCUME~1\admin\AppData\Local\ANWEND~1\ANWEND~1\ANWEND~1\ANWEND~1\A
NWEND~1\ANWEND~1\ANWEND~1\ANWEND~1\ANWEND~1\ANWEND~1\ANWEND~1\ANWEND~1\ANWEND~1\
ANWEND~1\ANWEND~1\ANWEND~1\ANWEND~1\ANWEND~1\ANWEND~1\ANWEND~1\ANWEND~1\ANWEND~1
\ANWEND~1 - Das System kann den angegebenen Pfad nicht finden.

Diese Meldung kommt nach dem Löschbefehl. Ich habe mehr als 250 Zeichen ;))

Wie bekomme ich den Ordner gelöscht auch ohne formatieren? Mit Knoppix hatte ich auch kein Glück.

Grüße
Mitglied: askando
18.01.2011 um 17:00 Uhr
sollte eigentlich mit Knoppix gehen da ntfs-3g installiert ist. mmh Hast du auch rm -r /NEUERO~1 gschrieben?
Bitte warten ..
Mitglied: hewleTT09
18.01.2011 um 17:14 Uhr
Hallo,

wie askando schon sagte müsste es mit Knoppix und rm -r funktionieren. Es würde auch mit rm -r /NEUER* funktionieren. Falls du keinen zweiten Neuen Ordner in F: liegen hast weil der wäre dann auch weg.
Bitte warten ..
Mitglied: Biber
18.01.2011 um 17:16 Uhr
Moin FRAD,

lass mich raten: hast du vielleicht den Robocopy ohne Schalter "exclude Junctions" (/XJD) ausprobiert? *gg

Schau doch mal bei ebucht nach "Robocopy-Onlinemanual gebraucht".

Zur Entsorgung deiner Phantom-Ordner ersetze ein paar Ebenen des Gestrunkeles durch einen SUBST-Befehl.

Beispiel, wenn der Mist auf Laufwerk F: angesiedelt ist:
SUBST X: F:\NEUERO~1\test\DOCUME~1\admin\AppData\Local\ANWEND~1\ANWEND~1\ANWEND~1  
rd X:\ANWEND~1 /s /q 
SUBST X: /d 
## danach ggf noch den Rest oder auch den ganzen "Test"-Ordner 
rd F:\NEUERO~1\test\DOCUME~1\admin\AppData\Local\ANWEND~1 /s /q
mei, mei, mei.. du traust dich Sachen...

Grüße
Biber
Bitte warten ..
Mitglied: 76109
18.01.2011 um 18:10 Uhr
Hallo!

Von dem abgesehen, habe ich gerade in meiner Verzeichnungsstruktur nachgesehen, und festgestellt, dass ich unter:
Benutzer\admin\AppData\Local\ANWEND~1\ANWEND~1\ANWEND~1
auch wieder eine Endlose Ordnerstrukur habe (Win 7).

Das gleiche Problem ist mir kürzlich schonmal aufgefallen und habe alle Ordner entfernt. Das seltsame daran ist, dass ich die Ordner überhaupt nicht angerührt habe. Also nix mit Kopie oder dergleichen?

Gruß Dieter

PS. Unter Default das gleiche:
Benutzer\default\AppData\Local\ANWEND~1\ANWEND~1\ANWEND~1
Bitte warten ..
Mitglied: Biber
18.01.2011 um 18:54 Uhr
[Eigentlich OT]
Moin didi1954,

kann durchaus sein, dass du auch ohne (genau genommen ohne bewusstes) Kopieren diese Ordnerstruktur erzeugt hast.

Das Problem liegt nicht bei dir, sondern trifft wahrscheinlich alle Win7-User, zumindest die, die mit Robocopy ohne Schalter /XJD (exclude junction directories) bzw. mit dem "alten" Robocopy /XJ (exclude junctions) arbeiten auf der "C:\USERS"-Ebene von Win7
Und auch die User, in denen ein Anwendungsprogramm etwas in den Unterordner "Anwendungsdaten" schreiben will.
[Edit] "Etwas schreiben" reicht nicht--> gemeint ist, wenn ein Anwenderprogramm einen Unterordner dort anlegen will. [/Edit]

Die Redmonder PraktikantInnen haben -so weit, wie Kidz halt denken können, wenn sie ein neues Spielzeug haben - im Verzeichnis
C:\Users\<benutzername>\Anwendungsdaten
eine relative symbolische Verbindung namens (nicht lachen jezz') "Anwendungsdaten" angelegt.
Die verpointert auf (jezz' kannste lachen!) "..\..\Anwendungsdaten"

Lade dir, falls nicht vorhanden, irgendwo die junctions.exe oder die Mklink.exe runter und zieh den Quark glatt.

Als Administrator ausführen.
junctions -d C:\Users\<benutzername>\Appdata\Local\Anwendungsdaten 
## falls vorhanden auch 
junctions -d C:\Users\<benutzername>\Appdata\LocalLow\Anwendungsdaten
....wobei <benutzername> halt deiner ist sowie "Default", "Default User" und "All Users".

NUR die genannten Unterverzeichnisse, nicht nicht nicht C:\Users\<benutzername>\Anwendungsdaten"

junctions.zip auf sysinternals

Grüße
Biber

P.S. Wann ist denn eigentlich Windows 8 fertig? oder wie heisst die bugbereinigte Version?
[/Eigentlich OT]
Bitte warten ..
Mitglied: 76109
18.01.2011 um 19:50 Uhr
[Auch eigentlich OT]

Hallo Biber!

Zitat von Biber:
kann durchaus sein, dass du auch ohne (genau genommen ohne bewusstes) Kopieren diese Ordnerstruktur erzeugt hast.
Das Problem liegt nicht bei dir, sondern trifft wahrscheinlich alle Win7-User, zumindest die, die mit Robocopy ohne Schalter /XJD
(exclude junction directories) bzw. mit dem "alten" Robocopy /XJ (exclude junctions) arbeiten auf der "C:\USERS"-Ebene von Win7
Und auch die User, in denen ein Anwendungsprogramm etwas in den Unterordner "Anwendungsdaten" schreiben will.
OK, dass habe ich soweit verstanden und räume somit ein, dass ich unbewusst und ungwollt diese Ordnerstrukter erzeugt habe
Die Redmonder PraktikantInnen haben -so weit, wie Kidz halt denken können, wenn sie ein neues Spielzeug haben - im Verzeichnis
> C:\Users\<benutzername>\Anwendungsdaten
eine relative symbolische Verbindung namens (nicht lachen jezz')
"Anwendungsdaten" angelegt.
Die verpointert auf (jezz' kannste lachen!) "..\..\Anwendungsdaten"
Klingt schon recht lustig , ist einleuchtend und erklärt diesen sonderbaren Umstand.
Lade dir, falls nicht vorhanden, irgendwo die junctions.exe oder die Mklink.exe runter und zieh den Quark glatt.
Danke für den Hinweis! Hab's mir inzwischen runtergeladen und werde mich damit beschäftigen

Das ist bisher nur in
C:\Users\<benutzername>\Appdata\Local\Anwendungsdaten
und
C:\Users\<default>\Appdata\Local\Anwendungsdaten
aufgetreten und die beiden habe ich platt gemacht. Und diesen hier:
C:\Users\<benutzername>\Anwendungsdaten"
rühre ich natürlich nicht an

P.S. Wann ist denn eigentlich Windows 8 fertig? oder wie heisst die bugbereinigte Version?
Keine Ahnung, werde ich mir auch so schnell nicht zulegen. Muss sparen, habe mir gerade zu Weihnachten ein neues Auto geleistet

Danke für die ausführliche Information!

Gruß Dieter

[\Auch eigentlich OT]
Bitte warten ..
Mitglied: FRAD
19.01.2011 um 08:41 Uhr
Danke für die Hinweise... Ich war/bin ja nicht alleine ;)

Grüße
Bitte warten ..
Mitglied: Biber
19.01.2011 um 13:36 Uhr
Moin FRAD,

der Vollständigkeit halber, weil der Beitragsverlauf ja ein bisschen zerfasert ist...

? Hast du denn denn jetzt deine Bandwurm-Ordnerstruktur löschen können und wie?

Damit die nachfolgenden Win7-Fans Bescheid wissen...

Danke
Biber
Bitte warten ..
Mitglied: alexgame
24.01.2011 um 16:47 Uhr
Hi...

ich kann dir TreeSize Free empfehlen.
Ist Kostenlos und damit kannst du Pfade > 255 Zeichen löschen.

http://www.jam-software.de/treesize_free/

lg alex
Bitte warten ..
Mitglied: PCKenny
29.01.2011 um 13:47 Uhr
Irgendwie erinnere ich mich an so Endlosverzeichnisse (LOL) - probiere mal mit die Eingabeaufforderung (unter Win 7 als Admin ausführen) und dann, per CD F: auf F: wechseln und per

del "F:\Neuer Ordner\*.*"

alles darin zu löschen.

...sag mal bescheid ob es so geht

es grüßt

der Kenny
Bitte warten ..
Mitglied: FRAD
31.01.2011 um 11:23 Uhr
Hi,

werde ich heute Abend mal testen. Habe die Platte zur Zeit nicht dabei.

grüße
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Batch & Shell
gelöst Powershell: Dateien nach Version löschen in mehreren Ordnern (4)

Frage von ImmerKind zum Thema Batch & Shell ...

Exchange Server
gelöst SBS2011 - im Exchange mobile Geräte löschen (4)

Frage von MiSt zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (13)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...