Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OScommerce SSL einbinden

Frage Entwicklung Webentwicklung

Mitglied: JollyJumper83

JollyJumper83 (Level 1) - Jetzt verbinden

01.03.2009, aktualisiert 20:56 Uhr, 7357 Aufrufe, 1 Kommentar

Hallo lieber Forum,

ich habe meinen Shop soweit fertiggestellt. Läuft alles super und durchsteigen tue ich eigentlich auch. Zum Schluss ist mir das mit SSL noch eingefallen, was ich total vergessen hatte. Ich habe dann erstmal, da ich bei 1&1 Kunde bin, mein GoTrust Zertifikat für die Shopdomain beantragt und bestätigt bekommen. Jetzt wollte ich das alles einrichten und habe mich durchs Forum gelesen. Doch erstens ruft er die SSL Verbindung gar nicht auf wenn ich z.B. in den Kundenbereich gehe. Erst wenn ich selber https://... eingebe dann tut er das aber ohne mir ein Schloss im IE7 anzuzeigen. Zudem fragt er mich ob ich unsichere Elemente anzeigen möchte, wenn ich dort auf Nein klicke macht er die komplette Seite ohne Bilder, ohne Textformatierung, sogar das Trust Zertifikat wird nicht angezeigt. Kennt sich vieleicht einer mit dem GoTrust Zertifikat aus und kann mir evtl. sagen wie ich das einrichten muss. Im Forum von OScommerce finde ich leider kein Thread darüber. Vieleicht habe ich auch ein generelles Problem.
Ich habe im OS Shop lediglich die beiden Configure.php im Code:

define('ENABLE_SSL', true);

auf "true" gesetzt und nach Angaben von 1&1 da das nicht funktioniert hatte, im Root Verzeichnis meiner HP die .htaccess den Code

RewriteEngine On RewriteCond %{SERVER_PORT} !=443 RewriteRule ^(.*)$ https://ihre-webhosting-domain.de/$1 [R=301,L]

eingefügt. Ist das überhaupt ausreichend? (ihre-webhosting-domain.de - habe ich natürlich in meine Domain abgewandelt!)

Bitte um Hilfe.

Mit besten dank und freundlichen Grüßen
Simon
Mitglied: Kovold
01.03.2009 um 21:14 Uhr
Suche 'mal da: http://www.ecombase.de/ (Forum)

-.> Kovold
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Ubuntu
SSL Zertifikat für Webmin (2)

Frage von ClepToManix zum Thema Ubuntu ...

Outlook & Mail
Profile in Outlook 2013 via GPO einbinden (4)

Frage von fiffi1 zum Thema Outlook & Mail ...

Sonstige Systeme
SSL -Zertifikate für interne Webdienste (3)

Frage von JoHeAnDr zum Thema Sonstige Systeme ...

Heiß diskutierte Inhalte
Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (18)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...

Grafikkarten & Monitore
Neue Graifkkarte - kein Bild (10)

Frage von bestelitt zum Thema Grafikkarten & Monitore ...

Exchange Server
gelöst Exchange 2013 - Kontakte aus CSV importieren (9)

Frage von hesper zum Thema Exchange Server ...