Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OSPF-Redundanz über GRE-Tunnel

Frage Netzwerke Router & Routing

Mitglied: Kiaska

Kiaska (Level 1) - Jetzt verbinden

15.10.2009, aktualisiert 19:51 Uhr, 6469 Aufrufe, 5 Kommentare, 1 Danke

OSPF-Redundanz über LAN und GRE-Tunnel... was muss konfiguriert werden?

Hallo zusammen,

Zwischen zwei Routern sollen per OSPF Routen ausgetauscht werden. Zwecks Redundanz sind diese sowohl über eine Layer-2-Strecke als auch über das Internet mittels eines GRE-Tunnels verbunden. Allerdings kommt es beim Ausfall einer der Strecken zu erheblichen Problemen mit OSPF.

Die Router sind in einer NSSA-Area konfiguriert. Beide Router hängen an unterschiedlichen Switches, d.h. in Falle eines Problems zwischen diesen beiden Switches bleiben die entsprechenden Links auf den Routern, über welche diese sich direkt erreichen können, aktiv. Die Router haben zusätzlich zu dieser Layer-2-Verbindung noch jeweils eine Verbindung zum Internet, über welche sie einen GRE-Tunnel aufbauen. Über diesen Tunnel soll bei einem Ausfall der LAN-Verbindung OSPF weiter dafür sorgen, dass die üblichen Routinginformationen weiterhin übermittelt werden. Schön wäre es allerdings, wenn der Weg über die Layer-2-Strecke, falls vorhanden, präferiert wird.

Die Konfiguration sieht also (vereinfacht) so aus:

Router A:
01.
interface Tunnel100 
02.
 description GRE-Tunnel zu Router B 
03.
 bandwidth 100000 
04.
 ip address 10.0.1.1 255.255.255.252 
05.
 ip mtu 1476 
06.
 ip route-cache flow 
07.
 ip ospf cost 500 
08.
 tunnel source 10.0.5.1 
09.
 tunnel destination 10.0.6.2 
10.
 
11.
interface FastEthernet0/0 
12.
 no ip address 
13.
 ip address 192.168.0.1 255.255.255.248 
14.
 duplex full 
15.
 speed auto 
16.
 no snmp trap link-status 
17.
 no clns route-cache 
18.
 
19.
router ospf 100 
20.
 no log-adjacency-changes 
21.
 area 1 nssa 
22.
 redistribute connected subnets 
23.
 redistribute static subnets 
24.
 network 10.0.1.0 0.0.0.3 area 1 
25.
 network 192.168.0.0 0.0.0.7 area 1 
26.
 
27.
Router B: 
28.
interface Tunnel100 
29.
 description GRE-Tunnel zu Router A 
30.
 bandwidth 100000 
31.
 ip address 10.0.1.2 255.255.255.252 
32.
 ip mtu 1476 
33.
 ip route-cache flow 
34.
 ip ospf cost 500 
35.
 tunnel source 10.0.6.2 
36.
 tunnel destination 10.0.5.1 
37.
 
38.
interface FastEthernet0/0 
39.
 no ip address 
40.
 ip address 192.168.0.2 255.255.255.248 
41.
 duplex full 
42.
 speed auto 
43.
 no snmp trap link-status 
44.
 no clns route-cache 
45.
 
46.
router ospf 100 
47.
 no log-adjacency-changes 
48.
 area 1 nssa 
49.
 redistribute connected subnets 
50.
 redistribute static subnets 
51.
 network 10.0.1.0 0.0.0.3 area 1 
52.
 network 192.168.0.0 0.0.0.7 area 1
Fällt nun die Layer-2-Strecke aus und der Tunnel wir dann aktiviert, funktioniert soweit alles. Ist der Tunnel allerdings bereits vorher aktiv, bekommt scheinbar manchmal z.B. Router B von Router A zwar Routen per OSPF über den Tunnel, hat aber als ip next-hop immer noch die 192.168.0.1. Leider habe ich noch nicht viele Erfahrungen mit OSPF, denke aber da es grundsätzlich wie gewünscht funktioniert (mit wenigen manuellen Eingriffen), müsste eine automatische Lösung ebenfalls realisierbar sein. Meine wichtigsten Fragen wären:

Was muss konfiguriert werden damit der Tunnel wirklich nur im Notfalls genutzt wird?
Offenbar werden LSAs von Router B akzeptiert, obwohl er über das entsprechende Subnetz selbst keinen Neighbor mehr finden kann, woran liegt das?
Wieso macht es einen Unterschied ob der Tunnel vor dem Ausfall der Layer-2-Strecke aktiv war oder nicht?

Vielen Dank für die Hilfe!
Mitglied: aqui
15.10.2009 um 14:55 Uhr
Generell ist deine Konfig so richtig. Was allerdings etwas verwirrend ist, ist deine Cost Berechnung auf dem Tunnel Interface.
Per default wird die OSPF Cost mit 100.000.000 / Bandbreite in bps gemessen ist also invers proportional zur Bandbreite.
Das bedeutet primär wir der Bandbreitenwert zur Cost Kalkulation für das jeweilige Interface herangezogen wenn die Cost nicht statisch gesetzt ist.
Du machst es aber irgendwie doppelt gemoppelt indem du erst zwangsweise die Bandwith setzt um sie mit dem Cost Parameter dann wieder zu killen. Vermutlich bekommst du dadurch irgendwelche Probleme. Die Cost mit 500 also einer fiktiven 200 kBit Leitung anzugeben ist auch sehr konservativ oder hat deine Internet Anbindung nur ISDN NiveaU ??
Fazit: Bandwith Kommando vom Tunnel weglöschen und den Tunnel auf eine OSPF Cost von 50 setzen, was einer 2 Mbit Leitung entspricht und bei heutigen Geschw. eher realistisch ist.
Du kannst aber besser ganz auf ein Cost tuning verzichten, denn wenn du dir mit sh int tunn x mal die default Bandwith auf einem Tunnel Interface ansiehst:

7200test#sh int tunn 0
Tunnel0 is up, line protocol is up
Hardware is Tunnel
MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set.....

erkennst du selber das Cisco per default 9kbit annimmt. Damit erübrigt sich also jede Cost Fummelei auf dem Interface. Du solltest auch besser die Tunnel IP MTU auf ip mtu 1440 1440 Byte setzen denn mit deinem Wert kann es passieren das der GRE Encapsulation Overhead noch zu groß wird !

Damit sollte es eigentlich auf Anhieb klappen.
Ein paar Outputs ala show ospf neig oder sh ospf data wären hier auch etwas hilfreicher gewesen...
Bitte warten ..
Mitglied: Kiaska
27.10.2009 um 16:09 Uhr
Hallo,

Ich habe das Testszenario nochmal überarbeitet und wie empfohlen die Cost von dem Tunnel-Interface entfernt. Ich würde nun gerne ein Problem nach dem anderen lösen, das erste ist nun, dass alle Routen nun scheinbar über den Tunnel laufen und ich verstehe nicht warum. Hier meine Konfiguration inkl. einiger Outputs:

01.
Router A: 
02.
interface Loopback100 
03.
 description Loopback OSPF 
04.
 ip address 220.0.1.1 255.255.255.255 
05.
 
06.
interface Tunnel100 
07.
 description Tunnel zu RouterB 
08.
 bandwidth 100 
09.
 ip address 10.0.1.1 255.255.255.0 
10.
 ip mtu 1476 
11.
 tunnel source 192.168.0.1 
12.
 tunnel destination 192.168.1.1 
13.
 
14.
interface FastEthernet0/0 
15.
 description LAN zu RouterB 
16.
 ip address 10.0.0.1 255.255.255.0 
17.
 duplex full 
18.
 speed auto 
19.
 
20.
interface FastEthernet1/0 
21.
 description Uplink zu Transit 
22.
 ip address 192.168.0.1 255.255.255.0 
23.
 duplex full 
24.
 speed auto 
25.
 
26.
interface FastEthernet1/1 
27.
 description LAN zu Hosts 
28.
 ip address 200.0.0.1 255.255.255.0 
29.
 duplex full 
30.
 speed auto 
31.
 
32.
router ospf 100 
33.
 log-adjacency-changes 
34.
 area 1 nssa 
35.
 redistribute connected subnets 
36.
 redistribute static subnets 
37.
 network 10.0.0.0 0.0.0.255 area 1 
38.
 network 10.0.1.0 0.0.0.255 area 1 
39.
 
40.
ip classless 
41.
ip route 192.168.1.1 255.255.255.255 192.168.0.2 
42.
 
43.
RouterA#show ip ospf neighbor 
44.
 
45.
Neighbor ID     Pri   State           Dead Time   Address         Interface 
46.
220.0.0.1         0   FULL/  -        00:00:39    10.0.1.2        Tunnel100 
47.
220.0.0.1         1   FULL/BDR        00:00:38    10.0.0.2        FastEthernet0/ 
48.
49.
 
50.
RouterA#show ip ospf database 
51.
 
52.
            OSPF Router with ID (220.0.1.1) (Process ID 100) 
53.
 
54.
                Router Link States (Area 1) 
55.
 
56.
Link ID         ADV Router      Age         Seq#       Checksum Link count 
57.
220.0.0.1       220.0.0.1       136         0x80000011 0x001546 3 
58.
220.0.1.1       220.0.1.1       630         0x8000000E 0x00CB93 3 
59.
 
60.
                Net Link States (Area 1) 
61.
 
62.
Link ID         ADV Router      Age         Seq#       Checksum 
63.
10.0.0.1        220.0.1.1       635         0x80000001 0x0090FC 
64.
 
65.
                Type-7 AS External Link States (Area 1) 
66.
 
67.
Link ID         ADV Router      Age         Seq#       Checksum Tag 
68.
192.168.0.0     220.0.1.1       636         0x80000008 0x004CEE 0 
69.
192.168.0.1     220.0.0.1       79          0x80000009 0x0055E3 0 
70.
192.168.1.0     220.0.0.1       79          0x80000009 0x0054E4 0 
71.
192.168.1.1     220.0.1.1       636         0x80000008 0x003702 0 
72.
200.0.0.0       220.0.1.1       636         0x80000008 0x00CB10 0 
73.
200.0.1.0       220.0.0.1       79          0x80000009 0x00D306 0 
74.
220.0.0.1       220.0.0.1       79          0x80000009 0x00CFF5 0 
75.
220.0.1.1       220.0.1.1       637         0x80000008 0x00B114 0 
76.
 
77.
RouterA#show ip ospf interface 
78.
Tunnel100 is up, line protocol is up 
79.
  Internet Address 10.0.1.1/24, Area 1 
80.
  Process ID 100, Router ID 220.0.1.1, Network Type POINT_TO_POINT, Cost: 1000 
81.
  Transmit Delay is 1 sec, State POINT_TO_POINT, 
82.
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 
83.
    oob-resync timeout 40 
84.
    Hello due in 00:00:06 
85.
  Index 2/2, flood queue length 0 
86.
  Next 0x0(0)/0x0(0) 
87.
  Last flood scan length is 3, maximum is 5 
88.
  Last flood scan time is 0 msec, maximum is 4 msec 
89.
  Neighbor Count is 1, Adjacent neighbor count is 1 
90.
    Adjacent with neighbor 220.0.0.1 
91.
  Suppress hello for 0 neighbor(s) 
92.
FastEthernet0/0 is up, line protocol is up 
93.
  Internet Address 10.0.0.1/24, Area 1 
94.
  Process ID 100, Router ID 220.0.1.1, Network Type BROADCAST, Cost: 1 
95.
  Transmit Delay is 1 sec, State DR, Priority 1 
96.
  Designated Router (ID) 220.0.1.1, Interface address 10.0.0.1 
97.
  Backup Designated router (ID) 220.0.0.1, Interface address 10.0.0.2 
98.
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 
99.
    oob-resync timeout 40 
100.
    Hello due in 00:00:06 
101.
  Index 1/1, flood queue length 0 
102.
  Next 0x0(0)/0x0(0) 
103.
  Last flood scan length is 1, maximum is 5 
104.
  Last flood scan time is 0 msec, maximum is 4 msec 
105.
  Neighbor Count is 1, Adjacent neighbor count is 1 
106.
    Adjacent with neighbor 220.0.0.1  (Backup Designated Router) 
107.
  Suppress hello for 0 neighbor(s) 
108.
 
109.
RouterA#show ip route ospf 
110.
     220.0.0.0/32 is subnetted, 1 subnets 
111.
O N2    220.0.0.1 [110/20] via 10.0.1.2, 00:04:15, Tunnel100 
112.
O N2 200.0.1.0/24 [110/20] via 10.0.1.2, 00:04:15, Tunnel100 
113.
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks 
114.
O N2    192.168.1.0/24 [110/20] via 10.0.1.2, 00:04:15, Tunnel100 
115.
 
116.
Router B: 
117.
 
118.
interface Loopback100 
119.
 description Loopback OSPF 
120.
 ip address 220.0.0.1 255.255.255.2 
121.
 
122.
interface Tunnel100 
123.
 description Tunnel zu RouterA 
124.
 bandwidth 100 
125.
 ip address 10.0.1.2 255.255.255.0 
126.
 ip mtu 1476 
127.
 tunnel source 192.168.1.1 
128.
 tunnel destination 192.168.0.1 
129.
 
130.
interface FastEthernet0/0 
131.
 description LAN zu RouterA 
132.
 ip address 10.0.0.2 255.255.255.0 
133.
 duplex full 
134.
 speed auto 
135.
 
136.
interface FastEthernet1/0 
137.
 description Uplink zu Transit 
138.
 ip address 192.168.1.1 255.255.255.0 
139.
 duplex full 
140.
 speed auto 
141.
 
142.
interface FastEthernet1/1 
143.
 description LAN zu Hosts 
144.
 ip address 200.0.1.1 255.255.255.0 
145.
 duplex full 
146.
 speed auto 
147.
 
148.
router ospf 100 
149.
 log-adjacency-changes 
150.
 area 1 nssa 
151.
 redistribute connected subnets 
152.
 redistribute static subnets 
153.
 network 10.0.0.0 0.0.0.255 area 1 
154.
 network 10.0.1.0 0.0.0.255 area 1 
155.
 
156.
ip classless 
157.
ip route 192.168.0.1 255.255.255.255 192.168.1.2 
158.
 
159.
RouterB#show ip ospf neighbor 
160.
 
161.
Neighbor ID     Pri   State           Dead Time   Address         Interface 
162.
220.0.1.1         0   FULL/  -        00:00:20    10.0.1.1        Tunnel100 
163.
220.0.1.1         1   FULL/DR         00:00:20    10.0.0.1        FastEthernet0/ 
164.
165.
 
166.
RouterB#show ip ospf database 
167.
 
168.
            OSPF Router with ID (220.0.0.1) (Process ID 100) 
169.
 
170.
                Router Link States (Area 1) 
171.
 
172.
Link ID         ADV Router      Age         Seq#       Checksum Link count 
173.
220.0.0.1       220.0.0.1       343         0x80000011 0x001546 3 
174.
220.0.1.1       220.0.1.1       1446        0x8000000E 0x00CB93 3 
175.
 
176.
                Net Link States (Area 1) 
177.
 
178.
Link ID         ADV Router      Age         Seq#       Checksum 
179.
10.0.0.1        220.0.1.1       1457        0x80000001 0x0090FC 
180.
 
181.
                Type-7 AS External Link States (Area 1) 
182.
 
183.
Link ID         ADV Router      Age         Seq#       Checksum Tag 
184.
192.168.0.0     220.0.1.1       1457        0x80000008 0x004CEE 0 
185.
192.168.0.1     220.0.0.1       214         0x80000009 0x0055E3 0 
186.
192.168.1.0     220.0.0.1       214         0x80000009 0x0054E4 0 
187.
192.168.1.1     220.0.1.1       1457        0x80000008 0x003702 0 
188.
200.0.0.0       220.0.1.1       1457        0x80000008 0x00CB10 0 
189.
200.0.1.0       220.0.0.1       214         0x80000009 0x00D306 0 
190.
220.0.0.1       220.0.0.1       214         0x80000009 0x00CFF5 0 
191.
220.0.1.1       220.0.1.1       1458        0x80000008 0x00B114 0 
192.
 
193.
RouterB#show ip ospf interface 
194.
Tunnel100 is up, line protocol is up 
195.
  Internet Address 10.0.1.2/24, Area 1 
196.
  Process ID 100, Router ID 220.0.0.1, Network Type POINT_TO_POINT, Cost: 1000 
197.
  Transmit Delay is 1 sec, State POINT_TO_POINT, 
198.
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 
199.
    oob-resync timeout 40 
200.
    Hello due in 00:00:08 
201.
  Index 2/2, flood queue length 0 
202.
  Next 0x0(0)/0x0(0) 
203.
  Last flood scan length is 3, maximum is 6 
204.
  Last flood scan time is 0 msec, maximum is 4 msec 
205.
  Neighbor Count is 1, Adjacent neighbor count is 1 
206.
    Adjacent with neighbor 220.0.1.1 
207.
  Suppress hello for 0 neighbor(s) 
208.
FastEthernet0/0 is up, line protocol is up 
209.
  Internet Address 10.0.0.2/24, Area 1 
210.
  Process ID 100, Router ID 220.0.0.1, Network Type BROADCAST, Cost: 1 
211.
  Transmit Delay is 1 sec, State BDR, Priority 1 
212.
  Designated Router (ID) 220.0.1.1, Interface address 10.0.0.1 
213.
  Backup Designated router (ID) 220.0.0.1, Interface address 10.0.0.2 
214.
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 
215.
    oob-resync timeout 40 
216.
    Hello due in 00:00:01 
217.
  Index 1/1, flood queue length 0 
218.
  Next 0x0(0)/0x0(0) 
219.
  Last flood scan length is 3, maximum is 6 
220.
  Last flood scan time is 0 msec, maximum is 4 msec 
221.
  Neighbor Count is 1, Adjacent neighbor count is 1 
222.
    Adjacent with neighbor 220.0.1.1  (Designated Router) 
223.
  Suppress hello for 0 neighbor(s) 
224.
 
225.
RouterB#show ip route ospf 
226.
     220.0.1.0/32 is subnetted, 1 subnets 
227.
O N2    220.0.1.1 [110/20] via 10.0.1.1, 00:09:41, Tunnel100 
228.
O N2 200.0.0.0/24 [110/20] via 10.0.1.1, 00:09:41, Tunnel100 
229.
     192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks 
230.
O N2    192.168.0.0/24 [110/20] via 10.0.1.1, 00:09:41, Tunnel100
Bitte warten ..
Mitglied: Kiaska
28.10.2009 um 00:16 Uhr
Hallo nochmal,

das andere Problem habe ich nun offenbar lösen können. Ich habe übersehen das man bei OSPF keine Point-to-Point-Konfiguration (GRE-Tunnel) mit einer Broadcast-Konfiguration mischen darf. Es hat also genügt auf beiden Routern in den Tunnel-Interfaces ip ospf network broadcast zu konfigurieren. Danach sind auch die OSPF-Neighbor über die Tunnel-Interfaces im State FULL/DR bzw. FULL/BDR statt nur FULL/ -. Trotzdem habe ich immer noch das Problem das die Routen nicht wie gewünscht alle erstmal nur über das FastEthernet-Interface reinkommen. Die Cost scheint auch keinen Einfluss darauf zu nehmen. Wenn dazu noch jemand einen nützlichen Hinweis hätte wäre mir wirklich sehr geholfen
Bitte warten ..
Mitglied: aqui
29.10.2009 um 15:35 Uhr
Was heisst denn "Erstmal" ?? Die OSPF Updates kommen immer gleichzeitig an auf allen Interfaces wo OSPF aktiv ist !
Wichtig und relevant ist was in deiner Routing Tabelle steht (sh ip route) dort sollte die aktive Route mit einem * gekennzeichnet sein und das MUSS bei korrekter Cost Konfiguration (oder auch ganz ohne ohne, denn das Tunnel Interface hat IMMER eine geringere Cost !) immer das Ethernet Interface sein mit dem Tunnel als Backup !
Broadcast passt eigentlich auch nicht auf einem Tunnel Interface, denn ein Tunnel Interface ist IMMER ein Point to Point Interface !
Richtig wäre hier auf beiden Seiten eigentlich ein "ip ospf network point-to-point".

Nimm doch den Tunnel einseitig erstmal auf shutdown und checke ob die Updates üder das FA Interfaces sauber übertragen werden und die Routing Table korrekt aufgebaut wird !
Wenn das klappt machst du ein no shut auf dem Tunnel und prüfst die Routing Table.

Noch 2 Fragen zur Konfig:
1.) Öffentliche IP Adressen fürs Loopback Interface ?? Mmmmhhh
2.) Warum nimmst du als Tunnel Source und Destination nicht deine Loopback Adressen. So bist du unabhängiger vom physischen Zustand der Interface. Ist dein Interface down geht auch der Tunnel down !! Nimmt man Loopback IPs als Tunnel source und destination kann das nicht passieren !
Das 255.255.255.2 bei Router B ist wohl hoffentlich nur ein Cut and paste Fehler, oder ??
Bitte warten ..
Mitglied: Kiaska
06.12.2009 um 11:41 Uhr
Das "erstmal" war vielleicht schlecht formuliert. Die Sache mit den OSPF-Updates ist auch klar, was ich sagen wollte ist, die Routen die ich über OSPF empfangen hatten nicht alleine das Neighbor-Interface des anderen Routers via der FastEthernet-Strecke als Ziel, d.h. der Traffic wäre vermehrt weiter über den Tunnel geflossen (was ja nicht gewollt ist). Das ich diese Informationen nicht aus den Fingern gesaugt, sondern mit "sh ip route", "sh ip ospf route" und ähnlichen Befehlen erhalten habe, dass ist hoffentlich klar

Tunnel shutten und unshutten hatte ich schon ganz am Anfang probiert, das führte schon zu Problemen, da die Routing-Updates dann falsche LSAs erhalten haben. Ist aber nun auch alles gelöst, zunächst noch zu den Fragen:

1.) Ist nur ein Testszenario, war mir einfach gerade in den Kopf gekommen
2.) Ich will ja gar nicht verhindern dass der Tunnel down geht, warum sollte ich? Layer-3-Strecke weg, Tunnel weg. Wozu einen Backup-Tunnel aktiv halten, der nur bei Ausfall der Layer-2-Strecke was machen soll, wenn die Backup-Strecke selbst weg ist?

Und ja, die Subnetmask ist natürlich nur ein Fehler beim Konfig kopieren, da würde der Router würde da eh direkt schreien ;)

Jedenfalls, als Lösung habe ich die Interfaces beide auf "point-to-multipoint" umgestellt. Nach meinen Recherchen hinsichtlich diesen Themas bin ich darauf gestoßen das "point-to-multipoint" als einzige Konfiguration die Möglichkeit gibt einem Neighbor sozusagen direkt eine Cost zuzuweisen. Zudem wird keine LSA-DB aufgebaut, die Verbindungen werden als Punkt-zu-Punkt bewertet. D.h. beide Neighbor-Adresse, sowohl über den Tunnel als auch über das FE-Interface sind nun im Status "FULL/ -", primär wird nun immer das FE-Interface genutzt, fällt dieses aus dann ist der entsprechende Neighbor weg (d.h. es gibt auch keine falschen LSAs über das jeweils andere Interface), der Traffic fliesst über den Tunnel. Damit dies zeitnah passiert habe ich noch die OSPF-Timer runtergesetzt ("ip ospf hello-interval 10").

Es mag durchaus sein das andere Konfigurationen ebenfalls funktionieren würden, diese tut es jedenfalls auch
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Firewall
gelöst Gibt es ein fertiges Web-Tunnel-Gateway? (27)

Frage von StefanKittel zum Thema Firewall ...

Router & Routing
Tunnel VPN to VPN (8)

Frage von itschloegl zum Thema Router & Routing ...

Hyper-V
gelöst Hardware und Lizenzfrage: Hyper-V Umgebung um Redundanz erweitern (10)

Frage von Knorkator zum Thema Hyper-V ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...