Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Osticket und MySQL...probleme mit der Verbindung

Frage Entwicklung PHP

Mitglied: gabeBU

gabeBU (Level 1) - Jetzt verbinden

11.06.2012 um 16:23 Uhr, 7386 Aufrufe, 7 Kommentare

Hallo Zusammen

Ich bin gerade dabei, auf meinem PC das Ticketsystem OSTicket einzurichten. Das System läuft wie XAMPP sowie auch die MySQL-Datenbank. Ich habe für das Programm auch eine Datenbank angelegt und ein Benutzer eingerichtet, sowie auch ein Passwort (OSTicket verlangt ein Passwort). Wenn ich nun die Daten eingebe, dann kommt die Meldung, dass die Verbindung mit der Datenbank nicht möglich sei. Wenn ich das Passwort weglasse, kommt aber, dass ein Passwort notwendig ist und die Verbindung somit eigentlich möglich sein müsste...

Was genau habe ich vergessen?

An das OSTicket-Forum habe ich mich schon gewendet, habe aber noch keine Antwort erhalten.

Gruss

gabeBU
Mitglied: Arano
11.06.2012 um 16:34 Uhr
Hallo gabeBU

kannst du dich den lokal über die Command-Line in MySQL einloggen ?
Also überprüfen ob du überhaupt das richtige Passwort verwendest...

Dieses schon einmal ausprobiert ? osticket.com - Self-Help_Troubleshooting
Dann spuckt die PHP möglicherweise die genaue Fehlermeldung aus... ggf steht diese aber auch in dem Apache-Logfiles.


~Arano
Bitte warten ..
Mitglied: gabeBU
11.06.2012, aktualisiert 16.06.2012
Danke für deine Antwort. Nein leider spuckt auch dann PHP die genauere Fehlermeldung nicht aus. Auch in den Apache-Logfiles steht nichts.

Ich bin noch nicht so versiert mit mysql. Es könnte auch sein, dass ich etwas falsch eingegeben habe.

Das habe ich eingegeben

01.
create database domainnameticket 
02.
create user osticket 
03.
update user set password=PASSWORD("123") where User='osticket';
und dann habe ich versucht es zu starten.

Ich komme auch mit der Kommandozeile in das System mit dem Benutzer...
Bitte warten ..
Mitglied: Arano
11.06.2012 um 17:59 Uhr
Hi,

Das du dich über die Kommandozeile einloggen kannst ist ja schon mal gut !
Das nichts in den Logs steht ist schade...

Aber wozu gibt es den Holzhammer !
Öffne mal die Datei:
/include/mysql.php
und entferne in der Zeile 26 das "@" Zeichen (NUR das @-Zeichen, das unterdrücken nämlich die Ausgabe der Fehlermeldung)
JETZT sollten dir beim anschließendem aufrufen auch eine Fehlermeldungen angezeigt werden - vorausgesetzt, der Fehler liegt auch hier ;)


Hoffe wir kommen jetzt voran.
~Arano
Bitte warten ..
Mitglied: gabeBU
12.06.2012, aktualisiert 16.06.2012
"@$$dblink =mysql_connect($dbhost, $dbuser, $dbpass);" ?? Auf der 26. Zeile hat es bei mir kein "@"-Zeichen, aber das wäre das nächste...ich probiers mal aus

und jaaa :D es hat geklappt hier die Fehlermeldung:

01.
Warning: mysql_connect() [function.mysql-connect]: php_network_getaddresses: getaddrinfo failed: Der angegebene Host ist unbekannt. in C:\xampp\htdocs\include\mysql.php on line 26 
02.
 
03.
Warning: mysql_connect() [function.mysql-connect]: [2002] php_network_getaddresses: getaddrinfo failed: Der angegebene Hos (trying to connect via tcp://%:3306) in C:\xampp\htdocs\include\mysql.php on line 26 
04.
 
05.
Warning: mysql_connect() [function.mysql-connect]: php_network_getaddresses: getaddrinfo failed: Der angegebene Host ist unbekannt. in C:\xampp\htdocs\include\mysql.php on line 26
EDIT masterG, 16.06.2012 09:41: Auch wenns nur Fehlermeldungen sind, schaut doch schöner in einem Codeblock aus ;)^^
Bitte warten ..
Mitglied: Arano
12.06.2012 um 12:29 Uhr
Hi

ja genau diese Zeile meinte ich !

Hm... diese Fehlermeldung ist mir noch nicht untergekommen. hört sich aber so an, als könne PHP die angegebene DB-Server-Adresse nicht auflösen bzw. findet ihn nicht.

Was hast du denn als MySQL-Host angegeben ?
Probier es mal mit
  • 127.0.0.1 oder
  • localhost


Gruß
~Arano (via Handy)
Bitte warten ..
Mitglied: gabeBU
12.06.2012 um 13:44 Uhr
Ist gut, ich habe es geschafft...musste einfach nur in das Administrator-Konto wechseln...nun ist es einfach so, dass die Menübuttons nicht richtig funtkionieren und überall diese Meldungen erscheinen:

Notice: Undefined index: active in C:\xampp\htdocs\include\staff\header.inc.php on line 48
href="kb.php" title="Knowledge Base: Premade">Knowledge Base
Directory
Bitte warten ..
Mitglied: Arano
12.06.2012, aktualisiert um 20:16 Uhr
Nabend

...musste einfach nur in das Administrator-Konto wechseln...
Welches, das von OSTicket oder das von Windows ?
(Lief der MySQL-Server etwa nicht, oder was ?)

Das ist eine Notiz die über eine mögliche Fehlerquelle informieren soll um so unvorhergesehenem Verhalten vorzubeugen - oder so !
...jetzt fällt mir kein Passendes Beispiel für eine genauere Erklärung ein...

Nunja, ich vermute aber mal weiter das diese Notiz, besser gesagt, __die Ausgabe dieser Notiz__ den Quelltext der Seite verunstaltet was zu der Störung des Menüs führt. Ich denke das, wenn du dir den ausgegebenen Quelltext der Seite anschaust, die Notiz mitten in den Menü-Links steht (Darum wird auch ein Teil des Link-Quelltextes angezeigt). Das führt in deinem Browser zu Interpretationsfehler und schlussendlich zum nicht funktionieren der Links.

Das kannst du nun beheben in dem du den Quelltext von OSTicket umschreibst *fg*
Oder du einfach den "Fehlerlevel" von PHP reduzierst. Dies geht in der php.ini über die Direktive error_reporting oder über die gleichnamige PHP-Funktion php.net - error_reporting


Nicht vergessen das "@" wieder in der Zeile aus "/include/mysql.php" einzufügen !
Hässliche Fehlermeldungen will und SOLL keiner sehen ;)


~Arano
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows 10
gelöst VPN Verbindung Probleme (7)

Frage von Yeter2 zum Thema Windows 10 ...

Windows Server
Probleme bei der Verbindung zu einem Terminalserver 2012R2 (1)

Frage von takvorian zum Thema Windows Server ...

Windows Server
gelöst Probleme bei der Herstellung einer RemoteApp-Verbindung (7)

Frage von raba34 zum Thema Windows Server ...

Peripheriegeräte
gelöst APC Back UPS PRO USV 1200VA, Probleme bei der Verbindung zum Mac und PC (15)

Frage von IFNNTNF zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...