Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

OTRS empfängt keine Mails mehr automatisch

Frage Linux Linux Tools

Mitglied: NuitShuHeru

NuitShuHeru (Level 1) - Jetzt verbinden

04.03.2010 um 11:16 Uhr, 12545 Aufrufe, 2 Kommentare

Hallo liebe Gemeinde, vielleicht gibt es hier ja auch jemanden der sich mit dem Open Source CRM System OTRS auskennt.

Unser OTRS läuft auf einem Linux (Debian) Webserver und hat seit dem letzten Update eine kleine Macke. Leider muss ich eingestehen, dass ich das System nicht aufgesetzt habe und auch nicht allzu sehr mit dem Produkt auskenne.

Hier nun die Problematik:

Für die Ticket-Erstellung in den verschiedenen Queues sind insgesamt 6 Mailadressen hinterlegt, welche via POP3 abgerufen werden und über welche auch die Mails aus dem CRM System heraus versand werden. Wenn in den POP3 Fächern Mails vorhanden sind, werden die Betreffzeilen der Mails geprüft und diese dann entweder den in der Betreffzeile aufgeführten Ticketnummer zuegordnet oder als ein neues Ticket abgelegt.

Das funktionierte bis zum letzen Update auch alles reibungslos, das System hat alle paar minuten die POP3 Postfächer geprüft und die Mails abgeholt.
Seit dem Update funktioniert diese automatisierte Abholung leider nicht mehr. Sie wird augenscheinlich überhaupt nicht mehr angestoßen, da es in den Postmaster Logs keinerlei Einträge für einen Abruf mehr gibt. Der Versand aus dem OTRS heraus funktioniert aber nach wie vor.

In den Einstellungen für die Postmaster Mailaccounts gibt es für die Einstellungsüberprüfung die Option, den Abruf manuell zu testen (also die gesamte Mailprozedur für die entsprechende Mailadresse einmal durchlaufen zu lassen).
Das funktioniert auch reibungslos und im Postmaster Log kommen dann auch brav die Einträge für die abgerufenen Mails. Auch die Zuordnung der Tickets funktioniert so reibungslos.

Meine Vermutung ist, da das Update einige Einstellungen in anderen Bereichen (z.B. Syntax der Ticketnummern) auf die Default Werte zurück gesetzt hat, dass auch die Einstellungen für das Abrufintervall der Postmaster Mailaccounts geändert/zurückgesetzt/überschrieben wurde. Ich hab jetzt alle Parameterenstellungen aller Bereiche in der Sysconfig durchforstet (ca 1500 Stück), konnte aber keine entsprechende Einstellung finden.

Weiss vielleicht jemand welche Einstellungen für den automatsierten Abruf zuständig sind und wo ich diese finde ?

Vielen Dank schon einmal im Vorraus.

Gruß
-Nuit-
Mitglied: nautilus99
05.07.2010 um 09:30 Uhr
Zitat von NuitShuHeru:
Unser OTRS läuft auf einem Linux (Debian) Webserver und hat seit dem letzten Update eine kleine Macke. Leider muss ich
eingestehen, dass ich das System nicht aufgesetzt habe und auch nicht allzu sehr mit dem Produkt auskenne.

Hier nun die Problematik:

Für die Ticket-Erstellung in den verschiedenen Queues sind insgesamt 6 Mailadressen hinterlegt, welche via POP3 abgerufen
werden und über welche auch die Mails aus dem CRM System heraus versand werden. Wenn in den POP3 Fächern Mails vorhanden
sind, werden die Betreffzeilen der Mails geprüft und diese dann entweder den in der Betreffzeile aufgeführten
Ticketnummer zuegordnet oder als ein neues Ticket abgelegt.

Das funktionierte bis zum letzen Update auch alles reibungslos, das System hat alle paar minuten die POP3 Postfächer
geprüft und die Mails abgeholt.
Seit dem Update funktioniert diese automatisierte Abholung leider nicht mehr. Sie wird augenscheinlich überhaupt nicht mehr
angestoßen, da es in den Postmaster Logs keinerlei Einträge für einen Abruf mehr gibt. Der Versand aus dem OTRS
heraus funktioniert aber nach wie vor.

In den Einstellungen für die Postmaster Mailaccounts gibt es für die Einstellungsüberprüfung die Option, den
Abruf manuell zu testen (also die gesamte Mailprozedur für die entsprechende Mailadresse einmal durchlaufen zu lassen).
Das funktioniert auch reibungslos und im Postmaster Log kommen dann auch brav die Einträge für die abgerufenen Mails.
Auch die Zuordnung der Tickets funktioniert so reibungslos.

Meine Vermutung ist, da das Update einige Einstellungen in anderen Bereichen (z.B. Syntax der Ticketnummern) auf die Default Werte
zurück gesetzt hat, dass auch die Einstellungen für das Abrufintervall der Postmaster Mailaccounts
geändert/zurückgesetzt/überschrieben wurde. Ich hab jetzt alle Parameterenstellungen aller Bereiche in der
Sysconfig durchforstet (ca 1500 Stück), konnte aber keine entsprechende Einstellung finden.

Weiss vielleicht jemand welche Einstellungen für den automatsierten Abruf zuständig sind und wo ich diese finde ?

Vielen Dank schon einmal im Vorraus.

Gruß
-Nuit-
Hallo -Nuit,
falls noch ein Problem
ich hatte das gleiche Problem unter Solaris 11, OTRS2.4.7.
Hiier musste ich die Crontab anpassen.
Syntac steht in /opt/otrs/var/cron/postmaster_mailbox.dist-
Unabhängig davon: bitte mal Versionen mitteilen.
Bitte warten ..
Mitglied: NuitShuHeru
05.07.2010 um 11:14 Uhr
Hallo,

und danke für die Antwort.

Ich hab es bis jetzt ähnlich gelöst, und hab manuell einen neuen Cronjob erstellt, welcher nun den Mailabruf steuert. Ich bin mir ziemlich sicher, das das OTRS seine eigenen Jobs dafür hat und diese nun halt nicht mehr laufen, woran auch immer das liegt.

Die Probleme trat nach dem Update auf die Version 2.4.7 auf. Zusammen mit diversen anderen Bugs.

z.B. hat sich das HTML-Mailinterface mit diesem Update zugeschaltet, ich find auch keine Einstellungen das wieder abzuschalten. Das neue Mailformat hat sämtliche vorherigen Einstellungen für die Antwortmails zerschossen und die automatisch vorgeblendeten Textsegmente sind nun bunt mit den Signaturen und Mailzitaten durcheinander gewürfelt. Auch hier lässt sich in der Konsole des OTRS keine Einstellungsoption finden das anzupassen.

Gruß
-Nuit-
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
gelöst Outlook 2016 - Keine Mails sichtbar (nach Suche schon) (19)

Frage von Hirschix3 zum Thema Microsoft Office ...

E-Mail
gelöst Nach Opt-Out keine Massenmails oder gar keine Mails mehr? (27)

Frage von MegaGiga zum Thema E-Mail ...

Microsoft Office
gelöst Outlook 2013 Clients können im Cachemodus keine Mails senden (Exchange2010 - SBS2011) (1)

Frage von WeeWeeWee zum Thema Microsoft Office ...

Exchange Server
Mails mit "SPAM" im Betreff automatisch in Junk-Ordner verschieben (8)

Frage von BleppSatter zum Thema Exchange Server ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (50)

Frage von sabines zum Thema Internet ...

Netzwerke
LAN2LAN Verbindung sehr langsam flaschenhals gesucht (27)

Frage von PixL86 zum Thema Netzwerke ...

Router & Routing
PFsense - Netzverbindung steht, aber kein Internet vorhanden (24)

Frage von aschmid zum Thema Router & Routing ...

Windows Server
gelöst Windows 2016 Hyper-V und VHDS (19)

Frage von emeriks zum Thema Windows Server ...