Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Outlook 2010 mit Exchange 2013 verbinden ohne offizielle CA

Frage Microsoft Exchange Server

Mitglied: Androxin

Androxin (Level 2) - Jetzt verbinden

31.07.2013 um 10:54 Uhr, 3908 Aufrufe, 13 Kommentare

Hallo Profis,

ich habe einen funktionierenden Exchange 2013 Test-Server und möchte nun Outlook 2010 dahin verbinden.

Allerdings scheitert es an der folgenden Fehlermeldung:
Die Verbindung mit dem Microsoft Exchange Server ist nicht verfügbar. Outlook muss im Onlinemodus oder verbunden sein, um diesen Vorgang auszuführen.
Die Test-Umgebung:
- Exchange 2013
- Windows Server 2012 Datacenter
- Zertifizierungsstellenrolle läuft auf eigenem DC -> Zertifikat für Exchange daher bezogen

Folgendes habe ich schon probiert:
- Microsoft Remote Connectivity Analyzer bemängelt die CA. Ohne Vertrauensprüfung des Zertifikats funktioniert Autodiscover.
- Browser meckern beim Zugriff auf OWA über die CA, eigentlicher Zugriff aber problemlos möglich
- Stammzertifikat und das "Client"-Zertifikat des Servers wurde auf Client (Win 8) installiert
- Workaround "E-Mail Einstellungen suchen lassen, nach Abbruch zurück und manuell eingeben" hilft nicht
- Verwendung der HTTPS-Proxy Einstellung im Outlook-Konto hilft ebenfalls nicht


Was könnte man noch ausprobieren? Bzw: Hat jemand eine Idee, woran es noch hapern könnte?
Gibt es eine Möglichkeit Outlook auch ohne die manuelle Installation der Zertifikate zu benutzen?
Mitglied: Booyah
31.07.2013 um 12:50 Uhr
Hi,

kommt drauf an. Du könntetst auch Nicht-SSL-Verbindungen zulassen, aber das ist ja grob fahrlässig und nicht anzuraten! Hast du ein Active Directory, kannst du dein Zertifikat ja auch per GPO ausrollen. Hast die diverse Stand-Alone-Clients, kommst du ums händische Installieren deiner selfsigned-Zertifikate nicht herum.
Bitte warten ..
Mitglied: Androxin
31.07.2013 um 12:53 Uhr
Zitat von Booyah:
Hast die diverse Stand-Alone-Clients, kommst du ums händische Installieren deiner selfsigned-Zertifikate nicht herum.

Das heißt, dass ich die Zertifikate tatsächlich auf ALLEN Geräten installieren muss, die in irgendeiner Form Exchange nutzen? Vom iPhone, übers Android Tablet bis zum normalen Outlook 2010-Workstation?
Bitte warten ..
Mitglied: Dani
31.07.2013 um 13:09 Uhr
Zitat von Androxin:
Das heißt, dass ich die Zertifikate tatsächlich auf ALLEN Geräten installieren muss, die in irgendeiner Form
Exchange nutzen? Vom iPhone, übers Android Tablet bis zum normalen Outlook 2010-Workstation?
Natürlich.... denn dein Zertifikat ist ja Selbstausgestellt und wir somit von keinen Stammzertifizierungsstellen erkennt und somit als gültig markiert.
Darum inverstieren viele Firmen einfach die 50-100€ im Jahr und sparen sich den Aufwand der Admins.

Grüße,
Dani
Bitte warten ..
Mitglied: Androxin
31.07.2013 um 13:17 Uhr
Ich hatte jetzt gehofft, dass in Outlook einfach hinterlegen kann, dass es Zertifikaten von einer bestimmten Zertifizierungsstelle automatisch vertraut
Bitte warten ..
Mitglied: Dani
31.07.2013 um 13:20 Uhr
Deine Clients in Domäne sollte den Zertifikat eigentlich vertrauen, da das Stammzertifikat der CA automatisch ausgerollt wird. Für alle anderen Geräte musst du Hand anlegen.


Grüße,
Dani
Bitte warten ..
Mitglied: Androxin
31.07.2013 um 13:26 Uhr
Das wollte ich nicht hören


Aber zurück zur eigentlichen Frage:
Auf besagter Workstation habe ich die Zertifikate installiert, Outlook zickt trotzdem mit dieser nichtssagenden Fehlermeldung rum.

An welcher Stelle drohen einem da Stolpersteine?
Bitte warten ..
Mitglied: Dani
31.07.2013 um 13:28 Uhr
Ist die Workstation in der Domäne oder nicht?
Du hast sicher das Zertifikat deiner CA installiert und nicht das vom Exchange?!


Grüße,
Dani
Bitte warten ..
Mitglied: Androxin
31.07.2013 um 13:32 Uhr
Zitat von Dani:
Ist die Workstation in der Domäne oder nicht?
Die Workstation ist nicht in der Domäne. Das ist ein "Homeoffice".

Du hast sicher das Zertifikat deiner CA installiert und nicht das vom Exchange?!
Ich habe das CA Zertifikat (Aus dem Webinterface der Zertifizierungsstelle runtergeladen) in den Speicher für vertrauenswürdiger Stammzertifizierungsstellen installiert.
Bitte warten ..
Mitglied: Dani
31.07.2013 um 13:34 Uhr
Das hört sich nicht schlecht an...
Bekommst du einen Zertifiaktsfehler wenn du die OWA-Seite aufrufst?


Grüße,
Dani
Bitte warten ..
Mitglied: Androxin
31.07.2013, aktualisiert um 13:36 Uhr
Ja, die Browser werfen einen Fehler:
"Herausgeber unbekannt, bla..."

D.h., dass es garnichts mit Outlook zu tun hat..
Bitte warten ..
Mitglied: Dani
31.07.2013 um 13:37 Uhr
Bitte mit Internet Explorer testen, da Firefox und Co einen eigenen Zertifiaktsspeicher haben und auf den von Windows nicht zurückgreifen.
Was siehst du wenn du dir die Zertifikatseigenschaften anzeigen lässt? Stimmen die Zertifikatsdaten überein?


Grüße,
Dani
Bitte warten ..
Mitglied: Androxin
31.07.2013 um 18:56 Uhr
Und wieder einmal hat ein freundlicher Stups in die richtige Richtung zur Problemlösung geführt.

Der IIS hat, warum auch immer, ein falsches Zertifikat ausgeliefert, obwohl das richtige in Exchange und den IIS Bindings hinterlegt war.
Ich habe jetzt alle überflüssigen Zertifikate vom Server gelöscht, den IIS neu gestartet und alles war gut.
Bitte warten ..
Mitglied: Dani
31.07.2013 um 23:05 Uhr
IIS und Exchange waren und sind zwei paar Schuhe...
Schönen Abend!


Grüße,
Dani
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...