Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Outlook-Problem im Zusammenhang mit VPN und Exchange (zum Zähne ausbeissen)

Frage Microsoft Exchange Server

Mitglied: diobosco

diobosco (Level 1) - Jetzt verbinden

05.05.2005, aktualisiert 11.11.2005, 16949 Aufrufe, 11 Kommentare

Ich habe ein ätzendes Problem, bei dem mir schon 3 sogenannte "MS-Exchange-Spezialisten" gesagt haben, dass das Problem nicht lösbar sei.

Mein Problem ist, dass ich mit meinem Outlook-Client über VPN keine Emails senden und empfangen kann. Im Büro (ohne VPN) läuft das senden und empfangen von Emails über den Small Business Server einwandfrei.

Bin ich aber nicht im Büro (z.B. DSL-Zugang von zu hause oder WLAN-Hotspots) kann ich keine emails empfangen oder senden. Das Starten des VPN ist noch problemlos (ich kann auf alle Directories, Files und Drucker auf dem Server über VPN zugreifen. Starte ich aber den Outlook-Client, kann sich der Outlook-Client nicht beim SBS-Server anmelden.

Wenn ich dann versuche, im Outlook über den Senden/Empfang-Button das senden zu "erzwingen", kommt die Fehlermeldung: "Fehler (0x8004011D) beim Ausführen der Aufgabe "Microsoft Exchange Server": Der Server steht nicht zur Verfügung. Falls dieser Zustand fortbesteht, wenden Sie sich bitte an den Administrator:" Das Irre an der Sache ist, dass es ca. 1 bis 2 mal an 20 Tagen geht, die allermeiste Zeit aber nicht. Über OWA funktioniert aber alles einwandfrei.

Die sog. Spezialisten erzählen mir, dass VPN so unsicher wäre und bei langsamen Verbindungen das Ganze instabil wäre. Ich glaube das aber nicht (da machts sich einer zu einfach), da der Zugriff auf Server-Files IMMER funktioniert.

Ich habe das Problem schon seit 8 Monaten, verliere langsam aber sicher meine Haare und bin mittlerweile deswegen schon in therapeutischer Behandlung

Bitte helft mir!

Gruss
Bernd
Mitglied: 12217
05.05.2005 um 17:11 Uhr
Hi
ab Exchange 2003 kann mittels HTTPS auf den Server zugegriffen werden. Dies sollte das Problem lösen. Allerdings muss dann auch Outlook 2003 eingesetzt werden.
Bitte warten ..
Mitglied: diobosco
05.05.2005 um 17:24 Uhr
Ich habe Outloo 2003 im Einsatz. Danke für Deine Antwort, mich würde aber interesieren, wo das Problem meiner aktuellen Konfiguration liegt. Vielleicht sollte ich noch erwähnen, dass wir einen DNS-Service von no-ip.com benutze, um das problem von nicht vorhandenen statischen IP's zu umgehen. Bevor die Experten aber "reflexartig" die Hände in die Luft werfen, sei hier noch ausdrücklich gesagt, dass sowohl der File-zugriff über VPN als auch das OWA einwandfrei funktieren, nur eben das Zusammenspiel zwischen Outlook-Client, VPN und SBS nicht.
Bitte warten ..
Mitglied: 12217
05.05.2005 um 17:34 Uhr
Für eine genaue Diagnose wäre das Ereignisprotokoll des Servers eine große Unterstützung, falls zu darauf Uugriff haben solltest. Fehlerhinweise können bequem über eventid.net ermittelt werden.

Ein Tip in einer Newsgroup war das Caching von Outlook zu deaktivieren. Aber da wäre ich mir nicht ganz so sicher.

Viel Erfolg.
Bitte warten ..
Mitglied: pc-pure
05.05.2005 um 19:34 Uhr
Hallo,

VPN über RRAS auf den Server? Oder eine VPN-Verbindung auf einen Router?
VPN-Client von MS oder ein anderer?
Bitte warten ..
Mitglied: diobosco
05.05.2005 um 19:58 Uhr
PPTP-VPN von MS. VPN-Verbindung geht auf einen Router
Bitte warten ..
Mitglied: Tom2604
05.05.2005 um 19:59 Uhr
Schau dir mal die Seite AN!!!!
http://www.zdv.uni-mainz.de/2398.php
Bitte warten ..
Mitglied: pc-pure
05.05.2005 um 20:19 Uhr
@Bernd:

Ich hoffe mal, dass du einen DNS-Server und vielleicht auch noch einen WINS-Server laufen hast (in der regel bei SBS-Netzen identisch). Trage diese beim MS-Client ein.

Wenn es ein Hardwäre Router, wie z.B. einer von DrayTek ist, nimm aus dem MS-VPN-Client die Anmeldedomäne raus. Exchange fragt dich schon nache einem Benutzernamen, und Passort für die Übertragung. Dann bitte nicht übersehen: Benutzernamen in dieser Schreibweise eingeben: Domäne\Benutzer

Bitte überprüfe, ob dein Exchange-Server unter den Kontoeinstellungen mit dem FQDN eingetragen ist (also nicht xxx-srv, sondern z.B.: xxx-srv.domainname.local).

Starte Outlokk erst, wenn die VPN-Verbindung etabliert ist

Solltest du der einzige User sein, der VPN-Zugriffe macht, wäre unter Umständen bei Einsatz eines guten Security Gateways zu überlegen, ob du nicht die VPN-Verbindung per RRAS auf den SBS direkt abwickelst. Dann gibbet absolut nichts was deinen Mailgenuss stört.

@ Thomas:
DIese Einstellungen haben mit VPN-Access absolut nichts zu tun.
Bitte warten ..
Mitglied: diobosco
06.05.2005 um 12:11 Uhr
Hallo Zusammen

Nach zwei telefonischen Sessions gestern (1,5 Stunden) und heute (2 Stunden) hat pc-pure (Christian) mein Problem gefixt. Im Wesentlichen hat es damit zu tun, dass ein "Server-Experte" (MSCE!) beim Aufsetzen unseres Servers die Endung .NET verwendet hat, was zu DNS-Auflösungsproblemen geführt hat. Ein riesiges Dankeschön an Dich für die Lösung und Deinen Rieseneinsatz Christian, das war hervorragende Arbeit! Ich ziehe meinen Hut vor Dir.

Bitte erlaubt mir, für Christian (aus vollem Herzen) noch den Werbeblock zu schalten! Wenn Ihr ein kniffliges (oder auch kleines) Problem mit Netzwerken, Exhange, etc. habt, kontaktiert pc-pure (www.pc-pure.com) und Christian wird Euch helfen (ich hoffe für ihn, gegen eine kleine Gebühr - er ist es wert!)!

Vielen Dank
Bernd

P.S. Christian, falls Du meinst, die Forumteilnehmer sollten aus meinem Problem inhaltlich was mitnehmen können, erkläre Du bitte dem Forum das Problem / Lösung, mir war es zu hoch.
Bitte warten ..
Mitglied: pc-pure
06.05.2005 um 15:31 Uhr
Hallo,

für alle, die ein ähnliches Problem haben oder hatten, eine kurze Erklärung zum Problem von Bernd:

Konstellation:

- 1 Server (DC, DNS-Server, DHCP-Server, Exchangeserver, RRAS-Server(über PPTP-VPN)): yyy-srv
- mehrere Notebookclients
- Einwahl über MS-VPN-Client (ab Win2000 über Netzwerkverbindungen, neue Verbindung erstellen konfigurierbar) auf o.a. Server.
- Internet und email-Domäne: xxx.ch
- Lokale Domäne wird von MS bei der Installation mit xxx.local vorgeschlagen, wurde aber bei der Installation als xxx.net vergeben (diese Domäne existiert sogar, gehört einem deutschen Systemhaus, nicht der Firma mit dem Problem).

Problem:

Da durch die Vergabe einer .net-Domäne im lokalen Netz ein DNS-Suffix namens xxx.net kreiert wurde, wurde der Exchange-Server yyy-srv (FQDN: yyy.srv.xxx.net) von Haus aus im externen Netz gesucht (Ping auf die Adresse gab den Response eines grossen deutschen Hosting-Anbieters).

Das Problem tritt aber nur auf, wenn xxx.net nicht intern gehostet wird. D. h. wenn die Domain im Intranet gehostet würde und man eine feste IP-Adresse hätte gäbe es keine Probleme.

Ebenso keine Probleme dürfte es geben, wenn man sich auf einem Router mit VPN-Server-Funktion (z.B. DrayTek Vigor 2600/2900-Series) einloggt und den Server yyy-srv als DNS- und WINS-Server einträgt.

Um jetzt die Weiterleitung der Outloox-Exchange-Anfrage ins Extranet zu unterbinden, haben wir in den EInstellungen des MS-VPN Clients den Server als DNS und WINS-Server eingetragen und in der Registerkarte Netzwerk, unter den erweiterten Eigenschaften des TCP/IP-Protokolls auf der Registerkarte Allgemein das Kästchen bei "Standardgateway für das Remotegateway aktivieren" aktiviert. Somit läuft die DNS-Auflösung nicht über die root-server oder die DNS-Server des ISP (Eintrag im Router), sondern über den Forward-Lookup des Servers yyy-srv über die interne LAN-Schnittstelle.

Nichts desto trotz ist das jetzt nur Gebastel.

Wäre der Server richtig aufgesetzt worden (lokale Domäne z.B. xxx.local oder meinetwegen auch xxx.blablabla), wären alle diese Probleme nicht aufgetreten und es wäre eine saubere, gute Lösung.
Meine Empfehlung geht sowieso dahin einen Router zu verwenden, der auch als VPN-Server arbeiten kann, da dann die PPTP- Verbindung vor der Firewall hergestellt wird und nicht einfach durch die Firewall geleitet wird. Vor allem bei Servern mit nur 1 Netzwerkschnittstelle macht sich das bemerkbar, da dort die Server-Firewall nur extrem eingeschränkt arbeiten kann.

Wie aus Bernds letztem Beitrag deutlich hervorgeht, leben wir vom Lösen von EDV-Problemen. Ich möchte aber auch deutlich machen, dass wir z.B. auch in diesem Fall keine Kostennote stellen, da sich das Gespräch aus diesem speziellen Forumsbeitrag ergab und unserer Meinung nach ist der Sinn eines Forums nicht, möglichst viele zahlende Kunden zu finden, sondern zu helfen und Hilfe zu finden. Deshalb auch dieser abschliessende Beitrag mit der Lösung und den Gründen des Problems.

Auch wir haben schon Hilfe benötigt und diese in Foren gefunden. Deshalb auch noch ein kleiner Appell zum Schluß: Wenn ein Problem gefixt ist, bitte tragt am Schluß ein, wie es gelöst wurde und was die genaue Ursache war. Viele andere User werden es euch danken.
Bitte warten ..
Mitglied: pc-pure
08.05.2005 um 14:39 Uhr
Nachtrag:

Nachdem sich herausstellte, dass zwar bei VPN über eine UMTS-Internetverbindung diese Einstellung funktionierte, aber bei VPN über die DSL-Internet-Verbindung nicht (hab da auch schon drüber nachgegrübelt), haben wir die Verknüpfung der internen IP-Adresse mit der xxx.net Domäne in die" hosts" geschrieben.

Anscheinend gehts jetzt.

Da sieht man wieder mal, was dabei rauskommt, wenn man einen miesen Admin erwischt.
Bitte warten ..
Mitglied: zwiki
11.11.2005 um 11:42 Uhr
Genial!
Tausend Dank an Christian.
Dieser Tip war auch in meinem Fall Gold wert!
Das sie "spassige" Endung: "server.Domäne.de" zu Problemen führen kann, hab ich mir schon gedacht als ich es gesehen habe, aber hier hatte ich dann doch nicht vermutet.
Danke!
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Microsoft
AD Problem und VPN (4)

Frage von Yannosch zum Thema Microsoft ...

Exchange Server
Win 10, Outlook 2013, SBS 2011 Exchange (4)

Frage von FFSephiroth zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...