Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Outlook Web Access - Probleme mit SSL und HTTPS

Frage Microsoft Exchange Server

Mitglied: 69465

69465 (Level 1)

16.07.2010, aktualisiert 19:17 Uhr, 6172 Aufrufe, 5 Kommentare

Hallo zusammen,

sitze jetzt schon seit heute Morgen daran, auf einem frisch installierten und (eigentlich) super funktionierenden Windows 2003 Server + Exchange 2003 das Outlook Web Access mittels SSL-Zertifikat ans Laufen zu bringen... ich habe ca. 20 Anleitungen durch, es klappt einfach nicht.

Infrastruktur:
- Windows Server 2003 (SP2)
- Exchange 2003 (SP2)

Situation:
- Exchange-Zugriff funktioniert fehlerfrei
- OWA-Zugriff via HTTP (also OHNE Verschlüsselung) funktioniert auch einwandfrei

Ziel:
- OWA mit Zertifikat verschlüsseln

History (was ich bisher gemacht habe):
(1.) Zertifikat beantragt
(2.) Zertifikat erfolgreich via MMC installiert (einmal unter "Eigene Zertifikate" einmal (wahrscheinlich überflüssigerweise) unter "Vertrauenswürdige Stammzertifikate")
(3.) Zertifikat erfolgreich in IIS eingebunden und es ist gültig
- bei Standardwebsite > Verzeichnissicherzeit > Serverzertifikat
(4.) Einstellungen bei Standardwebsite vorgenommen
- Port 443 ist konfiguriert
- "Sicheren Kanal voraussetzen (SSL)" und "128-Bit Verschlüsselung verwenden" sind auch aktiviert
---- dabei habe ich bei Nachfrage (irgendwas mit UNCPasswort?!) nur "Exchange" und "ExchWeb" ausgewählt (so stand es in einer Anleitung)
---- ABER, habe nachgeschaut: "Sicheren Kanal voraussetzen (SSL)" ist bei allen Modulen aktiviert, also "Exchange", "ExchWeb", "OMA", "Exadmin", "Public", "Microsoft ActiveSync" => ist das ein Problem??!

Problem:
- egal was ich mache, der (serverlokale) Browser (IE) zeigt immer "Website nicht gefunden, wenn ich https://server/exchange eingebe (mit http:// funktioniert es...)

Fragen:
=> Wer hat eine Idee, wo das Problem liegen könnte, bin mit meinem Latein (und INTENSIVEM Googlen) am Ende meiner Ideen. Ich bin für jeden Hinweis SEHR dankbar!
(=> Vielleicht liegt es ja tatsächlich an den "Sicheren Kanal"-Einstellungen für die einzelnen Module? Oder ist es egal, wenn die Option bei allen Modulen aktiv ist?)

Vielen Dank im voraus und viele Grüße,
Christian
Mitglied: Dani
16.07.2010 um 20:45 Uhr
Hi Christian,
du hast nach jeder Änderung den IIS-Manager neugestartet?!


Grüße,
Dani
Bitte warten ..
Mitglied: 69465
16.07.2010 um 20:48 Uhr
Ja, das habe ich stets gemacht! (via iisreset /restart). Danke, Dani.
Bitte warten ..
Mitglied: 69465
16.07.2010 um 21:11 Uhr
...ich muss das Zertikat doch "nur" EINMAL in der IIS-Standardwebsite einstellen, oder noch zusätzlich irgendwo anders im System?

Danke und Grüße
Bitte warten ..
Mitglied: Dani
17.07.2010 um 18:57 Uhr
Hi,
lass mal den das Häkchen "Sicheren Kanal voraussetzen (SSL)" weg... und starte neu.


Grüße,
Dani
Bitte warten ..
Mitglied: 69465
18.07.2010 um 01:23 Uhr
Danke, aber das hatte ich auch schon probiert.

Habe das (Haupt-)Problem jetzt wie folgt gelöst:
- SSL wieder komplett entfernt (manuell)
- alle Zertifikate wieder entfernt (manuell)
- dann "OWA Web Verwaltungstools / Admin Tools" installiert
- dabei wird zwangsläufig SSL eingerichtet und automatisch ein "Selbstzertifikat" / SelfSSL installiert (aber nur, wenn keinerlei Zertifikate auf dem Server installiert sind)
=> und siehe da: jetzt fuktioniert SSL ... wenigstens prinzipiell
- danach habe ich das Windows-SelfSSL-Zertifikat wieder gegen unser eigenes getauscht und es funktioniert immer noch

Aber jetzt habe ich noch ein paar kleine Fragen an die IIS-/OWA-Profis:
(1.) die automatische Installation hat mir im ISS neben meiner "Standardwebsite" eine weitere Website eingerichtet "Default Web Site"
=> wie kann ich möglichst einfach und schmerzfrei die Konfiguration von "Default Web Site" in die Website "Standardwebsite" überführen? Muss ich die einzelnen Seiten manuell eintragen?!
(2.) macht es (zertifikattechnisch) einen Unterschied, ob der Server "SERVER" oder "server" heißt? Also: ist die "Domainname-Prüfung" des Zertifikats case sensitive?

Vielen Dank und viele Grüße,
Christian
Bitte warten ..
Ähnliche Inhalte
Verschlüsselung & Zertifikate
gelöst SSL Zertifikat für HTTPS (34)

Frage von Hendrik2586 zum Thema Verschlüsselung & Zertifikate ...

Exchange Server
Outlook Web Access auf IP Adresse beschränken (6)

Frage von touro411 zum Thema Exchange Server ...

Verschlüsselung & Zertifikate
gelöst SSL selbst erstellen (3)

Frage von Angosch zum Thema Verschlüsselung & Zertifikate ...

SEO
Wie funktioniert eine HTTPS Verschlüsselung? (5)

Frage von Yanmai zum Thema SEO ...

Neue Wissensbeiträge
Windows Update

Offenbar erneutes MS-Update mit Fehlerschleife (2012 R2)

Information von VGem-e zum Thema Windows Update ...

Windows Installation

Unorthodoxer Weg, um an einen Offline-Installer für Adobe Flash zu kommen

(14)

Tipp von beidermachtvongreyscull zum Thema Windows Installation ...

Datenschutz

Gefährdeter Datenschutz: Firefox löscht lokale Datenbanken nicht

(1)

Information von BassFishFox zum Thema Datenschutz ...

Heiß diskutierte Inhalte
Windows Systemdateien
Windows bootet nicht mehr Fehlermeldung 0xc0000098 (19)

Frage von franzgoerlich zum Thema Windows Systemdateien ...

LAN, WAN, Wireless
gelöst 802.1X-Authentifizierung (18)

Frage von Alex29 zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Proxy Server Settings Cloud + EWS (17)

Frage von SomebodyToLove zum Thema Exchange Server ...

Windows Server
PDF Editor für den Einsatz auf Terminal Servern (15)

Frage von kwame501 zum Thema Windows Server ...