Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

OutlookAnywhere über Squid 3.2 mit Exchange 2010

Frage Microsoft Exchange Server

Mitglied: SchroederFR

SchroederFR (Level 1) - Jetzt verbinden

02.08.2013, aktualisiert 15:08 Uhr, 3379 Aufrufe, 5 Kommentare

Hallo zusammen,

wir haben frisch einen Exchange 2010 installiert bekommen.
Cas-Rolle und Postfach befinden sich auf einem Server.
Eigentlich wollten wir die Aussenanbindung (OutlookAnywhere) über eine Sophos UTM laufen lassen - Aussage vom Support heute aber: es wird kein NTLM unterstützt. Leider funktioniert auch der Basic-Auth Support nicht.
Auf Basis von Dani's Eintrag (http://www.administrator.de/link/squid-3-2-unter-ubuntu-als-reverse-pro ... - Danke nochmal dafür) habe ich dann einen Squid auf Ubuntu aufgesetzt und versucht, ob ich damit das Ganze so zum laufen bekomme. Gute Nachricht: per Basic-Authentication funktioniert es nun (Riesenfortschritt ;) !) aber nun wäre das Ganze über per NTLM natürlich noch die Kür.

Meine derzeitige Squid-Config:
01.
# Publish the RPCoHTTP service via SSL 
02.
#extension_methods RPC_IN_DATA RPC_OUT_DATA 
03.
https_port 443 accel cert=/etc/squid3/ssl/exchange.crt key=/etc/squid3/ssl/exchange.key defaultsite=.EXTERN_DOMAIN 
04.
 
05.
cache_peer INTERN_DOMAIN parent 443 0 no-query proxy-only originserver login=PASS ssl sslflags=DONT_VERIFY_PEER sslcert=/etc/squid3/ssl/exchange_intern.crt sslkey=/etc/squid3/ssl/exchange_intern.key name=ExchangeServer 
06.
 
07.
#acl EXCH dstdomain .EXTERN_DOMAIN 
08.
 
09.
 
10.
# Fuer ActiveSync notwendig, behebt Fehler auf https://www.testexchangeconnectivity.com 
11.
#ignore_expect_100 on 
12.
 
13.
# Zugriff auf folgende Adressen ist erlaubt 
14.
acl EXCH url_regex -i ^https://webmail.EXTERN_DOMAIN/owa.*$ 
15.
acl EXCH url_regex -i ^https://pushmail.EXTERN_DOMAIN/Microsoft-Server-ActiveSync.*$ 
16.
acl EXCH url_regex -i ^https://webmail.EXTERN_DOMAIN/ews.*$ 
17.
acl EXCH url_regex -i ^https://autodiscover.EXTERN_DOMAIN/autodiscover.*$ 
18.
acl EXCH url_regex -i ^https://webmail.EXTERN_DOMAIN/rpc/.*$ 
19.
 
20.
acl all src all 
21.
cache_peer_access ExchangeServer allow EXCH 
22.
never_direct allow EXCH 
23.
http_access allow EXCH 
24.
http_access deny all 
25.
miss_access allow EXCH 
26.
miss_access deny all 
27.
access_log /var/log/squid3/access.log squid
Weis jemand, ob noch eine bestimmte, nicht Standardeinstellung auf dem Exchange notwendig ist, oder sonst eine Idee, warum es eventuell noch nicht über NTLM nicht klappt.

Der Test unter https://www.testexchangeconnectivity.com schägt mit folgendem Ergebnis fehl:
Es wird versucht, ein Ping-Signal an RPC-Endpunkt 6001 (Exchange Information Store) auf Server INTERNE_DOMAIN zu senden. 
 	Fehler beim Versuch, ein PING-Signal an den Endpunkt zu senden. 
 	 
	Weitere Details 
 	Vom RPC-Laufzeitprozess wurde ein RPC-Fehler ausgelöst. Fehler 1818 CallCancelled.
Mitglied: Dani
02.08.2013, aktualisiert um 15:04 Uhr
Moin,
du hast im Exchangeserver NTLM ausgewählt? Wie das geht steht im Technet.

Es wird versucht, ein Ping-Signal an RPC-Endpunkt 6001 (Exchange Information Store) auf Server INTERNE_DOMAIN zu senden. Fehler beim Versuch, ein PING-Signal an den Endpunkt zu senden.
Ist völlig normal mit der Infrastruktur.


Grüße,
Dani
Bitte warten ..
Mitglied: SchroederFR
02.08.2013 um 15:04 Uhr
Jep, sonst bricht der Test auch schon früher ab und beschwert sich über die Falsche Auth-Methode.
Bitte warten ..
Mitglied: Dani
02.08.2013, aktualisiert um 15:10 Uhr
Einfach mit Outlook testen... das Profil mit der automatischen Einrichtung konfigurieren und somit werden auch die Einstellungen RPC-Proxy, etc.. richtig gesetzt.

Du kannst es aber auch noch anders testen: Starte auf einem Rechner Outlook 2010, drücke die STRG Taste und klicke mit der rechten Maustaste auf das Outlooksymbole rechts unten in der Taskleiste. Dort gibt es dann den Punkt E-Mail Autokonfiguration testen... Dort alle Haken bis auf Option 1 entfernen.


Grüße,
Dani

P.S. Bitte pass die Regeln noch an. Hilfe welche Verzeichnisse für dich relevant sind, findest du hier.
Bitte warten ..
Mitglied: SchroederFR
02.08.2013, aktualisiert um 15:12 Uhr
Okay, werde ich mal machen. Mal ne Blöde Frage - läuft der Test auf eurer Umbegung ohne Fehler durch? (Das wäre jetzt erstmal der von mir verfolgte Ansatz gewesen - solange der nicht durchläuft, muss es noch nen Fehler geben.)

P.S. Da wir die komplette Palette nach draussen hin benötigen sind auch alle Dienste mitaufgeführt
Bitte warten ..
Mitglied: Dani
02.08.2013, aktualisiert um 15:12 Uhr
Zitat von SchroederFR:
Okay, werde ich mal machen. Mal ne Blöde Frage - läuft der Test auf eurer Umbegung ohne Fehler durch?
Nein.
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange 2010 - OutlookAnywhere
gelöst Frage von DataJoeExchange Server1 Kommentar

Hallo, ich stehe vor folgendem Problem. mal etwas zur Vorgeschichte, SBS 2003 wurde auf Exchange 2010 (2k8 R2) und ...

Exchange Server
OutlookAnywhere über RPCoHTTPS fehlerhaft
gelöst Frage von MasterPhilExchange Server1 Kommentar

Hallo Zusammen, ich habe Autodiscover wie in diversen Foren zu lesen war und durch eine Frage von mir hier ...

Ubuntu
Mongodb 3.2 - Problem mit authentifizierung
Frage von Wid0kejUbuntu

Hallo, ich habe ein großes Problem mit mongodb 3.2 auf ubuntu 14.04 und phpnongodb Treiber. Der Server läuft, ich ...

Router & Routing
Squid Revers Proxy Probleme - Exchange
gelöst Frage von theoberlinRouter & Routing1 Kommentar

Hallo zusammen, ich habe ein kleines Problem bezüglich einer Reverse Proxy Konfiguration. Ausgangssituation: PfSense CARP Cluster, Exchange 2016 auf ...

Neue Wissensbeiträge
Mac OS X

MacOS wo ist die Tilde ?

Tipp von Alchimedes vor 2 StundenMac OS X

Hallo, ich hab eine MacOS qwertz Keyboard auf US Layout umgestellt da die Sonderzeichen besser ereichbar sind. Leider fehlt ...

Datenschutz

Weitere Inforamtionen zum Sicherheitsproblem BeA

Information von Penny.Cilin vor 9 StundenDatenschutz

Im folgenden ein weiterer Bericht über die Sicherheitsprobleme von Bea. Fataler Konstruktionsfehler im besonderen elektronischen Anwaltspostfach Gruss Penny

Windows 10

Systemdienste behalten nach Win10 inplace-Upgrade nicht die ggf. modifizierte Startart bei

Tipp von DerWoWusste vor 10 StundenWindows 103 Kommentare

Stellt Euch vor, Ihr habt ein Win10 System und modifiziert dort die Startart von Systemdiensten. Zum Beispiel wollt Ihr ...

Microsoft Office

Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei

Anleitung von SarekHL vor 13 StundenMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...

Microsoft Office
Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei
Anleitung von SarekHLMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...

Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von fyrb38Windows 1017 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...