Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OWA Exchange 2007 geht nicht - Probleme mit dem IIS oder .NET

Frage Entwicklung Visual Studio

Mitglied: radwan

radwan (Level 1) - Jetzt verbinden

19.04.2009, aktualisiert 20:58 Uhr, 11729 Aufrufe, 8 Kommentare

Mein OWA und der Abwesenheitsassistent gehen nicht mehr. Im Hintergrund läuft ein Exchange2007 SP1 auf einem Server2008.

OWA ging bisher, der Fehler trat nach folgender Aktion auf: Ich habe auf dem selben Server SharePoint (wss3.0) installiert.
Damit wss mit Port 80 läuft, habe ich im IIS auf der Default Web Site den Port 80 gelöscht und auf der Standard Web Site nur https mit Port 443
behalten. Damit lief sowohl OWA (443) wie auch der WSS (80).

Dann habe ich (leider) angefangen im wss herum zu konfigurieren. Danach fehlten mir zB das virtuelle OWA Verzeichnis
und beim Aufruf der Exchange Verwaltungskonsole kamen Fehlermeldungen im im Beitrag Exchange 2007 Virtuelles Verzeichniss zweck OWA Fehlerhaft .

Folgendes habe ich dann gemacht:
- IIS deinstalliert.
- .NET3.5 deinstalliert
- in Exchange die Client Access Rules deinstalliert

dann wieder alles installiert.

Seit dem läuft auch die Exchange Verwaltungskonsole wieder ohne Fehlermeldungen und im IIS sind alle für Exchange wichtigen
virzuelle Verzeichnisse waren auch wieder da, nur OWA und der Abwesenheitsassistent (der ja wohl auch über das IIS gehen)
gehen immer noch nicht.

Beim Anmelden über OWA kommt folgende Fehlermeldung:

Beschreibung: Fehler beim Verarbeiten einer Konfigurationsdatei, die für diese Anforderung erforderlich ist. Überprüfen Sie die unten angegebenen Fehlerinformationen,
und ändern Sie die Konfigurationsdatei entsprechend.

Parserfehlermeldung: Die Datei oder Assembly "Microsoft.Exchange.Data, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" oder eine Abhängigkeit davon
wurde nicht gefunden. Die Berechtigung zum Ausführen konnte nicht erteilt werden. (Ausnahme von HRESULT: 0x80131418)

Quellfehler:


Zeile 49: the compiler. All assemblies in the GAC and owa\bin are referenced automatically.
Zeile 50: -->
Zeile 51: <add assembly="Microsoft.Exchange.Data,
Zeile 52: Version=8.0.0.0,
Zeile 53: Culture=neutral,


Im Anwender Protokoll auf dem Server sieht die Fehlermeldung etwas detaillierter so aus:

- Provider
[ Name] ASP.NET 2.0.50727.0
- EventID 1310
[ Qualifiers] 32768
Level 3
Task 3
Keywords 0x80000000000000
- TimeCreated
[ SystemTime] 2009-04-19T17:57:36.000Z
EventRecordID 107059
Channel Application
Computer SERVER.xyz.local

Security
- EventData
3008
Es ist ein Konfigurationsfehler aufgetreten.
19.04.2009 19:57:36
19.04.2009 17:57:36
c155354b65914fecbe05314cf2d34242
1
1
0
/LM/W3SVC/1/ROOT/owa-8-128846374564801570
WSS_Minimal
/owa
D:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\
SERVER01
2980

w3wp.exe

NT-AUTORITÄT\SYSTEM
HttpException

Die Datei oder Assembly "Microsoft.Exchange.Data, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
oder eine Abhängigkeit davon wurde nicht gefunden. Die Berechtigung zum Ausführen konnte nicht erteilt werden. (Ausnahme
von HRESULT: 0x80131418) (D:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\web.config line 51)

https://217.xxx.xxx.xxx:443/owa/auth/logon.aspx?url=https://217.86.184.9 ...
/owa/auth/logon.aspx
84.xxx.xxx.xxx


False

NT-AUTORITÄT\SYSTEM
10
NT-AUTORITÄT\SYSTEM
False

bei System.Web.Compilation.BuildManager.ReportTopLevelCompilationException() bei
System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled() bei
System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost,
IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)


Ich meine, dass das Ganze immer noch mit dem IIS oder .NET zusammenhängt, aber ich habe (nach einem ganze Wochenende vor dem Server) keine
Idee mehr wie ich den Fehler wegbekommen kann. Outlook geht übrigens (bis auf den Abwesenheitsassistent) problemlos. Hat mir jemand eine Idee ??
Mitglied: Nailara
19.04.2009 um 21:03 Uhr
Hi,

die Fehlernachricht ist recht aussagekräftig - es fehlen .NET-DLL-Dateien, die nicht im GAC hinterlegt sind.

Such mal per Google von Lutz Roeder den Reflector. Damit kannste die .NET-DLL's öffnen und anschauen und dabei testen, welche abhängigen DLL's da sein müssen.

CU
Bitte warten ..
Mitglied: radwan
19.04.2009 um 21:32 Uhr
Danke erst mal für die schnelle Antwort.
Das Tool habe ich gefunden und installiert, aber wie jetzt weiter ? Welche DLL's soll ich damit öffnen ?
In der Fehlermeldung sehe ich keinen Verweis auf DLL's.
Bitte warten ..
Mitglied: Nailara
19.04.2009 um 21:39 Uhr
Diese DLL wird gebraucht: "Microsoft.Exchange.Data, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

Die Datei sollte auch Microsoft.Exchange.Data heissen

In der Fehlernachricht steht, dass diese Datei oder eine Abhängigkeit davon gebraucht wird. Wenn die Datei selbst dann schon nicht da ist, dann ist das nicht unbedingt günstig.

Suche mal die Datei, ggf auch auf der CD des Exchange.


Dann steht da noch "Die Berechtigung zum Ausführen konnte nicht erteilt werden. (Ausnahme von HRESULT: 0x80131418)". Das kann natürlicha auch passieren, wenn das Dienstkonto des IIS nicht die Berechtigung hat, diese Datei zu starten.

Schau besser erstmal nach, ob die Datei da ist. Wenn ja, dann Lutz Roeders Reflektor und wenn das nicht hilft, dann Berechtigungen im IIS.

CU
Bitte warten ..
Mitglied: radwan
19.04.2009 um 22:28 Uhr
So, nun bin ich etwas weiter:
- Die Datei Microsoft.Exchange.Data.dll ist da (../Exchange Server/bin).
- Die Rechte dazu solletn auch stimmen.
Wenn ich die DLL mit dem Reflektor anschauen findet er zwei Verküpfungen zu zwei DLL's ´nicht.
Microsoft.Exchange.Data.Common.dll
Microsoft.Exchange.Data.Transport.dll
beide liegen im Verzeichnis ../Exchange Server/public

Jetzt stellt sich mir nur die Frage, wie bekomme ich diese "Verknüpfungen" in der .Dll gespeichert.
Bitte warten ..
Mitglied: Nailara
19.04.2009 um 23:07 Uhr
Unter Start->Verwaltung bekommst Du die .NET-Konfiguration (mscorcfg.msc) und damit auch unter "Assembly" Zugriff auf den GAC. Dort rechte Maus und Hinzufügen und dann die beiden DLL's mal registrieren, dann liegen die zwar im GAC, werden aber gefunden.

Es kann sein, dass ev. durch Servicepack oder Rollup Fix andere .DLL-Versionen benötigt werden, das gibt dann die entsprechende Fehlernachricht auch aus. Dabei kommt es in der Tat auch auf die n-te Stelle nach dem Komma an, damit das funktioniert.
Bitte warten ..
Mitglied: Nailara
19.04.2009 um 23:09 Uhr
Oder kopiere die beiden gefundenen Dateien einfach mit in das BIN-Verzeichnis, das sollte auch helfen. DotNet geht daher und schaut zunächst im Verzeichnis selbst, dann im System resp. GAC nach, ob er die Dateien findet.

Demnach sollte es ausreichen, diese Dateien ins Ziel zu kopieren.

Auch bei diesen Dateien könnten Abhängigkeiten existieren - nur damit Du nicht gleich verzweifelst, wenn es noch nicht geht
Bitte warten ..
Mitglied: radwan
21.04.2009 um 10:01 Uhr
danke für deinen Tipp mit der.NET Konfiguration. Das waren insgesamt vier .dll's die nicht regierstiert waren. Dafür kommt jetzt die Fehlermeldung beim Aufruf vom OWA:

Sicherheitsausnahme
Beschreibung: Die Anwendung hat versucht, einen Vorgang auszuführen, der von der Sicherheitsrichtlinie
nicht zugelassen ist. Um der Anwendung die erforderliche Berechtigung zu erteilen, wenden Sie sich an den
Systemadministrator oder ändern Sie die Vertrauensebene für die Anwendung in der Konfigurationsdatei.

Ausnahmedetails: System.Security.SecurityException: Die Assembly lässt keine Aufrufer zu, die nicht voll
vertrauenswürdig sind.

Quellfehler:
Beim Ausführen der aktuellen Webanforderung wurde einen unbehandelte Ausnahme generiert.
Informationen über den Ursprung und die Position der Ausnahme können mit der
Ausnahmestapelüberwachung angezeigt werden.
Stapelüberwachung:
[SecurityException: Die Assembly lässt keine Aufrufer zu, die nicht voll vertrauenswürdig sind.]
ASP.global_asax..ctor() +0
Bitte warten ..
Mitglied: radwan
30.04.2009 um 17:07 Uhr
Das Ende von Lied heißt leider Neuinstalltion
Ich kann nur jedem raten, Finger weg von einer Installtion bzw von einer Deinstalltion von Server SharePoint (wss3.0) auf einem Domain und / oder Exchange Server.
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Exchange Server
Exchange 2007 Datenbank restore ohne Exchange zu verändern - SBS2008

Frage von pitamerica zum Thema Exchange Server ...

DSL, VDSL
Fritzbox Exchange 2007 UM Gateway mit Freetz (2)

Frage von Herbrich19 zum Thema DSL, VDSL ...

Exchange Server
gelöst Zertifikatsfehler nach Migration von Exchange 2007 zu Exchange 2013 (2)

Frage von Tommy1983 zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2007 Migration auf Exchange 2016 (3)

Frage von Tommy1983 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...