Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Packet Tracer 4.01 - Problem ist die Konfiguration des Internet Routers

Frage Netzwerke Router & Routing

Mitglied: Timboo

Timboo (Level 1) - Jetzt verbinden

15.06.2007, aktualisiert 19.06.2007, 24912 Aufrufe, 12 Kommentare

Ich habe für mein Studium mit dem Packet Tracer ein Netzwerk aufgebaut, es kunktioniert alles bis auf das Internet.

Subnetz 1: 150.0.0.0
Gateway (Router2) ist: 150.1.1.1

Subnetz 2: 150.128.0.0
Gateway (Router2) ist: 150.129.1.1 (oder sollte man hier 150.128.1.1 nehmen?)

Diese Subnetze sind an Router2 sowie am Router0 (InternetRouter) eingestellt.

Ich versuche mal zu beschreiben, wie das Netzwerk aussieht (siehe auch screenshot):

Im Subnetz 2 sind PCs über einen Switch0 an Router2 angeschlossen.

Im Subnetz 1 wird es etwas komplizierter:
Es sind an 6 Switches jeweils PCs angeschlossen. Diese 6 Schwitches sind wierderum mit Switch5 verbunden.

4 Server sind mit einem weiteren Switch16 verbunden.

Also:
Untereinander sind die Switches16/5 und Router wie folgt miteinenader verbunden:


Internet -- Router0 -- Switch16 -- Switch5 -- (<--SubN1) -- Router2 -- (SubN2-->) -- (Switch0)


1eb1bb85b104d4723b578e4a87abe1a2-nw - Klicke auf das Bild, um es zu vergrößern

Meine Einstellung für den InternetRouter ist nun wie folgt:

IP 150.1.1.2 (Anschluss an Switch16) Ethernet0/0
... bei dieser IP funktioniert wenigstens etwas, ich kann nämlich Pakete von den PC's an Switch5 an den InternetRouter schicken, das wars aber auch schon, mehr geht nicht.

IP 150.2.2.2 (Anschluss an Internet) Serial1/0
... diese IP ist sicherlich falsch, und ich weiß nicht was ich da einstellen soll (die Broadcast Adresse habe ich übrigends nicht verwendet (geht nicht): 150.255.255.255, bräuchte man die fürs internet?)

Die Internet-Wolke/Cloud müsste richtig konfiguriert sein, habe sie durch einen Tip im Internet eingestellt.
Allerdings kann man keine Pakete von oder zur Wolke schicken, ich weiß auch nicht ob das überhaput möglich ist: Fehlermeldung: Internet does not have an IP-address


Ich habe schon Stunden probiert, aber leider komme ich nicht weiter, ...

Über jede Hilfe wäre ich sehr dankbar...
Mitglied: aqui
15.06.2007 um 22:21 Uhr
Es ist etwas verwirrend, da deine Zeichnung nicht mit der Routernummerierung korrespondiert

Leider hast du auch das ebenfalls einen wichtigen Punkt vergessen, welche Subnetzmasekn du verwendest. Trotz dieser etwas oberflächlichen Daten wollen wir mal einen lösungsversuch wagen unter der Annahme das du die klassische Maske eine Class B IP Adresse mit 16 Bit verwendest, denn alle deine 150er Adressen sind Class B Adressen.

Ein weiterer Punkt ist die Frage ob du statisch oder dynamisch routest. Auch hier nehmen wir mal an das du das fürs erste statisch lösen willst....

Deine Netze sehen dann so aus:

(Internet)---(I-Router)---150.0.0.0/16---(Router 1)---150.128.0.0/16

Was dann allerdings wieder die Bezeichnung Internet hinter Subnetz 2 zu sagen hat bleibt schleierhaft, da wohl Cloud Internet Router ja wohl auch das Internet bedeutet.
Anzunehmen ist wohl auch das deinen ganzen Switches nur Layer 2 Switching machen also IP netztechnisch voll transparent sind ?!

Nun hast du leider nicht die IP Adressen der Router angegeben so das man nun auch hier wieder raten muss deine unten angegeben Adressen 150.1.1.2 und 150.2.2.2 können wenigstens niemals funktionieren, da sie nicht innerhalb deiner o.a. Netze liegen, die du ja auf dem Ethernet verwendest !!!
Die Adressen sind also erstmal schlicht falsch !!!

Unter Annahme dieses Setups:

(Internet)---(I-Router)---150.0.0.0/16---(Router 1)---150.128.0.0/16

Sieht dein Netz dann so aus:

6288383093773dbcc1cf1a7014d339d4-admin - Klicke auf das Bild, um es zu vergrößern

Das Default Gateway ins Internet wird der next Hop Router am seriellen Interface sein. Die Adresse hast du leider nicht gepostet, deshalb Fragezeichen.
In beiden Segmenten sind übersichtshalbe mal als Beispiel ein Endgerät plaziert mit den korrekten IP Adresseinstellungen
Wenn du die Adressen so vergibst (bzw. mit den Adressen die du wirklich nutzt..?!) sollte das Netz problemlos laufen....

In jedem Falle musst du deine Beschreibung der Router und Switches nochmal erneuen, denn die haben mit den Namen in der Zeichnung nichts gemein. Das ist sehr verwirrend und macht eine Hilfestellung doppelt schwer....

(Interessant sind deine IP Adressen !!! Laut Whois sind die für Asien (Japan) reserviert !!! Ist das ein Laboraufbau oder ein Livenetz ??? Bei einem Livenetz wäre die IP Adressierung höchst bedenklich denn scheinbar sind diese öffentlichen IP Adressen nicht auf dich registriert ! Besser du nutzt dafür RFC 1918 Adressen !)
Bitte warten ..
Mitglied: Timboo
15.06.2007 um 22:59 Uhr
Folgendes hatte ich zu der IP am Seriellen Interface bereits geschrieben, das dürfte die IP sein die Du noch suchtest:

IP 150.2.2.2 (Anschluss an Internet) Serial1/0
... diese IP ist sicherlich falsch, und ich weiß nicht was ich da einstellen soll (die Broadcast Adresse habe ich übrigends nicht verwendet (geht nicht): 150.255.255.255, bräuchte man die fürs internet?)

Mit Deinen Annahmen lagst Du richtig, nun habe ich Deine IP Struktur und einstellungen schon teilweise im Packet Tracer vorgenommen, allerdings weiß ich nicht, wie ich Deine grün hinterlegten Routing einträge einstellen soll.

Bisher hatte ich, für beide router gleich, folgendes eingestellt:

150.0.0.0/16 via 150.0.0.0
150.0.0.0/16 via 150.128.0.0
... das sind die Static Routes
und bei "RIP Routing" habe ich jeweils die Netzadresse: 150.0.0.0 ... verwendet

... wie soll ich diese Einstellungen nun entsprechend deiner grün hiterlegten Felder ändern? Denn mehr Einstellmöglichkeiten gibt es dort nicht.
Bitte warten ..
Mitglied: aqui
15.06.2007 um 23:47 Uhr
Oha, das ist ja ein Durcheinander...

1.) OK, die 150.2.2.2/16 musst du noch am seriellen Interface konfigurieren dann ! Dahinter steht ja der Router der es weiterreicht ins Internet und die Adresse muss man in der Default Route dort angeben. Ob die richtig ist oder falsch kannst nur DU beantworten denn wie sollen wir denn raten welchen Internet Adressweg du hast ??!!

Wenn du dessen Adresse nicht kennst kannst du die Default Route auch so eingeben:
ip route 0.0.0.0 0.0.0.0 int serial1/0
Die Broadcast Adresse ist irrelevant für die Konfig. Bei der Maske am Seriellen ist die aber 150.2.255.255 und nicht 150.255.255.255. Das wäre ja ein Class A Broadcast was diese Adresse aber nicht ist denn sie ist eine Class B !!!

2.) Routing !
Was machst du denn da ??? Also entweder du machst dynamisches Routing mit RIP oder du machst statisches Routing. Beides parallel ist kompletter Unsinn oder kaufst du dir immer zum Gürtel auch die Hosenträger ???
Parallelbetrieb kann dir auch Probleme bereiten. Also entscheide dich für ein Verfahren !!!
Die Netzadresse von 150.0.0.0 ist auch nur die halbe Miete bei RIP. Wenigstens auf dem 2.Router musst du ja auch noch die 150.128.0.0 eingeben !
Wie gesagt...es gilt entweder oder ...!!!

P.S.: Was in aller Welt ist ein Packet Tracer ???
Bitte warten ..
Mitglied: Timboo
15.06.2007 um 23:59 Uhr
... danke für Deine Hilfe. Der Packet Tracer ist ein Tool von Cisco, welches wir im Studium verwenden.

Ich habe Deine IP-Stuktur aus dem Beispiel übernommen, und ich habe mich jetzt für Static Routing entschieden.
Jetzt wäre nur noch die Frage was ich bei dem InternetRouter und bei dem Router1 bei dem Static Routing einstellen soll? Damit ich das ganze testen kann..

(Die adressen bei RIP Routing habe ich nun gelöscht)

Das waren meine beiden Einträge (Static Routes) bei BEIDEN Routern, wie soll ich die nun ändern?

150.0.0.0/16 via 150.0.0.0
...das sieht im Packet Tracer so aus:
Network: 150.0.0.0
Mask: 255.255.0.0
Next Hop: 150.0.0.0

150.0.0.0/16 via 150.128.0.0
...das sieht im Packet Tracer so aus:
Network: 150.0.0.0
Mask: 255.255.0.0
Next Hop: 150.128.0.0



Wie und wo gebe ich eine Default Route ein?
ip route 0.0.0.0 0.0.0.0 int serial1/0

Alles was ich am InternetRouter unter serial1/0 angeben kann ist:
IP Adress: ...
Subnet Mask: ...


PS:
Ist es richtig, dass ich bei Static Routing im Prinzip autorisiert bin alle IPs zu nehmen, Class A, B C, etc.? Da dies nur in meinem Netzwerk intern bekannt ist?

Danke
Tim
Bitte warten ..
Mitglied: aqui
16.06.2007 um 00:16 Uhr
Ach du Schreck...solche Tools sind aus Erfahrung immer Blödsinn und machen mehr Probleme als sinnvolle Sachen und ersetzen niemals einen Labor Aufbau.
Hauptsache du lernst im Studium auch das die Welt nicht nur aus denm Cisco Einerlei besteht....

Im Static Routing trägst du das ein was oben in der Zeichnung unter Routing Einträge steht !!!

Router 1 benötigt nur eine default Route ins Internet, denn er ist ja an beiden Netzen direkt angeschlossen und kennt die also !

Der Internet Router benötigt eine Defaultroute auf den Internetrouter am seriellen Interface. Wie gesagt wenn du den nicht kennst dann nimmer einfach den globalen Eintrag serial 1/0 als next Hop.
Aisser dieser Defaultroute benötigt er natürlich noch eine für das 150.128.0.0/16 Netz denn das kennt er ja nicht.
Wie die statische Route aussieht, siehst du auch oben im Bild !
Bitte warten ..
Mitglied: Timboo
16.06.2007 um 00:27 Uhr
Ich denke Statisch ist besser, wegen der Sicherheitsaspekte..... im Netzwerk.
Bitte warten ..
Mitglied: Timboo
16.06.2007 um 00:58 Uhr
WOW, jetzt klappt es sowohl statisch als auch dynamisch.

Vielen Dank für Deine Hilfe !!!

Tim
Bitte warten ..
Mitglied: Timboo
16.06.2007 um 01:32 Uhr
Das Netzwerk geht jetzt, ich kann nun Pakete auch bis zum Internet-Router senden, von allen PCs und Servern, und umgekehrt.

Was mich nun noch interessiert ist warum, wenn ich auf die "Internet-Wolke" ein Paket schicken will es nicht klappt:


Einstellung am Internet Router:

Static Routes: (wie von Dir übernommen)
150.2.0.0/16 via 150.2.255.555
150.128.0.0/16 via 150.0.0.1

Serial1/0: (wie von Dir übernommen)
150.2.2.2 255.255.0.0


Einstellungen an der Internet-Wolke/Cloud (auf die wir noch gar nicht eingegangen sind):

(Anschluss von Internetrouter auf Serial0)

Serial0:
DLCI: 700
Name: trail link 1

Serial1:
DLCI: 800
Name: Whatever

Settings:
From Port: Serial0
Sublink: trail link 1
To Port: Serial1
Sublink: Whatever


... evtl. geht ja meine IP für den Seriellen Port (Internet) nicht: 150.2.2.2 ???


[[ Wenn du dessen Adresse nicht kennst kannst du die Default Route auch so eingeben:
ip route 0.0.0.0 0.0.0.0 int serial1/0 ]]

... wie soll ich die eingeben?
... wenn ich die beim Seriellen Port angebe verweigert er die 0.0.0.0

... oder wie soll ich die unter Static routes eingeben?
Network: ...
Mask: ...
Next Hop: ...


???
Wenn ich das noch wüsste wäre es wirklich perfekt.
Bitte warten ..
Mitglied: aqui
17.06.2007 um 16:42 Uhr
Ohh, ohh ohh...was fuer ein Chaos ! deshalb die Bemerkung mit dem Bloedsinn von solcherlei Programmen....

Das kleine "Woertchen" DLCI laesst vermuten das du dort auf dem Seriellen eine Frame Relay Verbindung definiert hast. Denn nur dort kommt der Terminus DLCI vor ! Frame Relay gibst zwar noch macht man aber nicht mehr...eigentlich ! Es ist fuer eine labor Simulation auch etwas aufwaendig... Aber ggf. will deine Aufgabenstellung das so ??? Einen Frame Relay Link zu konfigurieren sprengt hier etwas den Rahmen.
Kanst du das ggf. auf HDLC als Encapsulation Protokoll aendern ???
Das laesst sich einfacher handhaben.
Warum er die Route nicht annimmt ist eigentlich unverstaendlich ???
Klappt auch ein ip route 0.0.0.0 0.0.0.0 int ser 1/0 nicht ??? Das sollte immer gehen !
Bitte warten ..
Mitglied: Timboo
17.06.2007 um 21:27 Uhr
Bei dem Packet Tracer lässt sich nur DLCI einstellen (bei der Internet "wolke"), das wars. Mit diesem Programm von Cisco soll ich mein Netzwerk simulieren, das konnte ich mir leider nicht aussuchen. ;-( ...ich denke auch dass es wohl veraltet ist, und dass es dort eben nicht so viele Einstellmöglichkeiten gibt.

Beim Seriiellen Port des Internet routers kann ich nicht 0.0.0.0 einstellen, wird nicht angenommen, ich könnte die felder lediglich offen lassen, bisher steht dort:
Serial1/0: (wie von Dir übernommen)
150.2.2.2 255.255.0.0

Übrigends möchte ich dir nochmal meine komplette konfiguration der router mitteilen, mit der bitte diese evtl. zu koorigieren. (evtl. habe ich deine noch nicht ausgefüllten felder falsch ausgefüllt) DANKE:


Einstellung am Internet Router:
(Welche IP besitzt nun dieser Router??, sollte beim Internetrouter die IP nicht die Netzadresse sein?)

Static Routes: (wie von Dir übernommen)
150.2.0.0 255.255.0.0 150.2.255.555 (Next Hop wohin???)
150.128.0.0 255.255.0.0 150.0.0.1 (Next Hop zu Router 1)


Einstellungen am Router 1:
(Welche IP besitzt nun dieser Router??)

150.2.0.0 255.255.0.0 150.0.0.254 (Next Hop zu Internet Router)
Bitte warten ..
Mitglied: aqui
19.06.2007 um 11:36 Uhr
Das ist klar das du auf dem seriellen Interface was in die Internetwolke geht nicht 0.0.0.0 konfigurieren kannst, denn das ist keine gültige IP Adresse !

Dort muss eine gültige IP Adresse auf dem Interface stehen. Du kannst ja die 150.2.2.2/16 belassen, denn das netz gibt es ja noch nicht in deinem Szenario.
Es ist nun klar das der Router an dem diese Wolke angeschlossen ist per serielles Interface eine default Route haben muss in die große weite (Interent)Welt !!! D.h. das ist die Route an die der Seriell1/0 Router alle Packete hinschickt die nicht für seine beiden Netze 150.0.0.0/16 und 150.128.0.0/16 sind.
Da du ja das next Hop Gateway bzw. dessen IP Adresse nicht kennst (der liegt ja irgendwo in der Wolke...) kannst du nun nur entweder:
a.) Ein globale default Route auf das serielle Interface serial1/0 einrichten ! Oder
b.) Eine fiktive IP Adresse für diesen Router im 150.2.0.0/16 Netzwerk annehmen !

Auf dem Router käme dann also Lösung für a: infrage

ip route 0.0.0.0 0.0.0.0 int serial1/0
oder für b.)
ip route 0.0.0.0 0.0.0.0 150.2.0.254
Die 150.2.0.254 wird dann mal als fiktive IP Adresse für den Router zum Internet geraten !!!

Eine von diesen 2 Routen musst du so eingeben am Router der die Internetwolke angeschlossen hat !

Nochwas:
Deine statische Route:
150.2.0.0/16 via 150.2.255.555
die du oben angegeben hast ist vollkommener Unsinn denn das ist keine Route denn die next Hop Adresse 150.2.255.555 ist eine Broadcastadresse, die zudem auch noch im selben Netzwerk wie das Zielnetz liegt ! Also vollkommen falsch und unsinnig, denn eine Route kann natürlich, wie du ja sicher weisst, niemals auf eine Broadcast Adresse zeigen als next Hop !!!

An diesem Router muss gar keine Adresse für das 150.2.0.0/16 Netz konfiguriert sein, denn das kennt der Router ja , da es physisch direkt an ihm angeschlossen ist, somit eine Route dahin vollkommen überflüssig ist !!!
Wenn, dann müsste es der andere Router haben, aber der hat ja sowieso eine default Route (ip route 0.0.0.0 0.0.0.0 150.0.0.254) auf den Wolkenrouter, schickt also sowieso schon alles was er selber nicht kennt (und das wäre dann auch 150.2.0.0/16) an den anderen Router.
Fazit: Die o.a. falsche Route kann ersatzlos raus !
Bitte warten ..
Mitglied: Timboo
19.06.2007 um 21:22 Uhr
Also ich habe mich mittlerweile für RIP-Routing entschieden:

Router 1:
150.0.0.0
150.128.0.0

Internet-Router:
150.0.0.0
Beim Seriellen Anschluss habe ich nun die IP 192.168.20.20 gewählt (255.255.255.0):
als X-Beliebige zugewiesene Internet-IP-Adresse (so wie auch bei meinem PC zu Hause)

... ich habe nicht 150.2.0.2 genommen, da es sich dabei um ein Class B-Netz handelt.

Was es in diesem Zusammenhang der Adressvergabe mit dem NAT (Network Address Translation) auf sich hat habe ich ehrlich gesagt nicht ganz verstanden, es sollte auf jeden fall ein Netzwerk mit NAT gebaut werden.

...ich hoffe Du kannst mir noch folgen
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
DSL, VDSL
SDSL Problem - kein Internet (10)

Frage von cptkrabbe zum Thema DSL, VDSL ...

Netzwerkgrundlagen
PFSense kein Internet Zugang (3)

Frage von Phill93 zum Thema Netzwerkgrundlagen ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...