Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Pam-Konfig bzw. Winbind nicht richtig oder fertig konfiguriert

Frage Linux

Mitglied: 34453

34453 (Level 1)

13.02.2007 um 15:22 Uhr, 3511 Aufrufe

Problem bei der Konfiguration eines Samba - Mietglied - Servers per Konsole.

Einleitung:

2 unserer Unix-Server werden derzeit durch PCNetlink mit unserem ADS verbunden. PCNetlink ist ähnlich, wie Samba und verbindet Unix mit Windows. Das Problem dabei ist, dass PCNetlink auf dem Stand von NT stehen geblieben ist und nicht mehr weiter entwickelt wird. Dadurch sind wir auf Samba gekommen und wollen es damit lösen.


Anforderung:

Mein Probenetzwerk:

AD-Server mit Win2k3
Windows-Client mit XP
SUSE Linux 10.1

Soll späteres Netzwerk:

2 Solaris-Server mit Samba
AD-Server mit Win2k3
Windows-Clients
Linux- bzw. Unix-Clients

Bisher gemacht und geschafft:

AD-Server läuft. DNS auch. Der XP-Client auch.
Mein SUSE 10.1 ist installiert und die Authentifizierungsmethode ist auf "lokal" bei der Installation gestellt wurden.
Es wurden keine User bei der Installation hinzugefügt.

krb5.conf ist richtig konfiguriert.
Samba ist auf mein Probenetzwerk angepasst und konfiguriert.
nsswitch.conf ist auf "passwd: files winbind" und "group: files winbind" gestellt
"wbinfo -u" und "wbinfo -g" sowie "getent passwd" zeigen die Gruppen und User an, dass sie erfolgreich in die passwd gemappt wurden.
Ich kann einen Share erstellen, lass die Win2k3-Gruppe "Domänen-admins" Adminrechte auf diesen Share haben.
Die Domänen-admins dürfen Ordner erstellen und löschen und per Rechtsklick die Rechte vergeben.

Mein Problem:

Mein Problem ist folgendes.
Wenn man auf einen Share oder irgend einen Windows-Ordner Rechte vergeben will, dann zeigt es zum Beispiel an, dass User "Fritz" lesen/schreiben/ausführen darf.
Wenn ich jetzt aber mit einem befugten User, der Adminrechte auf diesen Share hat, jemanden Rechte geben will, dann würde anstatt User "Fritz" eine SID dastehen die wie folgt aussieht "S-1-5-21-2334373287-406835450-3753124356-1110".
In dem späteren Netzwerk wäre es unvorteilhaft, wenn solche langen ID's dastehen, da blicken wir dann selber nicht mehr durch.
Woran liegt es, dass es nicht "Fritz" sondern "S-1-5-21-2334373287-406835450-3753124356-1110" anzeigt?
Liegt es jetzt an pam oder an winbind, denn wenn ich alles per Konsole und Texteditor konfiguriere fehlt bestimmt irgendetwas. Bei SUSE kann ich sowas ja komfortabel per Yast machen und Yast führt mir dann automatisch die folgenden Konfigurationen aus, die benötigt werden, damit es geht.


Hoffe das Problem und Netzwerk ist gut dargestellt, bei fragen poste ich auch die smb.conf oder andere *.conf, wobei es sicherlich nicht am Samba liegt, oder???
Ähnliche Inhalte
Samba
Ubuntu-Server in AD - Winbind
gelöst Frage von caspi-pirnaSamba16 Kommentare

Hallo zusammen, ich versuche seit mehreren Tagen, einen Ubuntu 14.04-Server in eine Microsoft AD-Domain zu bekommen (s. Anleitung Samba ...

Weiterbildung
Ausbildung fertig, was nun ?
Frage von MeterpeterWeiterbildung16 Kommentare

Hallo *, Ich bin wahrscheinlich nächstes Jahr mit meiner 3 Jährigen Ausbildung als Fachinformatiker für SI fertig und mache ...

Switche und Hubs
Neue Telefonanlage - VOIP - HP Switche - Wie wird QOS richtig konfiguriert ?
Frage von toheilSwitche und Hubs1 Kommentar

Hallo liebe Mitglieder, Wie haben eine neue Telefonanlage von Unify und neue Switche von HP. (HP 1920-48G-PoE+ (370W) Switch ...

DNS
Bind9 Konfig-Problem
gelöst Frage von TiTuxDNS11 Kommentare

Hallo, ich habe hier auf einer physischen Maschine ein CentOS 7.1 mit bind9 installiert, der Dienst läuft, der Check ...

Neue Wissensbeiträge
Microsoft

Update KB4073578 für AMD CPU (Spectre und Meltdown Lücke)

Information von sabines vor 3 StundenMicrosoft

Wegen Problemen (BOSD, nicht startende PCs) wurde das Update KB4056897 und KB4056894 für AMD CPUs zurückgezogen. Dieses Update KB4073578 ...

Mac OS X

MacOS wo ist die Tilde ?

Tipp von Alchimedes vor 16 StundenMac OS X1 Kommentar

Hallo, ich hab eine MacOS qwertz Keyboard auf US Layout umgestellt da die Sonderzeichen besser erreichbar sind. Leider fehlt ...

Datenschutz

Weitere Informationen zum Sicherheitsproblem BeA

Information von Penny.Cilin vor 23 StundenDatenschutz

Im folgenden ein weiterer Bericht über die Sicherheitsprobleme von Bea. Fataler Konstruktionsfehler im besonderen elektronischen Anwaltspostfach Gruss Penny

Windows 10

Systemdienste behalten nach Win10 inplace-Upgrade nicht die ggf. modifizierte Startart bei

Tipp von DerWoWusste vor 1 TagWindows 103 Kommentare

Stellt Euch vor, Ihr habt ein Win10 System und modifiziert dort die Startart von Systemdiensten. Zum Beispiel wollt Ihr ...

Heiß diskutierte Inhalte
Batch & Shell
Anmeldevorgang für Informatikraum (Schule) unter Windows
Frage von IngenieursBatch & Shell24 Kommentare

Hey zusammen, ich werde in naher Zukunft den Informatik Raum meiner jetzigen Schule von dem aktuellen Betreiber übernehmen (Vertrag ...

Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von fyrb38Windows 1019 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...

Microsoft Office
Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei
Anleitung von SarekHLMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...