Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Parameter-Übergabe in URL klappt nur beim Internet Explorer 6 nicht

Frage Entwicklung PHP

Mitglied: coltseavers

coltseavers (Level 2) - Jetzt verbinden

05.02.2010, aktualisiert 07.02.2010, 8410 Aufrufe, 4 Kommentare

Das Problem:
Es wird auf einer von mir erstellten Webseite ein Link eingebaut, der z.B. auf folgende Seite führt: "irgendeinedatei.php?variable=wert"

Es werden also Daten per Get-Parameter über die URL an den Webserver geschickt.
Beim Internet Explorer 7 und höher und beim Firefox funktioniert das absolut problemlos.
Beim Internet Explorer 6 kommt jedoch eine HTTP 400 - Fehlermeldung.

Ich habe rausgefunden, der kommt mit dem Fragezeichen nicht klar. "irgendeinedatei.php?" erzeugt noch die fehlermeldung "Bad Request - Your browser sent a request, that this server could not understand".

"irgendeinedatei.php" verursacht keine fehlermeldung mehr.

Der Browser scheint also irgendwie das Fragezeichen beim übermitteln anders zu kodieren oder so?
was kann man da machen?

Webserver ist ein Apache, Version 2.2.9

Gruß,
Colt Seavers
Mitglied: StefanKittel
05.02.2010 um 00:32 Uhr
Hallo,
dafür gibts garantiert eine technische Lösung.
Die würde ich aber eigentlich nicht suchen sondern liebe ein Schild aushängen: "Ihr Browser ist stark veraltet und stellt ein erhebliches Sicherheitsrisiko für Sie dar!".
Stefan
Bitte warten ..
Mitglied: coltseavers
05.02.2010 um 00:41 Uhr
...jo - da sind wir natürlich einer Meinung!
Nur der Auftraggeber hat selbst nen IE6 und ist ausserdem (in meinen Augen auch nachvollziehbar) der Ansicht, dass die Webseite auf möglichst allen Browsern laufen soll - er will ja möglichst jeden Besucher halten.
Und so schade es auch ist: den IE6 haben immerhin so einige - schliesslich ist er bei XP vorinstalliert.
Wer ihn nicht updatet, surft heute noch damit!
Bitte warten ..
Mitglied: StefanKittel
05.02.2010 um 00:46 Uhr
Schau doch mal ins Log vom Apache was dort so ankommt oder wenn nicht möglich sniff auf einem PC mal den Request mit (WireShark).
Bitte warten ..
Mitglied: coltseavers
05.02.2010 um 01:03 Uhr
Logfile war ne gute Idee - aber erst aufm 2. Blick was gefunden:

Hatte die Webseite noch mit nem Passwort über ne Digest-Authentifizierung gesichert.
Nehm ich die Passwort-Sicherung ausm Apache raus, läuft die Seite auch im IE6 problemlos.
Das digest-Modul kommt also mit dem IE6 nich klar...

Aber macht nix. Wenn die Webseite wahrscheinlich morgen on geht, fällt natürlich die Passwort-Sicherung raus, und alles ist schön..
*puh*

Danke für Deine Hilfe!
Bitte warten ..
Ähnliche Inhalte
Webbrowser
URL an Internet Explorer aus Datei übergeben
gelöst Frage von hesperWebbrowser4 Kommentare

Tach zusammen! Ich hab hier wohl eine kleine Denkblockade und brauch einen Anschubser. Aufs Warenwirtschaftssystem wird nebst Terminalemulation auch ...

Windows Server
Parameter Übergabe Terminal Server
gelöst Frage von ThomasKernWindows Server9 Kommentare

Hallo zusammen, ich habe folgendes Problem. Wir führen gerade ein Dokumentenmanagement-System ein welches sehr eng mit unserm WAWI zusammen ...

Linux Netzwerk
Squid URL parameter hinzufügen
Frage von stefan2k1Linux Netzwerk1 Kommentar

Hi, ich habe hier einen Squid Proxy 3.x und würde gerne bei bestimmten URLs einen Parameter hinzufügen, z.B. www.google.de ...

Batch & Shell
Batch Parameter Argumente Übergabe Problem
gelöst Frage von BloodyRulzBatch & Shell1 Kommentar

Hallo zusammen, ich hoffe ich bekomme hier wieder die gewünschte Hilfe, da ich mit meinen sehr eingeschränkten Batchkenntnissen am ...

Neue Wissensbeiträge
Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 2 StundenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 3 StundenSicherheit5 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 4 StundenSicherheit4 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Sicherheit

Meltdown und Spectre: Die machen uns alle was vor

Information von Frank vor 4 StundenSicherheit12 Kommentare

Aktuell sieht es in den Medien so aus, als hätten die Hersteller wie Intel, Microsoft und Co den aktuellen ...

Heiß diskutierte Inhalte
Batch & Shell
Anmeldevorgang für Informatikraum (Schule) unter Windows
gelöst Frage von IngenieursBatch & Shell29 Kommentare

Hey zusammen, ich werde in naher Zukunft den Informatik Raum meiner jetzigen Schule von dem aktuellen Betreiber übernehmen (Vertrag ...

Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von 92943Windows 1028 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...

Netzwerkgrundlagen
Welches Modem für VDSL 50000 der T-Com
Frage von Windows10GegnerNetzwerkgrundlagen19 Kommentare

Hallo, ein Kollege von mir will sich VDSL50000 von der T-Com holen, um daran einen Server zu betreiben. Ich ...