Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Patch Putty AccessPoint reboot

Frage Entwicklung Batch & Shell

Mitglied: retz12

retz12 (Level 1) - Jetzt verbinden

18.02.2014 um 16:23 Uhr, 1897 Aufrufe, 7 Kommentare, 1 Danke

Hallo,
Ich habe ein Problem mit meinem Access Point "Netgear WG103".
Diese hängt sich öfter mal auf. Man kann sich danach zwar zum W-LAN Netz anmelden, jedoch kommt man nicht mehr ins Internet.
Einige Lösung, was ich bis dato gefunden habe ist ein reboot des AP

Jetzt habe ich mir gedacht, ich könnte diese ja per Batch (ssh) rebooten.

Ich hätte gerne ein Script, dass sich am AP einloggt und danach den AP rebootet. Dieses Script lasse ich vom Server wöchentlich/monatlich einmal ausführen.

ich habe mir ein wenig mit putty und nen Script gespielt, jedoch schaffe ich den automatischen reboot nicht.

Hier das Script putty.cmd
01.
putty.exe admin@192.68.0.3 -pw password -m C:\putty.txt 
in der putty.txt steht dann reboot

Der Login auf den AP funktionert einwandfrei, jedoch bleibt er dann hängen und führt keinen Befehl aus.

Kann mir da jemand helfen.

Danke
Mitglied: aqui
18.02.2014, aktualisiert um 16:38 Uhr
Das ist ja irgendwie alles Frickelei. OK vielleicht ja notwendig bei NG Schrott vom Blödmarkt aber nicht wirklich....
Hast du es mal mit der aktuellsten Firmware auf dem AP versucht und das geflasht ?
http://support.netgear.com/product/WG103
Ver. 2.2.25 ist die aktuellste.
Dann gelten die klassischen ToDos für das Einrichten eines WLANs:
  • Umgebung scannen mit einem freien WLAN Scanner wie dem inSSIDer z.B. http://www.metageek.net/products/inssider/ Wichtig ist hier das man zwingend mindestens 4 Kanäle von Nachbar WLANs entfernt sein muss um von diesen nicht gestört zu werden. Das also entsprechend fest im WLAN Setup des AP einstellen ! Niemals hier die Einstellung "AUTO" verwenden.
  • Die SSID (WLAN Name) sollte keine Sonderzeichen enthalten und individuell sein. Niemals hier den Default Namen des Herstellers verwenden sondern sowas wie Bitschleuder oder Wurstsemmel !
  • Auch das WPA Passwort sollte keine Sonderzeichen enthalten.
  • Als Verschlüsselung immer WPA-2 verwenden mit AES-CCMP. Niemals hier Mischbetrieb machen mit TKIP oder TKIP allein verwenden !
  • Die WLAN Bandbreite im 2,4 Ghz Bereich muss auf 20 Mhz eingestellt sein. Hier niemals AUTO oder andere Settings wie 40 Mhz verwenden !
Wenn du diese Schritte alle sauber beachtest und umsetzt im Setup auf dem AP wird das Ding auch nicht mehr abstürzen.
Bitte warten ..
Mitglied: retz12
18.02.2014 um 16:42 Uhr
Hallo aqui,
Bis auf die Wlan-Bandbreite habe ich alles so berücksichtigt. Firmware ist schon lange aktualisiert. Dacht auch, dass mit der aktuellen Firmware das Problem behoben sein könnte, leider nein.

Was könntest du mir für AP empfehlen?

Ich habe 2 AP, die mein Gebäude abdecken.
2 VLAN´s
Bitte warten ..
Mitglied: Dobby
18.02.2014 um 16:54 Uhr
Hallo,

das ist natürlich auch kein Wunder denn Netgear unterstützt diesen
WLAN AP auch über seine beiden WLAN Controller und daher wird
das mittels des Scripts dann wohl auch nicht so laufen wie Du Dir
das wünscht.

Kannst Du denn den WLAN AP mittels des Kommandos reboot
neu booten wenn Du dich richtig einloggst?

Gruß
Dobby
Bitte warten ..
Mitglied: retz12
18.02.2014 um 17:07 Uhr
Hallo,
Ja ich kann den AP per Putty rebooten.

1. Benutzer eingeben
2. Passwort eingeben
Danach kommt die Kommandozeile wo man reboot eingibt! dann funktioniert es auch einwandfrei.
Bitte warten ..
Mitglied: aqui
18.02.2014 um 17:13 Uhr
Ein paar Empfehlungen findest du hier wenn VLANs und mSSID ein Thema sind:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Ansonsten wenn man etwas Verlässlichkeit haben möchte wie immer Ubiquity:
http://varia-store.com/Hardware/UBIQUITI-Networks:::637_734.html
nanoStation oder UniFi
Jedenfalls kein NG bei APs...sorry, Dobby..
Bitte warten ..
Mitglied: colinardo
18.02.2014, aktualisiert 19.02.2014
Hallo retz12,
schließe mich meinen Vorrednern an, aber zurück zu deiner eigentlichen Frage mit Putty.
Für die Kommandozeile gibt es dafür das extra-Tool plink vom selben Hersteller, das dafür besser geeignet ist. Siehe dazu folgenden Kommentar:
http://www.administrator.de/forum/per-putty-auf-mehrere-cisco-ios-ger%C ...

Ansonsten ließe sich das auch in ganz hartnäckigen Fällen mit einem AutoIT- oder Powershell-Script über das Browserinterface des AP unsichtbar erledigen.

Grüße Uwe
Bitte warten ..
Mitglied: Dobby
18.02.2014 um 17:34 Uhr
Hallo nochmal,

Danach kommt die Kommandozeile wo man reboot eingibt!
dann funktioniert es auch einwandfrei.
Ok hast Du schon einmal überlegt ob mach
nicht einen "Delay" Befehl nutzen könnte.

Also einloggen und dann eine gewisse Zeit warten
und dann erst den Befehl reboot absetzen, ich meine
ich bin kein Programmierer und kann auch keinen Code
schreiben aber würde das eventuell helfen?

Gruß
Dobby
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

LAN, WAN, Wireless
Cisco AccessPoint 1131 - Status LED Red Radio LED blinkt rot (9)

Frage von 1x1speed zum Thema LAN, WAN, Wireless ...

Windows 10
gelöst Windows 10 - Automatischen Reboot sicher verhindern (2)

Frage von yakini zum Thema Windows 10 ...

Microsoft
Neue Sicherheitslücke in Windows - patch erst in einer Woche (1)

Link von keine-ahnung zum Thema Microsoft ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...