Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Performance prüfen

Frage Microsoft Windows Server

Mitglied: Akcent

Akcent (Level 2) - Jetzt verbinden

05.07.2013 um 14:22 Uhr, 3094 Aufrufe, 22 Kommentare

Hallo,

ich habe in einem Netzwerk ein kleines Performance Problem beim Zugriff auf Daten (Fileserver, Mail, WWS)

Wie würdest Ihr hier vorgehen um herauszufinden, warum der Zugriff seit ein paar Monaten immer langsamer wird?
Der Switch wurde bereits gewechselt.

Windows 2003 Dom.
ca. 10 User (XP und Win7 Clients)

Danke und viele Grüße,
Herry

Mitglied: jsysde
05.07.2013 um 14:47 Uhr
Mahlzeit,

da fällt mir spontan iperf ein:
http://sourceforge.net/projects/iperf/

Und wird mal nen Blick in den Taskmanager auf dem Server, wie sieht die RAM-Auslastung aus?
Wenn "Mail" == "Exchange" dann orakle ich mal, dass der Exchange allen verfügbaren RAM "frisst" und somit für I/Os nicht mehr viel über bleibt.

Cheers,
jsysde
Bitte warten ..
Mitglied: braind
05.07.2013 um 14:48 Uhr
Hallo,
ich hatte das kürzlich auch.
Was ich gemacht habe:
Auf jedem Server den Perfomace Monitor verwendet um zu sehen welche Services denn am meisten Netzwerkperfomace brauchen, Latenzeit.
Dann habe ich den PCATTCP, http://www.gtkdb.de/index_15_383.html, verwendet um die Netzwerklast zu beobachten.
Der ist echt gut und hat mich auch zum Flaschenhals geführt.
Managed Switches sind natürlich auch eine große Hilfe aber solche habe ich nicht.
Hoffe es hilft.

Meist sind es in solchen Fällen schon HW Komponenten. Switches, Netzwerkkabel, Netzwerkkarten (Treiber).
Bitte warten ..
Mitglied: aqui
05.07.2013, aktualisiert um 15:52 Uhr
Als allererstes solltest du die Infrastruktur selber testen um von vorn herein Fehler auf selbiger ausschliessen zu können !
Erst danach geht man an die Endgeräte und Applikationen.
Nimm also das obige iPerf oder NetIO:
http://www.ars.de/ars/ars.nsf/docs/netio
Das ist einen kleine .exe Datei die du direkt im Eingabefenster ausführen kannst.
Die komplette Bedienung wird hier erklärt:
http://www.nwlab.net/art/netio/netio.html
Damit checkst du dann erstmal was Switch, Netzwerk usw. überhaupt hergeben und das bei unterschiedlichen Paketgrößen.
Dann hast du einen Anhaltspunkt was du bei Applikationen überhaupt erstmal erwarten kannst !
Bei den XP Maschinen macht es Sinn die TCP Windowsize des TCP Stacks anzupassen auf einen akzeptablen Ethernetwert. Ansonsten denkt XP es hat benutzt ein 64kBit ISDN Netzwerk. Wie das genau geht ist hier beschrieben:
http://www.heise.de/netze/artikel/TCP-IP-Tuning-221778.html
Bei XP sollte man das zwingend machen, bei Win7 oder höher ist das nicht erforderlich da der TCP Stack anders ist.
Bitte warten ..
Mitglied: DerWoWusste
05.07.2013 um 16:04 Uhr
@aqui
Dieses Tuning soll in einem LAN eine Rolle spielen? Nicht bloß in einem WAN?
Bitte warten ..
Mitglied: aqui
05.07.2013, aktualisiert um 16:36 Uhr
Ja, das gilt auch für LAN Adapter. Wenn die TCP Windowsize in der Registry nicht richtig durch die Treiberinstallation einer NIC gesetzt ist, ist der Wert dort nicht angegeben und dann nimmt XP (und nur XP) eine auf Analog Modem Betrieb optimierte Windowssize an.
Setzt man die auf Fast Ethernet übliche Werte setzt erzielt man eine signifikante Erhöhung der Durchsatzleistung bei entsprechender Gegenstelle und natürlich nur bei Applikationen die TCP nutzen und kein UDP !
Wie gesagt ist nur gültig für XP und NICHT für neuere Winblows Versionen.

Wie gesagt, nur ein kleiner Punkt zu dem "Killerthema" Netzperformance was ja recht komplexx ist durch die Beteiligung unterschiedlicher Komponenten und Anwendungen !
Der TO macht ja hier leider wie immer recht wenig Angaben auch zur Hardware und gemachten Tests. Wie üblich also bei solchartigen Threads hier im Forum wo (sorry) wenig Sachkenntnis vorhanden ist. Da ist dann mal wieder hier die gesamte Bandbreite möglicher Fehler und Ursachen zu erwägen.
Bitte warten ..
Mitglied: Cthluhu
05.07.2013 um 16:40 Uhr
Hi Akcent,

Was heißt in diesem Zusammenhang "Zugriff"? Auflisten eines Ordnerinhalts? Kontinuierliches Kopieren einer einzelnen Datei? Dauert die Antwort auf einen ping lange? ...

Wenn der Zugriff auf Netzwerkfreigaben kontinuierlich langsamer wird, kann das z.B. an voll werdenden Festplatten am Dateiserver liegen. Oder an Ordnern liegen welche viele Dateien (meist ein Problem ab einigen Hundert Dateien im Ordner) beinhalten.

Mit freundlichen Grüßen

Cthluhu
Bitte warten ..
Mitglied: DerWoWusste
05.07.2013, aktualisiert um 16:47 Uhr
@aqui
Soso.
Mal ein netio-Bench von xp nach 2008 Server:
netio.exe -t Server

NETIO - Network Throughput Benchmark, Version 1.26
(C) 1997-2005 Kai Uwe Rommel

TCP connection established.
Packet size 1k bytes: 41099 KByte/s Tx, 109110 KByte/s Rx.
Packet size 2k bytes: 58479 KByte/s Tx, 113282 KByte/s Rx.
Packet size 4k bytes: 84454 KByte/s Tx, 115136 KByte/s Rx.
Packet size 8k bytes: 94092 KByte/s Tx, 115373 KByte/s Rx.
Packet size 16k bytes: 101530 KByte/s Tx, 115357 KByte/s Rx.
Packet size 32k bytes: 106737 KByte/s Tx, 115748 KByte/s Rx.
Done.
Und mit den Einstellungen, die dort stehen, fliegt er noch höher? Dein Ernst?
Das geht da doch um Breitband-Internetverbindungen.
Bitte warten ..
Mitglied: jsysde
05.07.2013 um 16:54 Uhr
Mahlzeit.

Zitat von Cthluhu:
[...]Wenn der Zugriff auf Netzwerkfreigaben kontinuierlich langsamer wird, kann das z.B. an voll werdenden Festplatten am Dateiserver
liegen. Oder an Ordnern liegen welche viele Dateien (meist ein Problem ab einigen Hundert Dateien im Ordner) beinhalten.
Der Füllstand einer Platte hat null Einfluss auf die Performance, weder beim Lesen, noch beim Schreiben. Die Platte ist so lange schnell (oder langsam), bis sie vollständig voll geschrieben wird.

Das Auflisten eines Verzeichnisses kann in Abhängigkeit von der Anzahl der Dateien im Verzeichnis dann allerdings wirklich länger dauern.

Cheers,
jsysde
Bitte warten ..
Mitglied: bronkz
05.07.2013 um 21:40 Uhr
Zitat von jsysde:
Mahlzeit.
Der Füllstand einer Platte hat null Einfluss auf die Performance, weder beim Lesen, noch beim Schreiben. Die Platte ist so
lange schnell (oder langsam), bis sie vollständig voll geschrieben wird.
Man sollte vielleicht anmerken, dass dies nicht für SSDs gilt. Dort spielt der Füllständ der Platte sehr wohl eine Rolle.

Gruß
bronkz
Bitte warten ..
Mitglied: aqui
06.07.2013, aktualisiert um 08:06 Uhr
.@DWW
Oha...schlechte Karte was das Senden von kleinen Paketen (und das sind 80% im Netzwerk Betrieb !) anbetrifft !
Das ist vermutlich keine Realtek basierte Karte bei diesen Werten....
Spass beiseite... nein, du hast natürlich zweifelsohne Recht. Allerdings ist zu vermuten das die Windowsize bei dir vermutlich korrekt gesetzt ist oder du hast einen Treiber mit Offload Option bei deiner Hardware. Hast du das mal in der XP Registry nachgesehen ?
Das Tunen war auch jetzt eher auf Massenhardware ala Realtek Chipsatz usw. bezogen wie die ct' das ja auch beschreibt.
Bitte warten ..
Mitglied: Akcent
06.07.2013 um 12:13 Uhr
Zu erst einmal Danke für das zahlreiche Antworten.

Es gibt einen phy. Server (HP ProLiant ML380) mit 12 GB RAM auf diesem ist Windows 2003 Enterprise installiert
Dann existiert ein VMware Server 1.x auf welchem dann 4 Gast- Windows 2003 Server laufen. War zu der damaligen Zeit aktuell und ist auch immer ohne Probleme gelaufen) Ich weiß .... altes VM, aber wie heißt es doch so schön. Never touch a running system.

RAM Aufteilung:
Host = 3 GB (lt. TaskManager)
Gast 1 = 2 GB (Mailserver)
Gast 2 = 2 GB (FileServer)
Gast 3 = 2 GB (WWS)
Gast 4 = 1 GB (Lizenz-Server CAD)
CPU-Auslastung Host = 10 - 15%

Mit NetIO von einer anderen phy. Maschine auf den File-Server habe ich diese Werte:
Packet size 1k bytes: 41.53 MByte/s Tx, 32.34 MByte/s Rx.
Packet size 2k bytes: 43.44 MByte/s Tx, 32.35 MByte/s Rx.
Packet size 4k bytes: 44.24 MByte/s Tx, 47.29 MByte/s Rx.
Packet size 8k bytes: 43.27 MByte/s Tx, 59.53 MByte/s Rx.
Packet size 16k bytes: 44.36 MByte/s Tx, 52.59 MByte/s Rx.
Packet size 32k bytes: 41.76 MByte/s Tx, 32.89 MByte/s Rx.

Als Switch ist ein HP V1910 48Port im Einsatz.
Bitte warten ..
Mitglied: DerWoWusste
06.07.2013, aktualisiert 07.07.2013
Sei so gut und beschreib doch mal, was Du meinst mit "Zugriff, der seit ein paar Monaten immer langsamer wird". Nur so kann man Dir helfen. Beschreib das so genau wie möglich, dazu gehören Zahlen, die über Deinen Benchmark hinaus gehen und den Verfall der Geschwindigkeit beschreiben. Wie war es einst, wie ist es jetzt? Wenn Du diese Zahlen nicht hast, dann beschreibe genau, warum Du sicher bist, dass es so ist und schätze den Verfall halt.

In muss aus meiner Erfahrung heraus jsysde widersprechen, schwankende Performance von Fileservern hängt unter anderem ab von
-Fragmentierung (und die kann bei gut gefüllten Platten durchaus deutlich höher sein, als bei leeren)
-Anzahl der Dateien/Größe des Masterfiletables
-zudem auch von der Lage der Daten auf der HDD (welche auch mit dem Füllstand zu tun hat), denn im Innenbereich der Scheiben liest die Platte deutlich langsamer als außen, Geschwindigkeitshalbierung ist dabei durchaus möglich und kann auch mit Benchmarks, die über die gesamte Platte schreiben/lesen nachgewiesen werden.

--
@aqui - dazu kann ich erst Montag mehr sagen.
Bitte warten ..
Mitglied: aqui
06.07.2013, aktualisiert um 23:46 Uhr
@Akcent
Ist das ein GiG Switch ? Dafür sind das ja recht mickrige Werte ! Das sind im Mittel ja gerade mal sehr dürftige 380 Mbit/s.
Für ein GiG Netzwerk sind das grottenschlechte Werte ! Kein Wunder das da was langsam ist.
Da ist irgendwas oberfaul...oder du fährst billige Realtek Chipsätze auf der Server NIC, oder das Netzwerk loopt irgendwie ?!
Ist Spanning Tree auf der HP Gurke an ?
Bitte warten ..
Mitglied: Akcent
07.07.2013 um 09:38 Uhr
@aqui: ja ist ein GB-Switch
Zum Einsatz kommt eine Broadkom LAN-Karte die im HP ProLiant Server eingebaut ist. Ich habe aber festgestellt, daß die Treiber von 2007 sind es es neue von 2010 gibt, die ich nun einmal installieren werden inkl. aller Firmware Updates.

Zuvor war dort ein Netgrear GB-Switch (unmanaged) eingebaut. Wegen Spanning Tree muß ich mal schauen wo ich das prüfen / einstellen kann.
Bitte warten ..
Mitglied: aqui
07.07.2013, aktualisiert um 13:53 Uhr
Mach nach dem zwingenden Treiber Update mal einen Back to Back Test mit dem Testclient !
Schliesse den also einmal ohne Switch direkt mit einem NIC zu NIC Kabelverbindung an den Server an und einmal mit Switch dazwischen.
So kannst du wasserdicht feststellen ob der Switch der böse Buhmann ist.
Bei so einer NetGear Billiggurke kann man nie wissen....

Beim Testclient solltest du nicht gerade einen XP rechner nehmen mit Realtek NIC Chipsatz. (Oder nimm den top getunten vom Kollegen Dww )
Such dir einen Win 7 Rechner der Marvell, Broadcom oder Intel Hardware hat und teste damit die Performance zum Server.
Auch der Client sollte die neuesten Treiber am besten von der Chipherstellerseite haben !!
Dann poste die Messadaten hier mal.
Bitte warten ..
Mitglied: DerWoWusste
07.07.2013 um 12:11 Uhr
Kein Feedback zu meinem Beitrag?
Bitte warten ..
Mitglied: Akcent
07.07.2013 um 21:55 Uhr
Zitat von DerWoWusste:
Sei so gut und beschreib doch mal, was Du meinst mit "Zugriff, der seit ein paar Monaten immer langsamer wird". Nur so
kann man Dir helfen. Beschreib das so genau wie möglich, dazu gehören Zahlen, die über Deinen Benchmark hinaus
gehen und den Verfall der Geschwindigkeit beschreiben. Wie war es einst, wie ist es jetzt? Wenn Du diese Zahlen nicht hast, dann
beschreibe genau, warum Du sicher bist, dass es so ist und schätze den Verfall halt.
Ich habe leider keine Zahlen und kann das nur vom Kunden wieder geben. Er lädt z.B. CAD Zeichnungen oder auch der Zugriff auf das WWS hätten sich verlangsamt

In muss aus meiner Erfahrung heraus jsysde widersprechen, schwankende Performance von Fileservern hängt unter anderem ab von
-Fragmentierung (und die kann bei gut gefüllten Platten durchaus deutlich höher sein, als bei leeren)
-Anzahl der Dateien/Größe des Masterfiletables
-zudem auch von der Lage der Daten auf der HDD (welche auch mit dem Füllstand zu tun hat), denn im Innenbereich der Scheiben
liest die Platte deutlich langsamer als außen, Geschwindigkeitshalbierung ist dabei durchaus möglich und kann auch mit
Benchmarks, die über die gesamte Platte schreiben/lesen nachgewiesen werden.
Habe mal die HD defragmentiert. Mal abwarten wir das Feedback ist.
Bitte warten ..
Mitglied: DerWoWusste
08.07.2013, aktualisiert um 13:06 Uhr
Noch ein Feedback an aqui:
Das Test-xp war eine VM. Nun habe ich erneut gebenchmarkt mit win7 (ebenso vm auf dem selben Host), da sieht es tatsächlich deutlich besser aus bei kleinen Paketen (selbe virtuelle Netzwerkkarte):
TCP connection established.
Packet size 1k bytes: 101.80 MByte/s Tx, 108.72 MByte/s Rx.
Packet size 2k bytes: 107.98 MByte/s Tx, 110.35 MByte/s Rx.
Packet size 4k bytes: 111.32 MByte/s Tx, 112.64 MByte/s Rx.
Packet size 8k bytes: 108.15 MByte/s Tx, 112.58 MByte/s Rx.
Packet size 16k bytes: 108.75 MByte/s Tx, 112.61 MByte/s Rx.
Packet size 32k bytes: 110.18 MByte/s Tx, 112.98 MByte/s Rx.

Ob nun ein Tuning bei ihm helfen würde? Schon möglich, aber sein Problem ist ja erst gekommen, zunächst bestand es nicht.
--
@Akcent:
Du brauchst mehr Messwerte. Teste im Vergleich dazu mit leeren Systemen (testserver, testclient, ruhig die selben OS, nur Servicepacks und aktuelle treiber installieren, keine weitere Software).
Bitte warten ..
Mitglied: aqui
08.07.2013, aktualisiert um 16:36 Uhr
.@DWW
Deine Werte sind aber sogar bei einer VM um Klassen besser als die vom Kollegen Akcent die ja nun wahrlich im alleruntersten Keller liegen. Da ist ja sogar ein XP mit alter Hardware und Realtek noch besser...
Irgendwas ist da also bei ihm grundsätzlich ziemlich im Argen.... Ein HD Defragmentieren ist da eher ein netter aber hilfloser Versuch der mehr laienhaft ist als sinnvoll. Zu erwarten ist das das rein gar nix bringt aber warten wir mal ab.
Wie gesagt...es braucht mehr Messwerte dafür !
Bitte warten ..
Mitglied: Akcent
08.07.2013 um 21:50 Uhr
habe eben einmal einen Test gegen den Host und einen anderen Windows 2003 Server gemacht.
Hier komme ich ca. 100 MBit/s

Ergo liegt das Übel am uralten VMware Server 1.0.7

Jetzt muß ich überlegen was wir machen
- Vmware Workstation 9 kaufen
- schauen wo man eine 1.0.9 her bekommt und hoffen, daß die etwas besser läuft.

Langfristig wäre ein Upgrade auf Windows 2012 mit Hyper-V wohl die beste Variante
Der Host braucht leider noch ein Windows, da hier eine 4-Port ISDN-Karte zum Einsatz kommt.
Bitte warten ..
Mitglied: DerWoWusste
08.07.2013 um 23:45 Uhr
Moment mal.
Hier komme ich ca. 100 MBit/s
Das ist doch weitaus weniger. Oder sprichst Du von MBit, meinst aber MByte?
Ergo liegt das Übel am uralten VMware Server 1.0.7
Auch diese Schlussfolgerung ist nicht nachvollziehabr. Du hattest deutlich einen Verfall beschrieben - oder war es nie schnell gewesen?
Bitte warten ..
Mitglied: Akcent
09.07.2013, aktualisiert um 15:42 Uhr
Sorry meine MByte

Teste gerade mal die neuste VMware Workstation
Hmm ... habe mal Vmware Workstation auf einem anderen Server installiert und damit getestet. Leider keine Verbesserung.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Netzwerkmanagement
Schlechte Performance im Heimnetz - Optimierungsmöglichkeiten (38)

Frage von Matthias182 zum Thema Netzwerkmanagement ...

Visual Studio
gelöst Remotedienst prüfen mit Visual Basic (1)

Frage von flyingmichael zum Thema Visual Studio ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...