Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Performance-Probleme bei HP HBA und ESXi 5.1

Frage Hardware Benchmarks

Mitglied: No.INI

No.INI (Level 1) - Jetzt verbinden

21.03.2016 um 17:00 Uhr, 1221 Aufrufe, 3 Kommentare

Hallo Zusammen,

habe ein Performance-Problem und versuchte einen Beitrag zu finden, der dies ähnelt (Link).
Ich wurde gebeten ein neuen Thread zu beginnen.

Nun hoffe ich auf wertvolle Tipps oder Hinweise:

Istzustand:
- HP ProLiant DL180 G6 (2HE)
- 24GB RAM
- 2x Xeon 4c
- P212 256MB Cache - Ohne batterie (Cache deaktiviert)

Backplane der Disks 4-Fach SATA 3,5 Zoll
Habe angeschlossen 3x 3TB Disks: Die Karte hat's angenommen: Raid5 zeigt korrekt 6TB Nutzbar.
ESXi 5.1 - HP Version installiert und die Konfiguration weitestgehend Default belassen. (Das Ganze ist noch keine Produktiv-Umgebung)

Test-weise Windows 7-64 als gast eingerichtet und max möglichen RAM zugewiesen.
Raid aufbauen lassen (FYI: hat ca. 1,5 Tage gedauert)
ESXi, sowie die Maschine sind auf dem Raid.
Separaten V-Disk (auf dem Raid) erstellt und angehängt (10GB).

Egal, ob das Erstellen der dummy files auf der V-Disk, oder kopieren übers Netzwerk: Die Datenrate steigt im Durchschnitt nicht über 28 MB/s.
Das ist selbst für die niedrige Anforderungen, die an diesem Svr gestellt werden zu gering.
ich habe mit 7200er Disks und dedizierter Raid-Controller mehr erwartet (mindestens doppelt so viel).

Nun zu meine Fragen:
-- Hat das evtl. mit dem 1TB< Disks zu tun (was ich persönlich nicht glaube)?
-- Anderweitig eine Idee, die zur Besserung des Zustandes beitragen könnte?

Für jeden konstruktiven Hinweis wäre ich herzlich dankbar.

Grüße
Mitglied: broecker
21.03.2016, aktualisiert um 17:58 Uhr
ohne Batterie und mit Consumer-Sata-Platten sind die 30MB normal! Die Prüfblöcke müssen immer geschrieben werden, d.h. jede Schreiboperation wird auf drei Festplatten (die sich nicht synchron drehen) geschrieben werden.
Sorry, Batterie bitte nachrüsten - 30 Euro in der Bucht
- Das Backupsystem ist auf die 6TB ausgelegt?!!!
HG
Mark
Bitte warten ..
Mitglied: SamvanRatt
21.03.2016 um 21:36 Uhr
Hi
wie Mark schon richtig schreibt: ohne CBM/Batterie schaltet der RAID Controller jeden Cache (wegen evtl Datenverlust) ab=> kein Array Cache, kein HD Cache. Sprich die HD liest viele Sektoren, verwirft jeden nicht gefragten und geht zum nächsten Stripe/Cluster über. Der HBA macht das selbe erneut, sprich im schlimmsten Fall hast du bei einem 7k2 System etwa 180 IOPS; durch RAID5 geht die Latenz um Wurzel der Members hoch und die IOPS runter , also bleiben so 100 übrig. Je nachdem welche Clustersize du eingestellt hast (64kB wäre so üblich) bleiben dann 100*64kB=6,4MB/s was dir im schlimmsten Fall passiert; das mal zwei (nutzbare Members) sind 30MB/s durchaus OK. Mit Cache (stell den mal im CPU ab L1+L2+L3 und du bist in der "Steinzeit") ist schnell das 100fache möglich da nicht jeder Auftrag sofort vergessen wird und WriteBack nutzbar ist. Die hohen 30MB/s sind schon da ESX cached was der RAM hergibt und immer 1MB große Blöcke gelesen werden.
ESX lebt von der Hardware unter ihr. Allein schon das Array erstellen (36h) hätte mich stutzig gemacht. Mein neues Infortrend System mit den naja recht langsamen He8 Serien (eine HD zum auslesen dauert schon 7h) dauert bei 16 Members eines RAID6 etwa 16h. Durch das DoubleParity wird aber jeder Block doppelt angefasst, was dann nahe der Einzelgeschwindigkeit geht, sprich Controller und Durchsatz sind Non-Blocking
Je nachdem wie schnell deine 3TB HDs sind (moderne Dual pLater sind ja deutlich schneller als alte 5 Plater vor 4 Jahren), kannst du da schon was drehen, aber ohne Cachefunktionen ist ein hostRAID nicht besser dran (der kann dann wenigstens auf den Hauptspeicher zugreifen, wie mdadm oder zfs).
Bei mir fällt in Kürze ein DL380G6 weg (brauche viel mehr RAM, daher kommt ein G9 rein); da kann ich den Zusatz P410 dir evtl abgeben (den Rest versetzte ich auch via ebay). Bin jetzt nicht sicher ob dein DL180 den verschlucken kann. Der kommt natürlich mit Batterie und CBM
Gruß
SAm
Bitte warten ..
Mitglied: No.INI
22.03.2016 um 05:38 Uhr
Hallo Mark,
Hallo Sam,

erstmal vielen Dank für die akkurate und professionellen Antworten - einige der Wenigen Boards, bei den man diese noch erwarten könnte!
Ja die Batteriekosten waren kein großes Problem und ich habe sie auch gleich nach meinem Beitrag bestellt. Sollte heute ankommen und ich werde sie heute testen und natürlich Berichten.

Tatsächlich soll auf dem System ca. 20 konstanten Streams á 6Mbit/s gespeichert werden. Die Anforderung ist also wirklich nicht hoch weshalb ich mich hierzu entschieden habe. Jedoch habe ich mit min. 50 MB/s gerechnet.

Den P410 habe ich Bereits in einer anderen Maschine und kenne die relative gute Leistungen von ihr.
Wäre aber dennoch nett, wenn du mir die Links zu deinen Ebay-Angeboten sendest. Könnte vielleicht noch was gebrauchen.

Grüße
Tim
Bitte warten ..
Ähnliche Inhalte
SAN, NAS, DAS
Performance Probleme bei MSA P2000 (6)

Frage von Kalma73 zum Thema SAN, NAS, DAS ...

LAN, WAN, Wireless
Proxy Performance-Probleme Testmöglichkeiten (4)

Frage von clubmate zum Thema LAN, WAN, Wireless ...

Windows Server
Sporadische Performance-Probleme auf RDS-Server (13)

Frage von Datenreise zum Thema Windows Server ...

Server-Hardware
HP Proliant ML30 + HPE H240 Probleme (7)

Frage von Sauropode zum Thema Server-Hardware ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(12)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Windows 10
Windows für Privatanwender "nicht mehr handhabbar" (28)

Frage von FA-jka zum Thema Windows 10 ...

LAN, WAN, Wireless
Brauche Hilfe: Mit (schnellem) WLAN Strecke überbrücken (23)

Frage von pierrehansen zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
Komplett neues Netzwerk, Ubiquiti WLAN, Router, Switch (15)

Frage von Freak-On-Silicon zum Thema LAN, WAN, Wireless ...

Backup
Backup Wochen- Monats- Jahressicherung (13)

Frage von Meterpeter zum Thema Backup ...