Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Permanente Route wird nach jedem Neustart geändert

Frage Netzwerke Router & Routing

Mitglied: Rayknox

Rayknox (Level 1) - Jetzt verbinden

14.08.2008, aktualisiert 15.08.2008, 6403 Aufrufe, 5 Kommentare

Hallo zusammen,

ich habe ein Problem mit einem Windows 2003 R2 Server. Das BS (=Betriebssystem) ist auf einem Blade installiert mit drei Netzwerkkarten.

NIC 1: 172.14.16.30 /24
NIC 2: Nicht verbunden
NIC 3: 172.14.16.90 /24

Das Blade steht in einer DMZ und um einen Zugriff auf das BS zu bekommen, muss auf dem Blade eine permanente Route hinzugefügt werden.

Ich trage die Route ein mit dem Befehl "route add 10.10.0.0 mask 255.255.0.0 172.14.16.90 IF 0x10005 -p" ein. Wenn ich mit die Routingtabelle ausgeben lassen, ist alles korrekt eingetragen und habe auch zugriff per RDP. Starte ich den Server neu, ist die permanente Route zwar noch vorhanden, Ziel, SNM und Gateway sind noch korrekt, allerdings ist die NIC Falsch. Statt der NIC 3 ändert das BS das Interface auf die NIC 1 ab.

Gibt es eine Möglichkeit, das so zu ändern, dass er statt NIC 3 NIC 1 nimmt???

Danke schon mal...

MfG Rayknox
Mitglied: harald21
14.08.2008 um 15:26 Uhr
Hallo,

nach deinen Angaben befinden sich NIC1 und NIC3 im selben Subnetz 172.14.16.0/24.
Wozu benötigst du denn beide?

Die Hilfe zum Befehl "route add" gibt folgende Befehlssyntax aus:
route add DESTINATION mask SUBNETMASKE GATEWAY if INTERFACE

Dabei ist GATEWAY das Gateway für diese Route (next hop), bei dir entspricht das allerdings der IP-Adresse des lokalen Interfaces. Irgendwie verwirrend???


mfg
Harald
Bitte warten ..
Mitglied: aqui
14.08.2008 um 17:44 Uhr
Genau das ist das Problem wenn keine Netzwerkbrücke zwischen den beiden NICs 1 und 3 definiert ist, denn so ohne diese Brücke kann es niemals funktionieren da beide NICs in der Tat in ein und demselben IP Netzwerk liegen was so nicht supportet ist ohne diese Brücke.

Generell sollte man ein Bridging auf Server NICs unbedingt unterlassen, da so alle Broad-, Uni- und Multicast Pakete die in einem Winows Netzwerk nicht unerheblich sind, in diesem Netzwerk dann komplett über den PC Bus übertragen werden müssen (Bridge Funktion) und das Server System damit erheblich belasten.
Entweder hast du also enen IP Design Fehler begangen oder vergessen das Bridging (Netzwerkbrücke) einzurichten.

Wenn du trotz Nachteile doch unbedingt Bridgen musst, dann hast du keinerlei Einfluss mehr über welche NIC deine Pakete raus- oder rein gehen, denn das ist dann einzig und allein abhängig von der MAC Adresse des Endgerätes und an welchem Adapter diese dann gesehen wird !!
Bitte warten ..
Mitglied: Rayknox
15.08.2008 um 07:22 Uhr
Es hat sich mal der Fehlerteufel eingeschlichen!

Das Gateway ist die 172.14.16.65 und nicht die 90.
Bitte warten ..
Mitglied: harald21
15.08.2008 um 13:48 Uhr
Hallo,

das macht keinen Unterschied, die Adressen sind alle im selben Subnetz 172.14.16.0/24

172.14.16.30/24 (NIC1)
172.14.16.90/24 (NIC3 alt)
172.14.16.65/24 (NIC3 neu)

mfg
Harald
Bitte warten ..
Mitglied: aqui
15.08.2008 um 15:24 Uhr
Richtig !!! Solange du das nicht sauber anpasst wie oben bereits beschrieben wird dein Problem weiter bestehen bleiben !
Bitte warten ..
Ähnliche Inhalte
Microsoft
Eintragen mehrerer permanenter Routen
Frage von funcarverMicrosoft4 Kommentare

Servus ich habe das Problem das auf einem Rechner 2 permanente Routen eingetragen werden müssen. Das Problem ist, das ...

Linux Netzwerk
CentOS 7: Permanente Route hinzufügen
gelöst Frage von honeybeeLinux Netzwerk8 Kommentare

Hallo, das Hinzufügen der Hostroute hat geklappt - danke! Leider wird das aber nicht dauerhaft abgespeichert. Ich habe unter ...

Router & Routing
Router: Oft keine Wlanverbindung bis Neustart
Frage von sfera-haizaRouter & Routing8 Kommentare

Hi, ich habe einen D-LINK DIR-615 und habe zzt. Probleme mit dem Verbindungsaufbau bei WLangeräten. Vorgeschichte: Ich wollte den ...

Router & Routing
Nach jedem PC-Neustart ist ein Router-Neustart notwendig (kein Internetzugriff)
Frage von equalizerRouter & Routing13 Kommentare

Hallo zusammen, ich habe derzeit ein immer wiederkehrendes Problem mit meinem Router (o2 Box 6431) . Nach jedem Neustart ...

Neue Wissensbeiträge
Mac OS X

MacOS wo ist die Tilde ?

Tipp von Alchimedes vor 10 StundenMac OS X1 Kommentar

Hallo, ich hab eine MacOS qwertz Keyboard auf US Layout umgestellt da die Sonderzeichen besser erreichbar sind. Leider fehlt ...

Datenschutz

Weitere Informationen zum Sicherheitsproblem BeA

Information von Penny.Cilin vor 17 StundenDatenschutz

Im folgenden ein weiterer Bericht über die Sicherheitsprobleme von Bea. Fataler Konstruktionsfehler im besonderen elektronischen Anwaltspostfach Gruss Penny

Windows 10

Systemdienste behalten nach Win10 inplace-Upgrade nicht die ggf. modifizierte Startart bei

Tipp von DerWoWusste vor 19 StundenWindows 103 Kommentare

Stellt Euch vor, Ihr habt ein Win10 System und modifiziert dort die Startart von Systemdiensten. Zum Beispiel wollt Ihr ...

Microsoft Office

Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei

Anleitung von SarekHL vor 22 StundenMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...

Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von fyrb38Windows 1018 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...

Microsoft Office
Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei
Anleitung von SarekHLMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...