Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

PfSense und Load Balancing mit 2 DSL Anschlüssen

Frage Netzwerke

Mitglied: Coachi81

Coachi81 (Level 1) - Jetzt verbinden

24.03.2011 um 13:00 Uhr, 8860 Aufrufe, 13 Kommentare, 1 Danke

Hallo,

ich habe pfSense 1.2.3 auf einem Rechner mit 2 DSL Anschlüssen installiert. Kann man die 2. DSL Leitung (opt1)
auch direkt mit PPPOE konfigurieren so wie die 1. DSL Leitung? Bei mir gibts da nur die Möglichkeit "DHCP" oder
"Static" auszuwählen. Heisst also das der externe Router die Verbindung aufbauen muss???

Jetzt wollte ich Load Balancing auf den beiden "WAN" Schnittstellen konfigurieren doch leider klappt das nicht. Der Status vom Load Balancing zeigt
mir bei beiden Verbindungen online aber wenn ich eine abstecke ist das Inet weg. Und zwar funktioniert die WAN Schnittstelle
aber die opt1 nicht so wie es ausschaut obwohl beide eingewählt sind. Was muss man genau einstellen oder kennt jemand eine Anleitung zu meinem Problem?

Und noch eine dritte Frage, kann man (vorausgesetzt das Load Balancing funktioniert), bestimmte Rechner immer über eine bestimmte Schnittstelle (opt1 oder WAN)
ins Internet routen? Evtl über die Firewall mit einer Regel???

Hoff ihr könnt mir helfen

Mit freundlichen Grüßen
Mitglied: aqui
24.03.2011 um 19:50 Uhr
Hast du DAS hier gelesen ???
http://doc.pfsense.org/index.php/Multi_WAN_/_Load_Balancing
2 mal PPPoE ist in der Tat nicht möglich. Nimm sonst einfach statt eines Modems dann einen Router am 2ten Port der das PPPoE erledigt. Damit klappt das dann problemlos..ebenso wenn man 2 Router verwendet natürlich.
Und ja ...man kann Endgeräten im lokalen LAN per Policy immer eine feste WAN Schnittstelle zuweisen !
Bitte warten ..
Mitglied: C.R.S.
24.03.2011 um 19:58 Uhr
Zitat von aqui:
Hast du DAS hier gelesen ???
http://doc.pfsense.org/index.php/Multi_WAN_/_Load_Balancing
2 mal PPPoE ist in der Tat nicht möglich.

Mit der 2.0 RC1 ginge das inzwischen.

Grüße
Richard
Bitte warten ..
Mitglied: aqui
29.03.2011 um 16:14 Uhr
OK, wenn die 2.0 dann wirklich 2mal PPPoE auf dem WAN Ports kann dann spricht nichts gegen so ein Design ! Dann musst du aber auch die Option haben "PPPoE" als Encapsulation einzustellen !
Hast du das nicht stimmt die Aussage das es mit 2.0 mit 2 mal PPPoE gehen soll vermutlich nicht !!
Bitte warten ..
Mitglied: Coachi81
30.03.2011 um 15:32 Uhr
Das mit der neuen Version lass ich jetzt erstmal weil der Rechner bereits fertig aufgesetzt ist und auch schon konfiguriert ist, wo wir beim Thema wären.

Hab mom. das Problem dass im Status vom Load Balancer alles als online angezeigt wird und beide Leitungen sich aufbauen allerdings funktioniert
das failover (und vermutlich auch load balancing) nicht. Wenn man die opt1 leitung abzieht geht das inet nach wie vor, wenn ich aber die wan abziehe
geht nichts mehr. Grundlage meiner Konfiguration ist oben genannte Anleitung.

Hat jemand einen Tipp für mich?
Bitte warten ..
Mitglied: Coachi81
11.04.2011 um 11:25 Uhr
Habs jetzt mittlerweile so hinbekommen dass das Load Balancing funktioniert aber das Failover nicht. Hat jemand eine Idee woran das noch liegen könnte? Kann ja nur ne Kleinigkeit sein weil ja beide Leitungen beim Load Balancing hergenommen werden
Bitte warten ..
Mitglied: aqui
11.04.2011 um 11:43 Uhr
Hast du das Failover mal mit einem Link Loss provoziert als z.B. das Kabel an der pfSense abgezogen ?
Meist ist das immer Link Loss besogen und zwar nur lokal. Es hilft also nicht wenn du nur die DSL Strippe ziehst...
Bitte warten ..
Mitglied: Coachi81
11.04.2011 um 14:34 Uhr
Nein ich hab schon direkt an der pfSense das Kabel gezogen und wenn es das "falsche" war dann war auch die Verbindung zum Inet weg
Bitte warten ..
Mitglied: Coachi81
11.04.2011 um 15:21 Uhr
Ich hab das Gefühl das es an den statischen Routen liegen könnte. Ich hab je ISP einen DNS Server bei "General Setup eingetragen. Beide sind nicht pingbar aber ohne funktioniert das Inet gar nicht, also ich denke mal dass das schon passt, oder?
Bitte warten ..
Mitglied: aqui
11.04.2011 um 15:51 Uhr
Um das auszuschliessen, was passiert denn wenn du eine nackte IP dauerpingst im Internet ??
Das wäre ja intelligenterweise ertsmal der simple Basistest um DNS Problematiken erstmal auszuschliessen um das reine Leitungs Failover zu testen.
Hast du das wenigstens mal gemacht ??
Also einfach 193.99.144.85 (heise.de) oder 195.71.11.67 (spiegel.de) dauerpingen und das Kabel ziehen.
Damit stellt sich doch die DNS problematik gar nicht erst... !?!
Bitte warten ..
Mitglied: Coachi81
11.04.2011 um 19:36 Uhr
ja klar hab ich das gemacht, so teste ich ja immer. funktioniert einwandfrei "www.web.de" aber sobald ich eine Leitung abzieh is es vorbei.
Das Load Balancing an sich funktioniert aber meiner Meinung nach schon. Wenn ich z.B. auf www.wieistmeineip.de geh bekomm ich abwechselnd meine beiden öffentlichen IP`s angezeigt.Ein Problem gibt es nur wenn eine Leitung wegfällt.

Aber ist es nicht so das man die Route braucht wenn ein ISP weg ist?
Bitte warten ..
Mitglied: aqui
13.04.2011 um 16:35 Uhr
Ja, aber damit sollte pfSense selber mit klarkommen. Du kannst ja keine statische Route auf einem provider eingeben, dann gibt es kein Load Balancing mehr.
Das er sauber zwischen 2 default Routen balancen kann siehst du ja an der erfolgreichen Verteilung der Sessions bei "wieistmeineip". Das klappt also.
Sessions die auf der ausgefallenen Leitung leigen sollten automatisch, dynamisch auf die 2te Leitung umgebogen werden.
Es ist dabei klar das die aktuell bestehende Session unterbrochen wird und neu aufgebaut werden muss.
Wenn du also eine Session über Leitung 1 hast und die fällt aus und pfSense schickt Folgepakete über den 2ten Link kommen die am Ziel mit einer ganz anderen Absender IP an und daraufhin bricht der Sessionpartner mit einen TCP Reset die Session ab. D.h. du musst neu initiieren. Das ist normales Verhalten.
Bitte warten ..
Mitglied: Coachi81
14.04.2011 um 13:16 Uhr
Ich hab jetzt meine Einstellungen mal abgeändert nach dieser Anleitung "http://doc.pfsense.org/index.php/Multi-WAN_Version_1.2.x".
Doch im Endeffekt ist der gleiche Fehler wieder. Load Balancing funktioniert aber kein Failover. Hier mal Bildschirmabzüge meiner Konfig, vielleicht sieht da jemand einen Fehler

http://mitglied.multimania.de/coachi1/Fwall.jpg
http://mitglied.multimania.de/coachi1/Int.jpg
http://mitglied.multimania.de/coachi1/LB.jpg
http://mitglied.multimania.de/coachi1/Route.jpg

Festgestellt habe ich bei dieser Konfiguration das bei den Firewall Regeln die 2. Regel "make shure dmz2 traffic goes to right wan2 dmz " einen Fehler schmeisst. Ich denk dass das der Grund für das Fehlverhalten sein könnte. Ich hoff jemand kommt damit weiter.
Hier noch ein paar Eckdaten:
192.168.1.230 ist LAN Gateway
192.168.3.99 ist das Gateway von pfSense Richtung Router von DMZ2
192.168.3.1 ist die IP vom Router in DMZ2

DSL Anschlüsse sind einmal T DSL Business Anschluss mit fester IP und ein normaler T DSL Anschluss mit dynamischer IP
Bitte warten ..
Mitglied: Coachi81
14.04.2011 um 18:11 Uhr
Es funktioniert jetzt. Wieso kann ich nicht so genau sagen weil ich viel rumprobiert hab mit DNS Server, Monitor IP Adressen...
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(3)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
gelöst Cisco IOS Load Balancing (2)

Frage von PharIT zum Thema LAN, WAN, Wireless ...

Internet Domänen
gelöst Load-Balancing über eine Domain, ist das möglich? (6)

Frage von D1Ck3n zum Thema Internet Domänen ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...