Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Linux

PHP CLI PDO MySQL Support

Mitglied: VB-NET

VB-NET (Level 1) - Jetzt verbinden

02.04.2009, aktualisiert 15:03 Uhr, 5372 Aufrufe, 7 Kommentare

Hallo,

ich habe folgendes Problem.

Auf meinem Debianserver installiere ich zur Zeit Lilac.

Ich hab alles bisher geschafft in Lilac freizuschalten (also bei der Installation läuft so nen Installscript, wo geprüft wird, ob alles in Ordnung ist.)

Aber an einem Punkt bleibe ich hängen:

CLI PDO MySQL Support

MySQL Support must be provided to PHP's command line interface. This is not the same as the MySQLi extension. Please refer to PHP's PDO documentation for more information.

Leider suche ich schon seit 3 Tagen, was ich freischalten muss o.ä.

Ich komme zu keinem Ergebnis.

Kann jmd. helfen?

Apache V. 2
PHP Version 5.2.6-1+lenny2
Mitglied: godlie
02.04.2009 um 18:43 Uhr
wenn php mit apt-get installierst hast dann installier mal php5-cli nach.
und schau evtl. in der /etc/php5-cli/php.conf mal nach ob die extension geladen ist.
Bitte warten ..
Mitglied: VB-NET
02.04.2009 um 21:53 Uhr
Welche Extension muss geladen werden?

ich lade dort pdo.so, pdo_mysql.so. mysql.so
Bitte warten ..
Mitglied: godlie
03.04.2009 um 07:26 Uhr
Also das müsste es eigentlich sein was ich so sehe.
Das php5-mysql paket dürfte auch installiert sein oder?
Schreib dir mal ein Script das PDO verwendet und für dieses über die cli mal aus, denn dann siehst ob das alles funktioniert oder nicht...
Bitte warten ..
Mitglied: VB-NET
03.04.2009 um 08:02 Uhr
Was für ein Script soll ich nehmen?

ich habe heute alles wieder überprüft und es funktioniert nicht.

muss ich vll. bei ./configure noch etwas hinzufügen?
Bitte warten ..
Mitglied: godlie
03.04.2009 um 09:36 Uhr
Hast du bei configure die --with-pdo-mysql angegeben?
Bitte warten ..
Mitglied: VB-NET
03.04.2009 um 13:42 Uhr
ja habe ich.

er kriegt es dennoch nicht gebacken
Bitte warten ..
Mitglied: godlie
04.04.2009 um 12:00 Uhr
halllo was gibt dir denn ein phpinfo() so aus über pdo?
kannst du mir den configure string mal posten bitte
Bitte warten ..
Ähnliche Inhalte
PHP
PHP PDO Problem
gelöst Frage von Tiggr1994PHP1 Kommentar

Hallo zusammen, Ich versuche gerade PHP zu lernen und bisher klappte es recht gut, jetzt habe ich jedoch ein ...

PHP
PHP Umstellung mysql connect
Frage von DPiegzaPHP7 Kommentare

Hallo zusammen. Ich bekomme immer diese Fehlermeldung / Warnung: Deprecated: mysql_connect(): The mysql extension is deprecated and will be ...

PHP
PHP MySQL Login
Frage von YanmaiPHP7 Kommentare

Hallo ihr Administratoren, ich habe eine Datenbank, in der alle User des Netzwerkes enthalten sind. Wenn ein User sich ...

PHP
MySQL in PHP mit Variablen
gelöst Frage von carl7nPHP10 Kommentare

Hallo, ich habe PHP-Grundkenntnisse, schaffe es aber nicht, nach meinen Vorstellungen ein paar kleine PHP-Scripts zusammen arbeiten zu lassen. ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 4 StundenLinux1 Kommentar

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 23 StundenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 23 StundenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 1 TagSicherheit9 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Netzwerkgrundlagen
Welches Modem für VDSL 50000 der T-Com
gelöst Frage von Windows10GegnerNetzwerkgrundlagen21 Kommentare

Hallo, ein Kollege von mir will sich VDSL50000 von der T-Com holen, um daran einen Server zu betreiben. Ich ...

Sicherheit
Meltdown und Spectre: Die machen uns alle was vor
Information von FrankSicherheit18 Kommentare

Aktuell sieht es in den Medien so aus, als hätten die Hersteller wie Intel, Microsoft und Co den aktuellen ...

Ubuntu
Ubuntu - Starter für nicht vertrauenswürdige Anwendungen
Frage von adm2015Ubuntu17 Kommentare

Hallo zusammen, Ich verwende derzeit die Ubuntu Versionen 17.10 bzw. im Test 18.04. Ich habe mehrere .desktop Dateien in ...

Netzwerke
Packet loss bei "InternetLeitungsvollauslastung"
gelöst Frage von Freak-On-SiliconNetzwerke17 Kommentare

Servus; Ja der Titel klingt komisch, is aber so. Wenn die Internetleitung voll ausgelastet ist, hab ich extreme packet ...