Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

PHP - Grafik wird falsch da gestellt!

Frage Entwicklung PHP

Mitglied: Dani

Dani (Level 5) - Jetzt verbinden

10.10.2006, aktualisiert 11.10.2006, 4042 Aufrufe, 1 Kommentar

Hallo zusammen,

ich bin gerade dabei ein Bild per PHP zuerstellen. Das klappt soweit auch. Das Bild beinhaltet nur eine Hintergrundfarbe mit einem Text. SO, in meiner Testseite wird das Bild einwandfrei dargestellt. Binde ich jetzt den Quelltext (1:1) in meine Seite wird nur folgendes dargestellt:
01.
ÿØÿàJFIFÿþ>CREATOR: gd-jpeg v1.0 (using IJG JPEG v62), default quality ÿÛC    $.' ",#(7),01444'9=82<.342ÿÛC  2!!22222222222222222222222222222222222222222222222222ÿÀn"ÿÄ ÿĵ}!1AQa"q2‘¡#B±ÁRÑð$3br‚ %&'()*456789:CDEFGHIJSTUVWXYZcdefghijstuvwxyzƒ"…†‡ˆ‰Š'""•–—˜™š¢ 
02.
 
03.
£¤¥¦§¨©ª²³´µ¶·¸¹ºÂÃÄÅÆÇÈÉÊÒÓÔÕÖ×ØÙÚáâãäåæçèéêñòóôõö÷øùúÿÄ ÿĵw!1AQaq"2B‘¡±Á #3RðbrÑ $4á%ñ&'()*56789:CDEFGHIJSTUVWXYZcdefghijstuvwxyz‚ƒ"…†‡ˆ‰Š'""•–—˜™š¢£¤¥¦§¨©ª²³´µ¶·¸¹ºÂÃÄÅÆÇÈÉÊÒÓÔÕÖ×ØÙÚâãäåæçèéêòóôõö÷øùúÿÚ ?í®.í­<¯´ÜE› Š?1ÂïsÑFz"éGÚí¾Ùö?´Eö¯/Íò7û3Ûzã\áG«d…J"%9è—_>Šßžº/'j1M6ΦŠ+ϵï_˜õëí:ûPKM;u²´0Ú¤):/ÌÌÅßæe*Ž˜‰É0Øib%Ë—¯›°B››²=¡û]·Û>Çöˆ¾Õåù¾Fñ¿fq»o\gŒÕmöMK@Ó¯æTYnmb™Â3('íÍp^,Óoïþ&Å6'øÔ¬tt»¶BûF[‚ 1ôefÈÎFH­0ØUV¬©Î\¶O_5úNŸ4œ[±èÖ÷v×~oÙ®"›ÊÅ'–á¶8ê§ô¦^êZl"kûË{X™¶žUE-ÉÆIëÁü«øc{¥¦ë·ð«¬W:ÍÄÈÁX!Ç~kKÆÖÖóXi³Üê)§­ž¥  
04.
 
05.
ÂÏ%»Kq¡ðFÕ$Œ± vÏ4å…Œ1^ÂMþ»y\4ªr3jÇVÓuO3û?Pµ»òñ¿ìó,›sœgã8?•\®gJÔo¡ñ…öƒ5ÛêVñZ¥ÐºtE{vc·É}€)$ ã€qž£‘ÓVé{9ÙlÒkçò_‘+ (¢±$*kd¶´·ŠÞÎØ¢@Š¹98É&Š)ÝÚÀ>X£¸…áš4')££¨*Êx ƒÔU _h¶7)si£éöó¦v˲#.F(¢œjN)¤ôcM­¥T%Ñ4›‹·»›K²'æE(ó=ºe+´‚Äd¼}8¢Š#9GávÚعQېÃGjUè)Ÿd¶ûgÛ>ÏÚ¼¿+ÏØ7ìÎvîëŒóŠ(¥ÌÅp·´¶´ó~Ío>l†Y<´ ½ÏV8êO­>X£¸…áš4')££¨*Êx ƒÔQEÎ÷ ÙiöZl& ;{X™·"‚%E-ÀÎëÀüªÍPääîÁ»îQE ?ÿÙ1

Quelltext für das Bild:
01.
/*Erzeugen*/ 
02.
$string = array("A", "B", "C", "D", "E", "F", "G", "H", "I", "J", "K", "L", "M", "N", "O", "P", "Q", "R", "S", "T", "U", "V", "W", "X", "Y", "Z", "a", "b", "c", "d", "e", "f", "g", "h", "i", "j", "k", "l", "m", "n", "o", "p", "q", "r", "s", "t", "u", "v", "w", "x", "y", "z", "1", "2", "3", "4", "5", "6", "7", "8", "9", "0"); 
03.
 
04.
 
05.
  for($i = 1;$i <= 6;$i ++) 
06.
07.
    $position=rand(0, 62); 
08.
    $text.=$string[$position]." "; 
09.
10.
 
11.
 
12.
/*Breite - Höhe*/ 
13.
$pic=ImageCreate(110,22); 
14.
 
15.
/*Schriftfarbe*/ 
16.
$front=ImageColorAllocate($pic,0,0,0);  
17.
 
18.
/*Hintergrundfarbe*/ 
19.
$back=ImageColorAllocate($pic,127,255,0); 
20.
 
21.
/*Erzeugt ein Rechteck*/ 
22.
ImageFilledRectangle($pic, 0, 0, 500, 22, $back);  
23.
 
24.
/*ERzeugt die Schrift*/ 
25.
ImageString($pic, 5, 5, 4, $text, $front);  
26.
 
27.
Header("Expires: Mon, 26 Jul 1997 05:00:00 GMT");  
28.
Header("Content-type: image/jpeg");  
29.
echo ImageJPEG($pic); 
Das kannste läuft bei mir lokal auf XAMPP. Ich hab sowas noch nie erlebt. Ich zähl auf euch... *gg*


Gruß
Dani
[EDIT 19.06.2007]
Thread gelöst und geschlossen
masterG(Moderator)
Mitglied: Dani
11.10.2006 um 21:01 Uhr
Hi,
die Lösung findet ihr hier oder schreibt mir ne PM!
http://www.phpforum.de/forum/showtopic.php?threadid=60870&time=& ...


Gruß
Dani
Bitte warten ..
Ähnliche Inhalte
PHP
gelöst Wie updatet man Php ab auf Windows ? (5)

Frage von rainergugus zum Thema PHP ...

Windows Netzwerk
Benutzername oder Passwort falsch (2)

Frage von Havanna63 zum Thema Windows Netzwerk ...

Batch & Shell
gelöst Batch - PHP - W10 - w7 - w2k8r2 (4)

Frage von Xaero1982 zum Thema Batch & Shell ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(4)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...