Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

PHP Problem mit Formular

Frage Entwicklung PHP

Mitglied: vServer

vServer (Level 1) - Jetzt verbinden

23.02.2015, aktualisiert 24.02.2015, 764 Aufrufe, 6 Kommentare

Hallo,

ich habe ein Formular jedoch ein Problem das später nicht alle Felder weitergegeben werden?
01.
                  <div class="tab-pane" id="content"
02.
                      <form action="" method="post" class="form-horizontal"
03.
                     <input class="form-control" type="hidden" name="id" value="content"
04.
                  	<div class="form-group"
05.
                    	<label class="col-md-3 control-label" for="type">Veranstaltung</label> 
06.
		                <div class="col-md-9"
07.
        		          	<input class="form-control" type="type" name="type" value="<?php if(isset($_POST['type'])) echo $_POST['type'];?>" required="required"
08.
                        </div> 
09.
                    </div> 
10.
                    <div class="form-group"
11.
                    	<label class="col-md-3 control-label" for="size">Nummer</label> 
12.
		                <div class="col-md-9"
13.
        		          	<input class="form-control" type="type" name="number" value="<?php if(isset($_POST['number'])) echo $_POST['number'];?>" required="required"
14.
                        </div> 
15.
                    </div> 
16.
                    <div class="form-group"
17.
                    	<label class="col-md-3 control-label" for="size">Datum</label> 
18.
		                <div class="col-md-9"
19.
        		          	<input class="form-control" type="type" name="date" value="<?php if(isset($_POST['date'])) echo $_POST['date'];?>" required="required"
20.
                        </div> 
21.
                    </div> 
22.
                    <div class="form-group"
23.
                    	<label class="col-md-3 control-label" for="size">Uhrzeit</label> 
24.
		                <div class="col-md-9"
25.
        		          	<input class="form-control" type="type" name="clock" value="<?php if(isset($_POST['clock'])) echo $_POST['clock'];?>" required="required"
26.
                        </div> 
27.
                    </div> 
28.
                    <div class="form-group"
29.
                    	<label class="col-md-3 control-label" for="size">size</label> 
30.
		                <div class="col-md-9"
31.
        		          	<input class="form-control" type="type" name="size" value="<?php if(isset($_POST['ort'])) echo $_POST['ort'];?>" required="required"
32.
                        </div> 
33.
                    </div> 
34.
                    <div class="form-group"
35.
                    	<label class="col-md-3 control-label" for="content">Inhalt</label> 
36.
		                <div class="col-md-9"
37.
        		          	<textarea class="form-control" name="content"><?php if(isset($_POST['content'])) echo $_POST['content'];?></textarea> 
38.
                        </div> 
39.
                    </div>
und hier hab ich das so:

01.
	public function content($type = null, $size = null, $date = null, $clock = null, $ort = null, $content = null) { 
02.
		$this->_data = " 
03.
Veranstaltung: {$type
04.
Nummer: {$size
05.
Datum: {$date
06.
Uhrzeit: {$clock
07.
Ort: {$ort
08.
		 
09.
Inhalt: 
10.
{$content
11.
"; 
12.
	}
aber es werden nur 3 Felder weitergegeben, die anderen Daten bleiben dann im Endformular leer.

Gruß & Danke
Mitglied: Arano
23.02.2015 um 20:13 Uhr
Hi,

in Zeile 31 nennst du das Eingabefeld "size" (name="size") in den PHP-Variablen versuchst du es aber mit "ort". Hier verwendest du wohl ein nicht existierendes Array-Element und bekommst so einen "leeren" wert !
PHP Fehlerausgaben richtig einstellen bzw. wärend des Entwickeln alle Fehler, Warnungen UND AUCH Notizen ausgeben lassen !

In der Funktion wiederum hst du beide Varianten definiert: $size und $ort. Die laut Formular aber ein einzelenes Element darstellen sollten. Darüber hinaus hast du das Eingabefeld "Nummer" (name="number") ganz vergessen.

Vielleicht gibt es auch noch einen Fehler beim Aufrufen der Funktion, aber das können wir nicht sehen.

Kontrolliere also noch mal alle Eingabefeldernamen und Variabelnamen bzw. Array-Indexe !


~Arano
Bitte warten ..
Mitglied: vServer
23.02.2015 um 20:30 Uhr
Hi,

hab es eben schnell hochgeladen, siehe unter Menu "Termine", aber irgendwie passt da noch was nich.

http://www.createqr.de/

mir wird mir sobald der QR erstellt wurde im QR nichts mehr angezeigt nur noch eine leere Seite.

Gruß & Danke
Bitte warten ..
Mitglied: Arano
23.02.2015 um 20:43 Uhr
Hi

aber irgendwie passt da noch was nich.
Ähm... aber das Formular funktioniert jetzt !?

Den zweiten Teil verstehe ich nicht !?
Aber damit meinst du vielleicht das der QR-Code nicht funktioniert !?
Jedenfalls ist der bei mir __nicht__ scannbar. Aber das muss mit dem Formular ja nichts zutun haben.


~Arano
Bitte warten ..
Mitglied: vServer
23.02.2015 um 21:08 Uhr
Welchen QR-Reader hast verwendest du, hast den QR in schwarz oder in einer anderen Farbe gehabt?

Der soll die Daten hier weitergeben und den QR-Code erstellen, das hat er bisher immer gemacht, hab nur die Felder angepasst und mehrere hinzugefügt, jedoch übernimmt er mir nicht alle, da irgendwie die ID's nicht richtig zusammenpassen.

Gruß
Bitte warten ..
Mitglied: Arano
LÖSUNG 23.02.2015, aktualisiert 24.02.2015
Hi vServer.

da irgendwie die ID's nicht richtig zusammenpassen.
Jup, das habe ich ja auch geschrieben. Darum sollst du das auchnoch mal überprüfen, irgendwo hast du da was durcheinander bekommen.
Und solange die Daten nicht korrekt übergeben werde kann natürlicha uch die Weiterverarbeitung fehlerhaft sein.
Also zurück ans formular und die Namen checken sowie alle variablen und Array-Indexe.

Qr Droid von Droidla habe ich.
Ja, zuerst hatte ich den QR in rot, nach den ersten Missversuchen habe ich das aber gleich auf schwarz geändert.
Die beiden QRs im Header lasse sich allerdings problemlos scannen. (Naja gut, der mit dem rot braucht manchmal etwas länger, aber ich bekomme die Kuh zugesicht)

Dann lass dir halt alle Daten ausgeben:
print_r($_POST) oder
print_r($GLOBALS)
vielleicht ein <pre></pre> drum herumm oder im Quelltext schauen was dabei raus kommt. Und dann schauen, wo tauchen die Werte die eingegeben wurden wieder auf und wie heißen dann die Variablen bzw. Indexe.


Schönen Abend noch
~Arano
Bitte warten ..
Mitglied: vServer
24.02.2015, aktualisiert um 18:09 Uhr
Jetzt sollte es funktionieren auf mit QR Droid

hab noch etwas vergessen zu ändern.

Gruß & Danke
Bitte warten ..
Neuester Wissensbeitrag
DSL, VDSL

Telekom blockiert immer noch den Port 7547 in ihrem Netz

(3)

Erfahrungsbericht von joachim57 zum Thema DSL, VDSL ...

Ähnliche Inhalte
Windows Netzwerk
gelöst Problem mit PSexec64 von Sysinternals (4)

Frage von MaxMoritz6 zum Thema Windows Netzwerk ...

Windows Server
gelöst Problem nach DC-Installation unter Server 2012 R2 (9)

Frage von manuel1985 zum Thema Windows Server ...

Windows 10
Problem: einzige Konto gesperrt + Bitlocker aktiv (14)

Frage von Windows11 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...