Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

PHP-Seiten laufen nur mit einleitendem (Fragezeichen) php

Frage Entwicklung PHP

Mitglied: derschakal83

derschakal83 (Level 1) - Jetzt verbinden

04.12.2008, aktualisiert 09:04 Uhr, 7512 Aufrufe, 2 Kommentare

Hallo liebe Administratoren/Administratorinnen

Ich weiß der Titel dieses Beitrags ist absolut dämlich, aber die entsprechenden Sonderzeichen die ich gebraucht hab, funktionieren leider nicht!

Hier kurz die Vorgeschichte:
Ich habe einen neuen "Windows 2003 Standard Server R2 mit SP2" installiert auf dem sich Apache2, MySQL5, PHP5 befindet. Die Apache+MySQL-Installation war hierbei automatisch bei der Installation von OTRS mit dabei und wurde damit in einem Rutsch installiert (OTRS ist ein Trouble-Ticket-System, das wollen wir für die EDV-"Hotline" einrichten).

Also Apache2+MySQL war schon mit dabei, PHP hab ich nach installiert und in der httpd.conf entsprechend eingebunden:

LoadModule php5_module "C:/Programme/PHP/php5apache2_2.dll"

AddType application/x-httpd-php .php
AddType application/x-httpd-php .php3
AddType application/x-httpd-php .php4

DirectoryIndex index.html index.php index.php4 index.phtml index.pl
Das funktioniert soweit auch ganz gut, ein "<?php phpinfo(); ?>" funktioniert einwandfrei und gibt die korrekten Ausgaben.

Das Problem:
sobald ich eine PHP-Datei so anlege: "<? phpinfo(); ?>", also ohne das "php" hinter dem Fragezeichen, erhalte ich nur eine leere Seite. Füge ich das "php" hinter dem Fragezeichen wieder ein, funktioniert es einwandfrei.

An sich wäre das ja nicht so schlimm, wenn man es weiß. Das Problem ist das ich mehrere bestehende PHP-Programme auf diesen neuen Server kopieren muss, und ich dann nicht bei jeder Datei von Hand das "php" rein schreiben kann....

Ich hoffe ihr habt ne Idee, wahrscheinlich ist es ja doch wieder nur ne Kleinigkeit. Bei Google hab ich leider nix gefunden...

Vielen Dank im Voraus!!

Gruß Tobias
Mitglied: Listo
04.12.2008 um 08:26 Uhr
Hallo Tobias,

suche einmal in der php.ini Datei nach folgendem Wert:
'short_open_tag = On'

Sollte der short_open_tag auf Off stehen, so wird der PHP Interpreter die PHP Dateien ohne <?php ?> nicht korrekt interpretieren.

Gruß
Mike
Bitte warten ..
Mitglied: derschakal83
04.12.2008 um 09:04 Uhr
Hallo Mike,

du bist spitze, das wars!

Vielen Dank!!

Gruß
Tobias
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(1)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
PHP
PHP: URL kürzen (14)

Frage von michi-ffm zum Thema PHP ...

PHP
gelöst PHP 7 und LDAP mit Umlauten (3)

Frage von wiesi200 zum Thema PHP ...

Administrator.de Feedback
Entwicklertagebuch: PHP 7 (4)

Information von admtech zum Thema Administrator.de Feedback ...

Entwicklung
Was brauche ich um über PHP eine Oberfläche zu erstellen? (10)

Frage von SIMONJAKOB zum Thema Entwicklung ...

Heiß diskutierte Inhalte
Hyper-V
gelöst Reiner Hyper- V Server oder lieber Rolle (41)

Frage von Winuser zum Thema Hyper-V ...

Linux Netzwerk
gelöst DHCP vergibt keine Adressen (30)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...