Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Linux Ubuntu

GELÖST

PHP updaten auf Ubuntu Host

Mitglied: Dirmhirn

Dirmhirn (Level 2) - Jetzt verbinden

19.08.2008, aktualisiert 06.10.2009, 4816 Aufrufe, 10 Kommentare

Verschoben nach Linux & Unix

Hi!

Habe vor kurzem ein LAMP system aufgesetzt. (Ubutu Server 8.04)

Habe zum entwickeln ein WAMP system.

Jetzt ist mir aufgefallen, dass manche dinge auf LAMP probleme machen. (zB.: header("location: $return_url"); am Ende einer Datei funktioniert auf WAMP problemlos)

Jetzt ist mir aufgefallen dass ich bei WAMP PHP Version 5.2.6 und bei LAMP PHP Version 5.2.4-2ubuntu5.3 laufen habe.

Gibt wie kann ich denn die Version auf Ubuntu updaten (ist das überhaupt möglich?)

lg Dirm
Mitglied: n.o.b.o.d.y
19.08.2008 um 19:57 Uhr
Hallo,

in den akutellen Versionen haben LAMPP und XAMPP beide PHP 5.2.6 mit im Paket. Also einfach updaten und fertig.

Ralf
Bitte warten ..
Mitglied: Dirmhirn
19.08.2008 um 21:21 Uhr
hm "sudo apt-get update"?!
Bitte warten ..
Mitglied: KHP
20.08.2008 um 09:26 Uhr
hi,

"sudo apt-get update"
und
"sudo apt-get upgrade"
oder evtl auch
"sudo apt-get dist-upgrade"

Gruß - Tobias
Bitte warten ..
Mitglied: Dirmhirn
20.08.2008 um 10:21 Uhr
phpinfo() zeigt mir noch immer (nach update, -grade, dist-u und reboot):
PHP Version 5.2.4-2ubuntu5.3

kann es sein dass ich ein repository nicht eingestellt habe?
Wo seh ich denn welche eingestellt sind?

lg Dirm
Bitte warten ..
Mitglied: n.o.b.o.d.y
20.08.2008 um 10:28 Uhr
Hallo,

bekommst Du den über das offizielle Ubuntu-Update wirklich das LAMMP Paket? Mußt Du das nicht von der apachefriends Seite runterladen?

Ralf
Bitte warten ..
Mitglied: Dirmhirn
20.08.2008 um 10:41 Uhr
hm weiß ich nicht.

bin gerade am Vergleichen der phpinfo angaben, kann es sein, dass der "Suhosin-Patch" manche funktionen einschränkt?

lg Dirm
Bitte warten ..
Mitglied: KHP
20.08.2008 um 11:21 Uhr
Du musst die Datei /etc/apt/sources.list editieren und die gewünschten repos entkommentieren ('#' entfernen)
01.
sudo mcedit /etc/apt/sources.list
(setzt Installation vom MidnightCommander voraus -> sudo apt-get install mc)

Hier mal meine sources.list (standard):

01.
deb http://de.archive.ubuntu.com/ubuntu/ hardy main restricted 
02.
deb-src http://de.archive.ubuntu.com/ubuntu/ hardy main restricted 
03.
 
04.
deb http://de.archive.ubuntu.com/ubuntu/ hardy-updates main restricted 
05.
deb-src http://de.archive.ubuntu.com/ubuntu/ hardy-updates main restricted 
06.
 
07.
deb http://de.archive.ubuntu.com/ubuntu/ hardy universe 
08.
deb-src http://de.archive.ubuntu.com/ubuntu/ hardy universe 
09.
 
10.
deb http://de.archive.ubuntu.com/ubuntu/ hardy multiverse 
11.
deb-src http://de.archive.ubuntu.com/ubuntu/ hardy multiverse 
12.
 
13.
# deb http://de.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted unive 
14.
rse multiverse 
15.
# deb-src http://de.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted u 
16.
niverse multiverse 
17.
 
18.
deb http://security.ubuntu.com/ubuntu hardy-security main restricted 
19.
deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted 
20.
deb http://security.ubuntu.com/ubuntu hardy-security universe 
21.
deb-src http://security.ubuntu.com/ubuntu hardy-security universe 
22.
deb http://security.ubuntu.com/ubuntu hardy-security multiverse 
23.
deb-src http://security.ubuntu.com/ubuntu hardy-security multiverse
Tipp: unter http://packages.ubuntu.com kannst Du nach dem gewünschten Paket suchen und die zugehörige Quelle in sources.list freischalten
Bitte warten ..
Mitglied: Dirmhirn
20.08.2008 um 12:31 Uhr
hm ja die passen bei mir auch alle.

zusätzlich gäbe es noch archive.canonical.com das ist aber auskommentiert. eine update mit nicht auskommentierten einträgen hilft auch nichts.

php-versionen habe auch bei http://packages.ubuntu.com nicht gefunden.

aber danke für die Tips.

habe jetzt mein header("location: $return_url"); umgestellt und es funktioniert alles.
ich belasse es halt einmal bei version 5.2.4

ahja kann es sein das PHP einmal nur als Modul für apache und einmal "fix" installiert ist?

lg Dirm
Bitte warten ..
Mitglied: KHP
20.08.2008 um 12:41 Uhr
Ja, ist so. Schau mal hier:

http://wiki.ubuntuusers.de/PHP
Bitte warten ..
Mitglied: Dirmhirn
20.08.2008 um 19:52 Uhr
ah, das ist super!

Danke!

werde ich morgen gleich lesen und ausprobieren.

lg Dirm
Bitte warten ..
Ähnliche Inhalte
Ubuntu
Destination Host Unreachable in Ubuntu
Frage von 120735Ubuntu2 Kommentare

Hallo, ich hatte vor kurzem Ubuntu als Virtuelle Maschine auf meinem Windows 8.1 Rechner installiert. Auf Ubuntu läuft ein ...

Debian
Ubuntu PHP Version 5.4.4
Frage von janosch12Debian

Hallo, ich habe einen Ubuntu Server ( last release ) mit Plesk 12 vor mir, mit der aktuelle PHP ...

Ubuntu
Update auf Ubuntu schlägt fehl
Frage von Philipp711Ubuntu3 Kommentare

Hallo Leute, ich betreibe einen kleinen Nextcloud-Server auf einem Ubuntu 16.04.3 LTS (Linux 4.4.0-104-generic). Der Standardprozedere zum Update des ...

PHP
Homepage nach PHP Update blank
Frage von ric2k17PHP4 Kommentare

Hallo, nach einem PHP Update ist unsere Seite blank. Der dortige Admin schrieb mir Folgendes: Ihre Webseite schient aber ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 8 StundenLinux1 Kommentar

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 1 TagTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 1 TagSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 1 TagSicherheit9 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Sicherheit
Meltdown und Spectre: Die machen uns alle was vor
Information von FrankSicherheit24 Kommentare

Aktuell sieht es in den Medien so aus, als hätten die Hersteller wie Intel, Microsoft und Co den aktuellen ...

Netzwerkgrundlagen
Welches Modem für VDSL 50000 der T-Com
gelöst Frage von Windows10GegnerNetzwerkgrundlagen23 Kommentare

Hallo, ein Kollege von mir will sich VDSL50000 von der T-Com holen, um daran einen Server zu betreiben. Ich ...

Ubuntu
Ubuntu - Starter für nicht vertrauenswürdige Anwendungen
Frage von adm2015Ubuntu17 Kommentare

Hallo zusammen, Ich verwende derzeit die Ubuntu Versionen 17.10 bzw. im Test 18.04. Ich habe mehrere .desktop Dateien in ...

Netzwerke
Packet loss bei "InternetLeitungsvollauslastung"
gelöst Frage von Freak-On-SiliconNetzwerke17 Kommentare

Servus; Ja der Titel klingt komisch, is aber so. Wenn die Internetleitung voll ausgelastet ist, hab ich extreme packet ...