Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

PHP warnings werden nicht angezeigt

Frage Entwicklung PHP

Mitglied: imaginaer

imaginaer (Level 1) - Jetzt verbinden

19.12.2011, aktualisiert 20.12.2011, 2578 Aufrufe, 2 Kommentare

Edit: Das Problem ist gelöst. Es waren nicht die Warnings an sich, die nicht ausgegeben wurden, sondern die Warnings bei Header-Modifikationen. Um die Warnungen auch in solchen Fällen anzuzeigen, muss der Wert output_buffering in der php.ini auf off gesetzt werden.

Hallo zusammen.

Mich plagt seit einer Weile ein kleines Problem und nachdem ich einige Internetrecherchen hinter mir habe und mir nicht einmal klar wird, wo ich noch suchen soll, wende ich mich an das Forum...

Folgendes: Mir werden auf meinem lokalem System keine PHP Warnings angezeigt - was mich ziemlich nervt, da ich die Ausgaben in einer Online-Umgebung habe und ich nicht ständig online gucken möchte, ob nun irgendetwas knallt.

Das Kuriose: Ich habe in der php.ini explizit angegeben, dass Warnungen ausgegeben werden sollen...
Ein paar Einstellungen aus der php.ini:
display_errors On
display_startup_errors On
error_reporting E_ALL | E_STRICT

Allgemeine Angaben zu der Umgebung:
OS: Gentoo
Webserver: Apache 2.2.21
Sprache: PHP 5.3.9 (mod_apache)
(Anmerkung: Ich habe nie wirklich groß an den Konfigurationsdateien Änderungen vorgenommen...)


In der httpd.conf sowie in der Konfigurationsdatei für virtuelle Hosts (00_default_vhost.conf) finde ich auch keine spezifischen Einstellungen, die die Standardwerte aus der php.ini überschreiben...

Kurzes Testscript:
01.
<?php 
02.
	echo "Hallo"
03.
	session_start(); 
04.
?>
Das sollte eigentlich ausgeben: "
01.
[...]Cannot send session cookie - headers already sent by[...]

Hat jemand eine Idee woran es liegen kann oder kann mir zumindest einen Tipp gehen, an welcher Stelle ich mich näher umschauen kann?

Wer noch spezielle Infos oder bestimmte Dateien braucht -> einfach Bescheid geben.

Viele Grüße
Mitglied: dog
19.12.2011 um 19:15 Uhr
Das sollte eigentlich ausgeben: "

Nö, wenn z.B. Output Buffering systemweit aktiviert ist, dann wäre das kein Fehler.
Da solltest du lieber sowas nehmen wie:
01.
<?php echo 5 / 0 ?>
Hast du den Apache nach den Änderungen neu gestartet?
Bitte warten ..
Mitglied: imaginaer
19.12.2011 um 19:47 Uhr
Hallo!

Danke für deine Antwort, das hat mir weitergeholfen, wenngleich auf eine andere Art und Weise

Es ist mir ja schon etwas peinlich, aber Warnings wurden tatsächlich ausgegeben, nur bei Header-Modifikationen gab es eben besagtes Problem der Nicht-Ausgabe (ich habe mich zu sehr darauf fixiert...). Nachdem ich den Wert für das Output Buffering deaktiviert habe, wurden mir auch die gleichen Meldungen wie in der Online-Umgebung ausgegeben...

Ich glaube, nach dem ganzen Tag habe ich einfach den Wald vor lauter Bäume nicht mehr gesehen...

Von daher, Danke für den Hinweis und den Stups in die korrekte Richtung!
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Verschlüsselung & Zertifikate
gelöst Revocation Server innerhalb der PKI wird als offline angezeigt (1)

Frage von Snipes zum Thema Verschlüsselung & Zertifikate ...

PHP
gelöst Php regex und Array (5)

Frage von Thomas91 zum Thema PHP ...

Heiß diskutierte Inhalte
Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...