Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Bei PHP5 Installation auf IIS6.0 (Server2003Standart) nur leere Seite mit Timeout

Frage Internet Server

Mitglied: GeneralGunrider

GeneralGunrider (Level 1) - Jetzt verbinden

09.03.2006, aktualisiert 12.05.2006, 13367 Aufrufe, 8 Kommentare

Hallo!

Ich habe folgendes laut Anleitung schon eingestellt: http://www.peterguy.com/php/install_IIS6.html
- PHP5 nach C:\PHP unzipped
- PECL (Win32) nach C:\PHP
- php_*.dll nach C:\PHP\ext
- php.ini in C:\PHP
- php.ini: extension_dir=C:\PHP und extension php_gd2.dll ist als einzige aktiv
- NTFS für IUSR-Benutzer auf C:\PHP gesetzt

Das is mein Stand.
Soweit ich weis muss man bei den Webseiten in den Eigenschaften die Rechte für "Skripts und ausführbare Dateien" geben,
sowie in der Konfiguration ".php" mit "C:\PHP\php.exe" und Alle eintragen.
Die ISAPI-Filter "PHP" mit "C:\PHP\php5isapi.dll" eintragen.
Dann noch die Webdiensterweiterung "PHP" mit "C:\PHP\php.exe" und "C:\PHP\php5isapi.dll" eintragen.

Als ich das alles gemacht habe, zeigt er mir nach einem Reboot der IIS unter den ISAPI-Filtern "PHP" "nicht geladen" an??
Zudem wenn ich eine Webseite aufrufe, kommt nur eine leere Seite mit andauerndem Laden.....nach 30sec kommt ein Timeout!

Kann mir jemand helfen?
Mitglied: Dani
09.03.2006 um 15:37 Uhr
hi,
mach einfach nach dieser Anleitung. Die geht 1000000%ig!!!
http://www.visualwin.com/PHP-ISAPI/

Gruß
Dani
Bitte warten ..
Mitglied: GeneralGunrider
09.03.2006 um 15:57 Uhr
naja okay hab das ganze aber schon durchgemacht, wobei ich ja PHP >5< verwende und ich dadurch nur nicht auf C:\PHP\sapi\ sonder in das C:\PHP\-Verzeichnis gelinkt habe!

Naja ich versuchs nochmal aber denke nicht dass es hilf - habs ja bereits gemacht!
Bitte warten ..
Mitglied: Dani
09.03.2006 um 17:14 Uhr
Hi,
also, wenn du dich genau an die Anweisungen hälst, geht es!

Gruß
Dani
Bitte warten ..
Mitglied: GeneralGunrider
09.03.2006 um 19:51 Uhr
Sehr informativ! Danke!
So ne dumme bemerkung kann ich mir sparen ;) sry
Bitte warten ..
Mitglied: GeneralGunrider
11.03.2006 um 00:10 Uhr
Achja
Hab mich NICHT an die Anweisung gehalten:

Habe anstatt:
-- sowie in der Konfiguration ".php" mit "C:\PHP\php.exe" und Alle eintragen.
-- Die ISAPI-Filter "PHP" mit "C:\PHP\php5isapi.dll" eintragen.
-- Dann noch die Webdiensterweiterung "PHP" mit "C:\PHP\php.exe" und "C:\PHP\php5isapi.dll" eintragen.
folgendes Eingetragen:
-- sowie in der Konfiguration ".php" mit "C:\PHP\php.exe "%s" %s" und Alle eintragen.
-- Die ISAPI-Filter nicht eingetragen
-- Dann noch die Webdiensterweiterung "PHP" mit "C:\PHP\php.exe "%s" %s" eintragen.

Jetzt bringt er mir CGI-Fehler
Die angegebene CGI-Anwendung hat keinen vollständigen Satz von HTTP-Headern zurückgegeben.
Bitte warten ..
Mitglied: Dani
11.03.2006 um 09:51 Uhr
Guten Morgen,
sorry, wenn ich dich "'nieder gemacht habe"?! Aber jetzt gehts wohl? *g*


Gruß
DAni
Bitte warten ..
Mitglied: GeneralGunrider
11.03.2006 um 10:10 Uhr
Ja wie gesagt, der CGI-Fehler is daraus entstanden...

@Dani: Tud mir leid, aber ich bin durch das ganze ziemlich gestresst
Bitte warten ..
Mitglied: som
12.05.2006 um 14:46 Uhr
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (13)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...