Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

phpmyadmin kann nicht angezeigt werden

Frage Microsoft Windows Server

Mitglied: Franzmann

Franzmann (Level 1) - Jetzt verbinden

04.09.2007, aktualisiert 14:08 Uhr, 7624 Aufrufe, 6 Kommentare

Hallo,
habe auf einem W2K3 Server einen Apachen mit PHP und MySQL installiert.
Ich habe MySQL als Service installiert und es läuft auch wunderbar, ich kann auch über die Eingabeaufforderung wunderbar darauf zugreifen ...
Habe mir nun PhpMyAdmin runtergeladen und in das /htdocs/ Verzeichnis vom Apache geschoben.
Nachdem ich nun http://server/phpmyadmin/ aufrufe, bekomme ich nur eine Liste der Dateien die im phpmyadmin ordner sind aufgelistet.
Ich habe in der config.inc.php folgendes stehen:
01.
$cfgPmaAbsoluteUri = ''; //Pfad, der im Apache VirtualHost angelegt wurde 
02.
$cfgServers[1]['host']          = 'localhost'; // MySQL hostname 
03.
$cfgServers[1]['port']          = '';          // MySQL port - leave blank for default port 
04.
$cfgServers[1]['socket']        = '';          // Path to the socket - leave blank for default socket 
05.
$cfgServers[1]['connect_type']  = 'tcp';       // How to connect to MySQL server ('tcp' or 'socket') 
06.
$cfgServers[1]['controluser']   = 'pma';          // MySQL control user settings 
07.
                                               // (this user must have read-only 
08.
$cfgServers[1]['controlpass']   = '';          // access to the "mysql/user" 
09.
                                               // and "mysql/db" tables) 
10.
$cfgServers[1]['auth_type']     = 'config';    // Authentication method (config, http or cookie based)? 
11.
$cfgServers[1]['user']          = 'root';      // MySQL user 
12.
$cfgServers[1]['password']      = 'meinpasswort';          // MySQL password (only needed 
13.
                                               // with 'config' auth_type) 
14.
$cfg['Servers'][$i]['only_db'] = ''; 
15.
 
16.
$cfgServers[1]['verbose']       = '';          // Verbose name for this host - leave blank to show the hostname 
17.
$cfgServers[1]['bookmarkdb']    = '';          // Bookmark db - leave blank for no bookmark support 
18.
$cfgServers[1]['bookmarktable'] = '';          // Bookmark table - leave blank for no bookmark support 
19.
$cfgServers[1]['relation']      = '';          // table to describe the relation between links (see doc) 
20.
                                               //   - leave blank for no relation-links support
Wo is der Fehler ???
Mitglied: DerBiba
04.09.2007 um 09:22 Uhr
Schau mal in die Conf deines Apache. Der findet bloß keine Indexdatei im phpmyadmin-Verzeichnis.

Entweder definierst du in der conf neben index.html auch index.php (oder so)
oder du legst ne HTML Seite dort ab die die *.php nachlädt (Autorefresh)


Biba
Bitte warten ..
Mitglied: Franzmann
04.09.2007 um 09:29 Uhr
Schau mal in die Conf deines Apache. Der
findet bloß keine Indexdatei im
phpmyadmin-Verzeichnis.

Entweder definierst du in der conf neben
index.html auch index.php (oder so)
oder du legst ne HTML Seite dort ab die die
*.php nachlädt (Autorefresh)


oh hatte vergessen im DirectoryIndex auch index.php und so mit anzugeben.
hab ich nu gemacht. Jetzt hab ich folgendes Problem:

phpMyAdmin - Fehler

Die Erweiterung mysql kann nicht geladen werden. Bitte überprüfen Sie Ihre PHP-Konfiguration. - Dokumentation
Bitte warten ..
Mitglied: Franzmann
04.09.2007 um 12:31 Uhr
Habe die extension=php_mysql.dll noch hinzugeladen.
Die fehlte irgendwie obwohl die standardmässig aktiv sein müsste.
Jetzt hab ich aber das problem das phpMyAdmin funktioniert aber meine php Seiten aufgelistet angezeigt werden und nicht dargestellt im Browser ?!
Bitte warten ..
Mitglied: Franzmann
04.09.2007 um 13:42 Uhr
Habe die extension=php_mysql.dll noch
hinzugeladen.
Die fehlte irgendwie obwohl die
standardmässig aktiv sein müsste.
Jetzt hab ich aber das problem das
phpMyAdmin funktioniert aber meine php Seiten
aufgelistet angezeigt werden und nicht
dargestellt im Browser ?!

Apache restarten und dann läufts ;D
Bitte warten ..
Mitglied: DerBiba
04.09.2007 um 13:46 Uhr
Ich merk schon... lässt man dich mal machen, dann klappts irgendwann auch ohne Hilfe *hihi*
Bitte warten ..
Mitglied: Franzmann
04.09.2007 um 14:08 Uhr
Ich merk schon... lässt man dich mal
machen, dann klappts irgendwann auch ohne
Hilfe *hihi*


Ja aber meine Nerven ;-(
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows 10
Partitonen werden nicht angezeigt (3)

Frage von Alex.Sp zum Thema Windows 10 ...

Windows Server
gelöst GPO wird übernommen aber nicht angezeigt (11)

Frage von stefts zum Thema Windows Server ...

Server
gelöst Internetzugriff auf Synology Diskstation Ordner werden nicht angezeigt (1)

Frage von Coreknabe zum Thema Server ...

Heiß diskutierte Inhalte
DSL, VDSL
gelöst DSL 200m verlängern (16)

Frage von Angela44 zum Thema DSL, VDSL ...

Windows Server
SBS 2011 Standard virtualisieren (11)

Frage von HeinrichM zum Thema Windows Server ...

LAN, WAN, Wireless
Per Script auf UniFi-controller zugreifen und WPA2-Key ändern (11)

Frage von Winfried-HH zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst DHCP Sever MS Server 2012 Problem (10)

Frage von Florian86 zum Thema Exchange Server ...