Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Phymyadmin export.php Missing parameter what und export type

Frage Entwicklung PHP

Mitglied: 65999

65999 (Level 1)

25.03.2010, aktualisiert 11.04.2010, 7539 Aufrufe, 5 Kommentare

Hallo!
Ich bin aktuell dabei, phpmyadmin richtig zu konfigurieren.

Laufen tut alles, wie es eigentlich soll, bis auf die Ausnahme: Exportieren geht nicht!

Jedes mal, wenn ich eine Datenbank exportieren will, kommt folgender Fehler:

01.
export.php: Missing parameter: what (FAQ 2.8) 
02.
export.php: Missing parameter: export_type (FAQ 2.8)
Die Dinge, die in den FAQs stehen, habe ich bereits durchgearbeitet, konnte aber nichts auffälliges finden!
Auch Dinge, die ich im Netz finden konnten, brachten keinen Erfolg

Könnt ihr mir helfen und erklären, wo der Fehler liegt?
Welche Dateien braucht ihr zur Hilfe, die poste ich dann hier?!

Danke euch!
Mitglied: nxclass
25.03.2010 um 20:13 Uhr
... wundere mich das hier noch keine Antwort da ist.

Also ich konnte den Fehler jetzt nicht reproduzieren. Da kann ich nur um mehr Informationen bitten.
  • Server- ,PHP- und phpMyAdmin Versionen ?
  • benutzter Browser ?
  • Javascript aktiviert ?

Also die 'export.php' ist das Script was entweder die Textarea mit dem SQL Code anzeigt oder eben den download der Daten bereitstellt. Kann mir nur vorstellen das es beim Auswählen und Absenden der Formulardaten zu Problemen gekommen ist.

what : ist die Liste mit den Radio-Buttons (SQL, PDF, ...)
export_type : ist ein hidden Input Feld gleich am Anfang des Forms (Standart Inhalt ist: 'database' oder 'server')
... da wird wohl Javascript nicht aktiviert sein !?
Bitte warten ..
Mitglied: 65999
25.03.2010 um 22:54 Uhr
Hallo!
Das Problem konnte ich nun reproduzieren, nachdem ich eine org. php.ini genommen habe, die grundzüge angepasst und den iis resette habe!
danach kam es zu keinen problemen mehr! mache ich aber die richtigen einstellungen, sodass ich auch größere dateien per file upload hochladen kann, so gibt es wieder probleme!

daher nun meine frage:
wie muss die richtige einrichtung der php.ini aussehen, um größere dateien hochladen zu können und trotzdem noch php.ini nutzen zu können!

danke!
Bitte warten ..
Mitglied: nxclass
26.03.2010 um 08:38 Uhr
die grundzüge angepasst und den iis resette
größere dateien per file upload hochladen kann
Evtl. ist es ein Problem beim ISS in Verbindung mit PHP / phpMyadmin - hast Du schon mal die Logs des ISS angeschaut ?

wie muss die richtige Einrichtung der php.ini aussehen, um größere Dateien hochladen zu können und trotzdem noch php.ini nutzen zu können
Also ich kenne mich nicht mit dem ISS aus - aber ich habe ein paar Guides gefunden zu dieser Kombination:

http://www.iis-aid.com/articles/how_to_guides/install_and_configure_php ...
http://shabbir.hassanally.net/blog/2007/10/11/howto-installing-mysql-ph ...
Bitte warten ..
Mitglied: Dani
27.03.2010 um 11:41 Uhr
Hallo @65999,
Ähh...was hat die php.ini mit dem phpMyAdmin zu tun? Eigentlich direkt gar nichts. Mit dieser Konfiguration kannst du die PHP-Laufzeitumgebung anpassen. D.h. es ist ein PHP-Problem an sich.
Für uns interessant ist nun, welche Einstellungen du in der php.ini angepasst hast?


Grüße,
Dani
Bitte warten ..
Mitglied: 65999
29.03.2010 um 15:02 Uhr
Ich habe keine Ahnung, habe nun eine völlig neue php.ini Datei genommen und diese ersetzt! ISS neu gestartet und siehe da, es funktioniert! Gruß und danke!
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Powershell: ActiveDirectory Infos mit export-csv exportieren und formatieren (2)

Frage von MuHMuH zum Thema Batch & Shell ...

Windows Server
gelöst Server Umzug - Export von Rollen und Features in Windows 2008 R2 (6)

Frage von Linux266 zum Thema Windows Server ...

Datenbanken
Phpmyadmin export maximal 50kb groß (4)

Frage von Leo-le zum Thema Datenbanken ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...