Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Ping geht nicht, Traceroute geht, sobald ein traceroute läuft geht der Ping

Frage Linux Linux Netzwerk

Mitglied: Forseti

Forseti (Level 1) - Jetzt verbinden

08.01.2014 um 17:37 Uhr, 3117 Aufrufe, 4 Kommentare

Hallo,

ich hab Verhalten das ich so noch nciht erlebt habe.

Ich möchte in einem internen Netzwerk, einen Linux/Debian Server anpingen um zu checken ob er online ist.

Ich bekomme jedoch keinen Ping reply zurück, wenn ich einen traceroute auf den den gleichen Server mache bekomme ich eine Antwort. Das witzige hierbei ist, sobald der traceroute läuft (1 hop) geht auch der Ping, habe es auch nur durch Zufall entdeckt weil ich ein 'ping -t' habe mitlaufen lassen. Konnte es reproduzieren bei mehreren Server im Netzwerk (die angepingten Server unterliegen nicht meiner Administration).

Dazwischen hängt außer Switches nichts. Nichts was irgendwie auf Application-Firewall Ebene filtern würde.

Gibt es bei Debian etwas was dieses Verhalten erklären würde?

Danke schonmal!
Mitglied: Chonta
08.01.2014 um 17:51 Uhr
Hallo,

sind denn zwischen deinem PC und dem Debian mehr als 1 Hop?
Was ist denn die genaue Ausgabe vom ping?
Wenn Ping nicht geht, Du deinen Arpchacke löshst, dann nen Ping machst, der nicht geht, hast Du trozdem die Macadresse vom Debianserver im Cache?

Arpcache der Switches die dazwischen liegen kann ein Problem haben, das Routing, wenn verschiedene Netze kann auch nicht sauber laufen.
Geht der Ping denn Andersrum sofort bzw gehen andere Dienste wie ssh, http etc immer sofort?

Gruß

Chonta
Bitte warten ..
Mitglied: AndiEoh
09.01.2014 um 09:22 Uhr
Hallo,

prüfen ob du einen Adresskonflikt hast.

- ping auf IPv4 -> ARP cache checken
- traceroute -> ARP cache checken
- ping nach traceroute -> ARP cache checken

Unix meckert zunächst nicht wenn zwei Systeme die gleiche IP Adresse haben, die Auswirkungen sind allerdings teilweise sehr seltsam

Gruß

Andi
Bitte warten ..
Mitglied: Lochkartenstanzer
09.01.2014, aktualisiert um 09:28 Uhr
Moin,

Ich würde einfach einen tcpdump oder wireshark die mitlaufen lassen, um zu schauen, was genau passiert, z.B.
tcpdump -i eth0 -n -X host $zielhost
aufrufen und dann in einem anderen Fenster Deinen ping oder traceroute loslassen.

lks
Bitte warten ..
Mitglied: Lochkartenstanzer
09.01.2014 um 09:34 Uhr
Zitat von Forseti:

Ich bekomme jedoch keinen Ping reply zurück, wenn ich einen traceroute auf den den gleichen Server mache bekomme ich eine
Antwort. Das witzige hierbei ist, sobald der traceroute läuft (1 hop) geht auch der Ping, habe es auch nur durch Zufall
entdeckt weil ich ein 'ping -t' habe mitlaufen lassen. Konnte es reproduzieren bei mehreren Server im Netzwerk (die
angepingten Server unterliegen nicht meiner Administration).

  • Was passiert denn, wenn der traceroute "rum" ist. Hören dann die Pingantworten auf?
  • Wieviele Hops ist denn der Serevr weg?
  • Kannst du sagen, ob die echo-replies sofort mti absetzen des traceroute kommen, oder erst ab einem bestimmten hop?

versuch mal möglichst viel Information zu liefern.

lks
Bitte warten ..
Ähnliche Inhalte
Visual Studio
gelöst C-Sharp MVVM DataContext geht verloren (1)

Frage von mayho33 zum Thema Visual Studio ...

Router & Routing
gelöst WOL über zwei Router - Ping funktioniert nicht (3)

Frage von erdmelone zum Thema Router & Routing ...

RedHat, CentOS, Fedora
gelöst CentOS 7 als Datengrab in Windows-Domäne (SBS2011) geht auf einmal nicht mehr (12)

Frage von sirhc4022 zum Thema RedHat, CentOS, Fedora ...

Windows Server
gelöst Server 2016 VM EVA zu Standard geht nicht (7)

Frage von smeclnt zum Thema Windows Server ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...