Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Ping aus verschiedenen Netzsegmenten

Frage Microsoft Windows Netzwerk

Mitglied: nelson961

nelson961 (Level 1) - Jetzt verbinden

26.08.2008, aktualisiert 27.08.2008, 3691 Aufrufe, 9 Kommentare

Hallo Leute,

folgendes Szenario:

zwei Server mit jeweils zwei Netzwerkkarten. Netzwerkarte Nr. 1 jedes Servers ist mit dem hauseigenen LAN verbunden.
Netzwerkkarte 2 ist per Crosskabel mit der 2. Netzwerkarte des anderen Servers verbunden.

Netzdaten der Netzwerkkarten:

Server 1

NIC 1

IP: 10.34.1.10
Subnetmask: 255.255.255.0
Gateway: 10.34.1.1

NIC 2

IP: 10.0.0.1
Subnetmask: 255.0.0.0


Server 2

NIC 1

IP: 10.34.1.11
Subnetmask: 255.255.255.0
Gateway: 10.34.1.1

NIC 2

IP: 10.0.0.2
Subnetmask: 255.0.0.0

Jetzt mein Problem:

wenn ich einen Ping von einem Rechner mit der IP: 192.*.*.* an die Server sende, antworten sie aber wenn ich einen

Ping von der IP: 10.*.*.* an die Server sende, antworten sie nicht.

Auch wenn ich direkt von den Servern einen Ping an die 10er IPs schicke, antworten sie nicht. Bei den 192ern

funtioniert es.

Kann mir das mal jemand etwas genauer erläutern?!

Danke schonmal!
Mitglied: flaesch
26.08.2008 um 16:25 Uhr
Hallo,

Tippfehler? Keine Deiner NICs hat eine 192er-IP-Adresse. Ist das richtig?

Gruß
flaesch
Bitte warten ..
Mitglied: nelson961
26.08.2008 um 16:35 Uhr
Das ist richtig. Wenn ich von einem Client mit einer 192er IP eine Ping sende, dann geht es.

Die Server haben die oben angegebenen Netzdaten
Bitte warten ..
Mitglied: harald21
26.08.2008 um 16:36 Uhr
Hallo,

meiner Meinung nach ist das Subnetting fehlerhaft:

Der Bereich 10.34.1.X/24 (NIC 1) ist im Bereich 10.0.0.x/8 (NIC 2) enthalten!

Wo sind die Clients mit 192.*-Adressen angebunden? Da muß dann doch noch irgendwo ein Router sein?


mfg
Harald
Bitte warten ..
Mitglied: nelson961
26.08.2008 um 16:45 Uhr
Hallo Harald,

ja die 192er Clients erreichen die Server über einen Router.
Aber auch Clients mit 10er IPs erreichen die Server über Router.

Du meinst, der Ping funktioniert nicht, weil das Subnet von der 2. NIC relativ groß gewählt ist?!
Bitte warten ..
Mitglied: harald21
26.08.2008 um 16:57 Uhr
Hallo,

das hat nichts damit zu tun, ob die Subnetmaske "groß oder klein" gewählt ist, sondern damit, das Bereich 1 Bestandteil des Bereiches 2 ist. Natürlich würde es abhelfen, die Subnetmaske für den Bereich 2 zu korrigieren, aber wichtiger wäre es, ob du das Prinzip der TCP/IP-Adressierung verstanden hast. Wenn du nicht weist, was du tust, dann soltest du die Finger davon lassen, solange alles noch einigermaßen funktioniert.

Wenn auch Client-PC's mit 10.*-IP-Adressen existieren, so frage ich mich wie das Routing überhaupt funktioniert. Hast du evtl. eine Skizze oder einen Netzwerkplan, auf dem das dargestellt ist?

mfg
Harald
Bitte warten ..
Mitglied: JustForFun
26.08.2008 um 22:50 Uhr
wie halrald21 schon geschrieben hat.

gibt es evtl ne skizze dazu.
hast du clients im 10 netz?

Wie hast du die Router konifuriert? type und was lassen sie alles durch? Ping blockiert?
Bitte warten ..
Mitglied: nelson961
27.08.2008 um 09:50 Uhr
Hallo,

die Router haben mit der ganzen Sache nichts zu tun. Die benachbarten Server sind erreichbar.

Ich habe jetzt die IP von der NIC 2 bei beiden Servern in einen ungenutzten 192er Bereich gelegt. Subnetzmaske ist auf 255.255.255.0 eingestellt.

Es funktioniert jetzt!

Wie behandelt Windows die Ping Pakete, wenn die Situation ist, wie ich sie am Anfang beschrieben habe?

Nimmt es die Ping Pakete an, sendet die Antwort über die 2. NIC (bedingt durch die Subnetmaske) und dort landen sie im Nirvana, weil es nur 2 IPs in dem Netz gibt, die nicht die ursprüngliche Antwortadresse sind?!

Ich hoffe, ich habe es halbwegs verständlich dargelegt
Bitte warten ..
Mitglied: harald21
27.08.2008 um 10:20 Uhr
Hallo nelson961,

ja, so ähnlich kann man das beschreiben.

mfg
Harald
Bitte warten ..
Mitglied: nelson961
27.08.2008 um 13:05 Uhr
Alles klar!

Ich danke für eure Antworten!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Google Android
ANDROID - PING (2)

Frage von MrRobot1997 zum Thema Google Android ...

Netzwerke
gelöst Zugriff auf Server von verschiedenen VLANs aus (7)

Frage von Kroeger02 zum Thema Netzwerke ...

Batch & Shell
gelöst Powershell - Dateien aus verschiedenen Arrays - Attribute vergleichen (5)

Frage von Giffas zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...