Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Pop3 Connector langsam

Frage Microsoft Exchange Server

Mitglied: Milli2311

Milli2311 (Level 1) - Jetzt verbinden

23.02.2012 um 13:00 Uhr, 9486 Aufrufe, 14 Kommentare

Hallo zusammen,

Ich habe ein riesen Problem.

Seitdem wir auf SBS 2011 umgestellt haben von SBS 2003, haben wir mit dem POP3 Connector von Microsoft nur noch Probleme..

Das schlimmste ist, er braucht ewig um ein Mail herunterzuladen, wenn der Anhang mal etwas größer ist.

Beispiel: Soeben um 12:07 ging ein Mail online in der Inbox ein mit einem 11 MB Anhang.

Dieses Mail hat er erst eben gerade um 12:45 vollständig heruntergeladen und auch erst dann natürlich mit den anderen e-mails weiter gemacht !

Gibt es im POP3 Connector irgendeine Möglichkeit / Einstellung die die Verbindungsgeschwindigkeit festlegt ?

Also, kann es sein, dass der irgendwie gedrosselt ist ?

Und bitte keine Fragen warum wir noch nicht auf SMTP umgestellt haben. Dazu erstelle ich später einen separaten Post.

Vielen Dank für eure Hilfe.

Viele Grüße

Melina
Mitglied: keine-ahnung
23.02.2012 um 17:27 Uhr
Zitat von Milli2311:
Das schlimmste ist, er braucht ewig um ein Mail herunterzuladen, wenn der Anhang mal etwas größer ist.
Und Du bist sicher, das da nicht ein Scanner unwillig seinen Dienst verrichtet?
Gibt es im POP3 Connector irgendeine Möglichkeit / Einstellung die die Verbindungsgeschwindigkeit festlegt ?
Nein.
Also, kann es sein, dass der irgendwie gedrosselt ist ?
Du meinst so eine Art Pop light?
Ich würde bei der Geschichte mal auf einen grottigen Mail-Scanner tippen. Apropos grottig, welche Synchronisationsfrequenz ist da eigentlich eingestellt?
.. oder eventuell wäre der Wechsel vom guten alten Analogmodem auf etwas schnelleres eine Option ?
Viele Grüße
Zurück, Thomas
Bitte warten ..
Mitglied: Milli2311
23.02.2012 um 17:36 Uhr
Hei,

erst mal vielen Dank für deine Antwort

Ich bin mir nicht sicher, dass der Scanner sich da nicht rein schleicht, nein.. Wie kann ich das denn sicherstellen ? Wir nutzen McAfee VirusScan Enterprise v 8.8 auf dem Server.. Ich habe gerade mal geguckt, der On-delivery email scan war enabled aber im Log steht nur was bis 15/02/2012, sodass der es ja nicht gewesen sein kann oder ?

Das Internet ist sehr langsam in dem Büro.. Schnelleres geht leider nicht, aber wenn man manuell eine Datei mit 11 MB läd, dauert es vllt. 4-5 minuten, jedoch keine 40 wie in diesem Fall...

Vielen Dank

Milli
Bitte warten ..
Mitglied: keine-ahnung
23.02.2012 um 17:52 Uhr
Ich arbeite nicht mit McAfee, aber ein Blick auf Dr. Google hat mir dies: https://kc.mcafee.com/resources/sites/MCAFEE/content/live/PRODUCT_DOCUME ... ins Auge geworfen. Schau da mal unter "Configuring exclusions on Exchange servers with GroupShield", ob die Ausschlüsse eingetragen sind. Das könnte sonst tatsächlich Performanceprobleme geben.

LG, Thomas
Bitte warten ..
Mitglied: Milli2311
24.02.2012 um 09:54 Uhr
Hei

ich habe eben mal testweise ein 13 MB mail an mich geschickt (von extern) und dann manuell den POP3 Connector download angestoßen. Mit deaktiviertem McAfee, sowie mit aktiviertem McAfee braucht er 7 Minuten für das eine Mail..
McAfee scheint also keinen Unterschied zu machen hier..

Im POP3Connector log finde ich folgendes:

[t 0] 02/24/12, 04:16:48: ERROR: 0x800ccc07 ("m_pSocket->SendBytes( pszLine, lstrlenA( pszLine ), &cbSent )") at d:\wssg_src\sbs_sbs7\sbs\src\messaging\pop3\ixpbase.cpp:895.
[t 0] 02/24/12, 04:26:50: ERROR: 0x800ccc07 ("m_pSocket->SendBytes( pszLine, lstrlenA( pszLine ), &cbSent )") at d:\wssg_src\sbs_sbs7\sbs\src\messaging\pop3\ixpbase.cpp:895.
[t 0] 02/24/12, 05:56:52: ERROR: 0x800ccc07 ("m_pSocket->SendBytes( pszLine, lstrlenA( pszLine ), &cbSent )") at d:\wssg_src\sbs_sbs7\sbs\src\messaging\pop3\ixpbase.cpp:895.
[t 0] 02/24/12, 06:06:54: ERROR: 0x800ccc07 ("m_pSocket->SendBytes( pszLine, lstrlenA( pszLine ), &cbSent )") at d:\wssg_src\sbs_sbs7\sbs\src\messaging\pop3\ixpbase.cpp:895.
[t 0] 02/24/12, 06:16:58: ERROR: 0x800ccc07 ("m_pSocket->SendBytes( pszLine, lstrlenA( pszLine ), &cbSent )") at d:\wssg_src\sbs_sbs7\sbs\src\messaging\pop3\ixpbase.cpp:895.
[t 0] 02/24/12, 07:47:03: ERROR: 0x800ccc07 ("m_pSocket->SendBytes( pszLine, lstrlenA( pszLine ), &cbSent )") at d:\wssg_src\sbs_sbs7\sbs\src\messaging\pop3\ixpbase.cpp:895.
[t 0] 02/24/12, 07:47:03: ERROR: 0x800ccc07 ("m_pSocket->SendBytes( pszLine, lstrlenA( pszLine ), &cbSent )") at d:\wssg_src\sbs_sbs7\sbs\src\messaging\pop3\ixpbase.cpp:895.
[t 0] 02/24/12, 07:56:52: ERROR: 0x800ccc07 ("m_pSocket->SendBytes( pszLine, lstrlenA( pszLine ), &cbSent )") at d:\wssg_src\sbs_sbs7\sbs\src\messaging\pop3\ixpbase.cpp:895.


Soweit ich gelesen hatte, sollte der POP3 Connector diesen Error immer in das Log schreiben, wenn er automatisch Mails abruft. Ich wundere mich nur über die Zeiten.. Eigentlich soll er alle 10 Minuten abrufen aber 06:16 - 07:47 ist eindeutig mehr als 10 Minuten..

Vielen Dank

Mit freundlichen Grüßen

Milli
Bitte warten ..
Mitglied: keine-ahnung
24.02.2012 um 10:33 Uhr
Hi,

das wäre komisch (aber beim SBS nicht undenkbar ), dass error-logs für Normalzustandsinformationen geschrieben werden. Hast Du Port 25 auf den SBS weitergeleitet? Was passiert mit adnexen kleiner 10 MB? Hast Du die Möglichkeit, einen alternativen pop-connector zu testen? Es scheint beim SBS 2011 häufiger Probleme zu geben als bei 2003/2008 - bei mir läuft der Trödel seit Jahren problemlos in beiden System, bin aber halt auch noch nicht auf den 2011'er umgezogen, obwohl ich Lizenz und CAL's nun schon über ein Jahr in der Schublade liegen habe ...

LG, Thomas
Bitte warten ..
Mitglied: Milli2311
24.02.2012 um 10:42 Uhr
Hei,

danke für deine schnelle Antwort.

Ich bin mir ehrlich gesagt nicht sicher... Wir haben einen Router und in diesem Router habe ich Port 25 an die interne Server IP weitergeleitet. Muss ich im SBS selbst noch was umstellen ? Egal wie groß der Anhang ist, es dauert einfach unbeschreiblich lange.. Er kann für 4 MB auch schon mal 20 Minuten brauchen.. Im Moment habe ich mir alle Inboxen per IMAP im Outlook connected um sicherzustellen, dass auch ja nicht ein Mail mit einem Riesenanhang den Rest blockiert.. Früher, mit dem alten SBS 2003 und dem POP3 Connector gab es überhaupt keine Probleme...

Habe schon überlegt POPcon oder POPBeamer zu testen.. Bin mir aber nicht sicher ob ich etwas kaputt machen kann. Das Schlimmste wäre, wenn ich irgendwie e-Mails verlieren würde, weil ich einen POP Connector nicht richtig konfiguriert hätte, der die Mails runterläd, aber nirgendwohin zustellt.

Mit freundlichen Grüßen

Milli
Bitte warten ..
Mitglied: keine-ahnung
24.02.2012 um 12:13 Uhr
Wenn es beim mailing rumpelt, macht es zunächst Sinn, beim Hoster ersteinmal Kopien der eingegangenen Mails auf einen account zu schicken, der nicht automatisch abgeholt wird, um einen Verlust zu vermeiden. Bei der Gelegenheit kannst Du ja auch gleich mal gucken, ob da noch mails rumliegen, die der connector nicht abgeholt hat - dies würde er Dir aber auch in der Ereignisanzeige des SBS mitteilen. Wenn die 25 auf den SBS zeigt, ist das in Ordnung. Gibt das Ereignisprotokoll im Bereich SBS keine Fehlermeldungen aus??
Bitte warten ..
Mitglied: Milli2311
24.02.2012 um 12:20 Uhr
Hei,

Ein Backup aller eingehenden e-mails haben wir bei unserem Provider Das hatte ich ganz vergessen lol.

Die Ereignisanzeige sagt nix, außer wenn ein Mail,, so wie gestern, 13 MB groß ist und die Downloadzeit 10 Minuten übersteigt, sodass eigentlich ja schon der nächste Abruf dran wäre. Dann erscheint diese Meldung

Log Name: Microsoft-Windows-Small Business Server/Operational
Source: Windows Small Business Server 2011 Standard
Date: 23/02/2012 11:25:47
Event ID: 208
Task Category: Windows SBS POP3 Connector
Level: Error
Keywords:
User: LOCAL SERVICE
Computer: server.uk.domain.com
Description:
The TCP/IP connection with the 'localhost' server was terminated while trying to access the 'user@domain.com' mailbox. The cause may be server problems, network problems, a long period of inactivity, a connection time limit, or incorrect connection settings.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event;>"
<System>
<Provider Name="Windows Small Business Server 2011 Standard" Guid="{8A6CC93F-8047-4F7A-94AE-AABB0A1E3EFA}" />
<EventID>208</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>3</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000000</Keywords>
<TimeCreated SystemTime="2012-02-23T11:25:47.418213500Z" />
<EventRecordID>22286</EventRecordID>
<Correlation />
<Execution ProcessID="9628" ThreadID="9644" />
<Channel>Microsoft-Windows-Small Business Server/Operational</Channel>
<Computer>server.uk.domain.com</Computer>
<Security UserID="S-1-5-19" />
</System>
<UserData>
<EventData xmlns:auto-ns1="http://schemas.microsoft.com/win/2004/08/events" xmlns="logging">
<String1Data>localhost</String1Data>
<String2Data>user@domain.com</String2Data>
</EventData>
</UserData>
</Event>

Hilft das irgendwie ?

Vielen Dank

Viele Grüße

Milli
Bitte warten ..
Mitglied: keine-ahnung
24.02.2012 um 13:04 Uhr
Insgesamt irritiert mich, dass der connector überhaupt mails > 10 MB lädt, da muss an den Standardeinstellungen geschraubt wurden sein oder der poper hat neue Limits im Vgl. zu 2008/2003.

Eventuell hilft Dir bei der Kontrolle der Einstellungen dieses hier: http://social.technet.microsoft.com/Forums/en-US/smallbusinessserver/th ...

LG
Bitte warten ..
Mitglied: Milli2311
24.02.2012 um 17:43 Uhr
Hei,

Ja sorry das hätte ich erwähnen sollen.. Unsere Leute haben sich beschwert, dass 10 MB zu klein ist, somit musste ich die Limits raufsetzen. Ich habe hier jedoch nicht "wild herumgespielt" sondern bin nach Anleitungen im Internet vorgegangen.

Es ist "gewollt", dass alle Mails auf jeden Fall reinkommen. Vorher mit dem 10 GB Limit hat ein Mail mit größerem Anhang online alles blockiert. Solange bis ich den Anhang vom Benutzer manuell herunterladen lassen habe und das Mail manuell gelöscht hab. Der POP3 Connector hat immer wieder versucht dieses blöde Mail herunterzuladen und lief in ein Timeout.

Warum kann es nicht einfach so sein, wie beim SBS 2003 vorher.. Man musste sich nicht um den MailFlow kümmern. Mail funktionierte einfach.

Viele Grüße

Milli
Bitte warten ..
Mitglied: keine-ahnung
24.02.2012 um 18:07 Uhr
Leider gibt es IMHO kein downgrade-Migration . Fakt ist, das POP3 eigentlich ein Protokoll für Clients ist und per se im Spiel mit einem Exchange vermieden werden sollte. Dies lässt sich nur leider nicht immer vermeiden, wie ich aus eigener Erfahrung leidvoll weiss (inmitten der Hauptstadt eines deutschen Freistaates habe ich kein kabelgebundenes DSL sondern den Exchange an eine WIMAX-Verbindung mit dynamischer Adresse hängen müssen). Insofern muss ich das POP-Ding auch weiter bemühen, den eingehenden Mail-Verkehr werde ich nicht diesen wackeligen Bedingungen anvertrauen. Insofern muss ich mich natürlich auch etwas beschränken - funktioniert auch.

Warum lässt Du den Ex nicht direkt den Mailverkehr managen? Dann bist Du ein paar Sorgen loss oder geht technisch bei Dir auch nicht?

Eventuell hat ja auch Dein Hoster ein connection time limit im pop-Verkehr? Würde ich mich dort mal erkundigen. Ansonsten auch mal daran denken, die Synchronisierungsfrequenz herunterzusetzen, damit sich der popper nicht selbst in die Quere kommt.

Sonst halt das Größenlimit wieder auf die Standards zurücksetzen und die Mitarbeiter entsprechend primen, das größere Mailanhänge halt nicht akzeptiert werden. Wenn Ihr die beruflich braucht, wäre auch ein hinreichend schneller company connect für die direkte Mailsynchronisation eine Möglichkeit ...

LG, Thomas
Bitte warten ..
Mitglied: Milli2311
27.02.2012 um 11:51 Uhr
Hei,

also mit Exchange direkt ist es ein bisschen schwierig bei uns..

1. haben wir keine richtige Firewall, sondern nur die im Router integrierte

2. haben wir 4 Niederlassungen, die alle dieselbe domain für e-mails benutzen. Ich müsste ja dem Exchange eine Domäne zuteilen, über welche die Mails fließen. Wenn ich hier eine Subdomain nehme, habe ich das Problem, dass ausgehende Mails über die Subdomain geschickt werden und nicht mehr über die globale, wie es sein soll..

3. Ist mir sehr mulmig dabei, den Exchange direkt über das Internet zugänglich zu machen, da ich kein IT Security Experte bin und somit Angst habe, von Hackern angegriffen zu werden.

4. Haben wir bei unserem E-Mail Provider ein Archiv. Alle ausgehenden und eingehenden e-mails werden als Backup gespeichert und archiviert. Wenn ich den Exchange direkt Mails empfangen lasse, geht das ja nicht mehr über unseren Provider oder ?

Vielen Dank

Mit freundlichen Grüßen

Milli
Bitte warten ..
Mitglied: keine-ahnung
27.02.2012 um 13:54 Uhr
Hi,

prinzipiell sollte auch die im Router integrierte firewall genügen (da gibt es mitunter auch recht ausgefeilte, z.B. bei LANCOM), zusätzlich kann Dein Scanner die email-adnexen ja mit überwachen. Die Anbindung der Filialen sollte nicht das Problem sein - im schlimmsten Fall halt machen lassen. Trotzdem bleibt es bei meiner Meinung, ein mailserver ist kein fileshare-Medium, dafür ist er nicht gemacht. Hast Du mal Kontakt mit Deinem Hoster aufgenommen?

LG, Thomas
Bitte warten ..
Mitglied: Milli2311
27.02.2012 um 14:06 Uhr
Hei,

Also wir haben einen Draytek Vigor 2820 falls dir das was sagt.. Den haben wir in 3 Niederlassungen, sodass diese untereinander per VPN gekoppelt sind. Also ein permanenter VPN Tunnel zwischen 3 Offices.

Was meinst du mit "Trotzdem bleibt es bei meiner Meinung, ein mailserver ist kein fileshare-Medium, dafür ist er nicht gemacht." ?

Ich habe unseren Hoster gefragt wie er es sieht und der meinte eingehende Mails per MX Host an den Server leiten sei kein Problem, aber die ausgehenden dann auch über die Hauptdomain zu versenden und über den Mail hoster zu leiten, damit sie auch archiviert werden, das sei wohl ein Problem..

Mit freundlichen Grüßen

Milli
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
gelöst SBS POP3 Connector stellt keine Verbindung zu Exchange Server her (28)

Frage von bafo zum Thema Exchange Server ...

Exchange Server
Problem mit POP3-Abruf eines Exchange-2013-Postfachs

Frage von YotYot zum Thema Exchange Server ...

Windows Server
Server sehr langsam bei vielen kleinen Dateien (5)

Frage von MichiBLNN zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...