Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Port Forwarding über 2 Router funktioniert nicht

Frage Netzwerke Router & Routing

Mitglied: gkn112

gkn112 (Level 1) - Jetzt verbinden

13.07.2009, aktualisiert 18.10.2012, 18061 Aufrufe, 13 Kommentare

Hallo,

ich versuche schon seit Tagen, einen bestimmten Port (Port 28960) in meinem Netzwerk freizugeben. Allerdings funktioniert das nicht.

Es sind zwei Zyxel Router im Einsatz, Router 1 steht im Wohnzimmer und leitet das Signal weiter an Router 2, an welchem mein PC (PC3) hängt. Die Konfiguration an sich funktioniert wunderbar, Verbindungen ins Internet sind von jedem einzelnen Rechner möglich.

Die Leitung ist von T-Online, Die Router habe ich noch von meiner alten Arcor-Leitung.

Zur Veranschaulichung habe ich das Skizziert (Konfiguration Map)

Ich habe alle relevanten Seiten im Router-Konfig-Menü beider Router nochmal als Screenshots angehängt.

Mit dieser Konfiguration krieg ich aber z.B. auf canyouseeme.org die Meldung:

Error: I could not see your service on XX.XXX.XX.XX on port (28960)
Reason: Connection refused

Das bedeutet: Trotz ausgeschalteter Router-Firewall und Windows-Firewall und trotz Port Forwarding an Router 1 ist der Port 28960 nicht offen.

Kann es sein dass, ein anderes Programm diesen Port blockiert? Allerdings habe ich mal probehalber Port 10000 geöffnet... wieder nichts.

Ich würde mich sehr auf Vorschläge freuen.
Vielen Dank!

Übersicht:

6599a48f886a7fc7691fcb4daee4490c-konfiguration_map - Klicke auf das Bild, um es zu vergrößern

Router 1 Systemstatus

c5f2c6357050bf6ac8a477fd8abde47b-r1_systemstatus - Klicke auf das Bild, um es zu vergrößern

Router 2 Systemstatus

2c809393fe1092a9ecbef8a638654529-r2_systemstatus - Klicke auf das Bild, um es zu vergrößern

R1 LAN

52c4addec074d7b2926ef7c55f560954-r1_lan-einstellungen - Klicke auf das Bild, um es zu vergrößern

R2 LAN

c4c484d0a45b335c130d7d372bf92684-r2_lan-einstellungen - Klicke auf das Bild, um es zu vergrößern

R1 WAN

8cb82451de4548098c376f8a581ad115-r1_wan-einrichtung - Klicke auf das Bild, um es zu vergrößern

R2 WAN

392f479e99bd259381c628c688eaed5f-r2_wan-einrichtung - Klicke auf das Bild, um es zu vergrößern

R1 NAT (SUA)

ee41a9d86870f395546dfbb0af903a49-r1_nat - Klicke auf das Bild, um es zu vergrößern

R2 Nat deaktiviert

74953eac4a7b9c4e86613239a4c4a651-r2_nat - Klicke auf das Bild, um es zu vergrößern

R1 Firewall aus

8dbc0918e4aa966ca5c66faa9892e777-r1_firewall - Klicke auf das Bild, um es zu vergrößern

R2 Firewall aus

3e23c3eef816e4bc4d8872c6e1c474aa-r2_firewall - Klicke auf das Bild, um es zu vergrößern
Mitglied: LordXearo
13.07.2009 um 20:01 Uhr
Hi,

du schreibst ob es sein kann das ein anderes Programm den Port blockiert. Welche anderen Programme hast du denn laufen die als Firewall o.ä. fungieren? Dein zweiter Router steht auch im "Routing" Betrieb. Gibt es da noch mehr Auswahl? Dein zweiter Router wird ja praktisch nur als Switch gebraucht.

Der Port den du freigegeben hast, funktioniert so auch nur für die IP-Adresse die du da hinterlegt hast (Also PC3).

Ich warte mal dein nächstes Feedback ab. Normalerweise funktioniert das Wunderbar mit dem Zyxel Router, hatte auch mal einen.

Gruß

Xearo
Bitte warten ..
Mitglied: laumanu
13.07.2009 um 21:24 Uhr
Hallo,

Ich habe bei mir zuhause auch eine solche Konstellation am Laufen.
Versuche doch mal beim zweiten Router in den DHCP-Einstellungen, den Router als "Relay" laufen zu lassen.
Damit sollte es funktionieren!

Gruss
Bitte warten ..
Mitglied: gkn112
14.07.2009 um 00:59 Uhr
Hallo,
danke für eure Antworten bisher

Also, außer dem "Routing" ist da noch die Option "Modem" (also nicht von Belang denk ich mal).

Es läuft eigentlich keine weitere Software, die als Firewall fungieren könnte, die Windows-Firewall ist auch deaktiviert. Ich möchte das Augenmerk eigentlich von der Software zur Hardware lenken wenns geht, habe nämlich auch mal versucht, mein Laptop freizugeben - negativ. Es *muss* etwas mit den Routerkonfigurationen zu tun haben.

Ach ja, der Port soll auch nur am PC3 (also meinem) frei sein.

Relay habe ich auch schon mal versucht, es läuft auch, die Ports sind allerdings immer noch zu. Wie sieht das eigentlich aus mit dem Relaymodus und den NAT - Einstellungen an R2 aus? Muss man da auch Port 28960 auf der IP 192.168.1.38 freigeben? Ist mit Relaymode eigentlich dasselbe wie Bridge-Mode gemeint?

Ich habe mir folgendes vorgestellt: R1: Port 28960 auf 192.168.1.2 freigeben (also Port zu R2 weiterleiten), R2: 28960 auf 192.168.1.38 (PC3) freigeben. Was ist an dem Gedanken falsch? Es funktioniert nämlich nicht. Dann steht bei canyouseeme ein Timeout-Fehler.

Ich bin sehr auf eure Antworten gespannt!
Bitte warten ..
Mitglied: aqui
14.07.2009, aktualisiert 18.10.2012
Laut deiner Zeichnung oben benutzt du deinen 2ten Router ja nur als dummen Switch bzw. WLAN Accesspoint.

Was bei der Einrichtung zu beachten ist sagt dir dieses Tutorial:

http://www.administrator.de/wissen/kopplung-von-2-routern-am-dsl-port-4 ...

Ein Port Forwarding auf dem 2ten Router zu aktivieren ist also Blödsinn, denn laut deiner zeichnung ist dein WAN Port ja richtigerweise auch gar nicht in Benutzung.
Richtig deshalb wenn der 2te Router nur als Switch und WLAN AP missbraucht wird.

Relevant ist also NUR was auf dem ersten Router konfiguriert ist mit dem Port Forwarding...der 2te Router spielt in dem Szenario keine Rolle...jedenfalls nicht als Router !
Bitte warten ..
Mitglied: gkn112
14.07.2009 um 13:22 Uhr
@agui
Danke für deine Antwort, ich schalte also NAT aus im 2. Router, dieser ist im relay mode, ist im selben IP-Bereich wie R1 . Das bedeutet im R1 wird Port forwarding auf 192.168.1.38 betrieben?

Naja... (Canyouseeme.org) Error, reason: Connection timed out

Das bedeutet doch dass gar kein Signal ankam oder? ich meine je nach Einstellung steht hier Connection refused.

Habs auch mal mit alle ports freischalten versucht... Fehlanzeige...

Oder denkt jemand, es könnte andere Ursachen haben als die Router-einstellungen? Ich weis, dass einige Ports von der ISP - Seite her geblockt dein können, aber 28960 gehört meineswissens nicht dazu.
Würde es helfen wenn ichs mal mit ner Virtual Machine teste? Also komplett cleane WinXP bzw Win7 Version...

Das macht mich echt verrückt! ^^


Edit:
Also, habe jetzt die Virtual Machines getestet... weder mit einer total cleanen WinXP version, noch mit Ubuntu kann ich die Ports freigeben...
Bitte warten ..
Mitglied: LordXearo
14.07.2009 um 13:59 Uhr
Hast du es denn mal nur mit einem Router versucht?
Bitte warten ..
Mitglied: gkn112
14.07.2009 um 14:09 Uhr
Habe jetzt am PC1 getestet (192.168.1.36), die hängt ja nur an R1, Win-FW aus --> Connection refused.

BTW, was ist eigentlich asymmetrisches Routing?
Bitte warten ..
Mitglied: aqui
14.07.2009 um 14:27 Uhr
Im 2ten Router ist es völlig egal was du ein oder ausschaltest !! Das hat alles keinerlei Einfluss !!

Nochmals, da du vermutlich das Tutorial oben nicht wirklich gelesen hast :
  • Du benutzt den 2ten Router nur als dummen Switch (am WAN/DSL Port ist ja richtigerweise laut deiner Zeichnung nichts angeschlossen also routet oder forwardet hier auch nix !!) du benutzt ja nur die 4 Switchports an Router 2 und dort wird auf Baiss der OSI Layer 2 MAC Adressen geswitched und nicht geroutet. Routen kann der Zyxel nur zwischen LAN/WLAN und DSL Port.
  • Der 2te Router arbeitet nur als 2ter WLAN AP also hoffentlich mit gleicher SSID (WLAN Kennung) und Verschlüsselung wie Router 1 aber hoffentlich mit einem 5 kanaligen Sendeabstand im WLAN denn sonst stören sich beide Router gegenseitig (Siehe hier )

Folglich ist also dein 2ter Router nur ein dummer Accesspoint mit Switch, d.h. er ist also im gleichen LAN wie Router 1 und hat keinerlei Port Forwarding oder Routerfunktion !! Er sit nur ein Medeinwandler auf WLAN usw.
Hier muss also auch wie im Tutorial beschrieben der DHCP Server ausgeschaltet sein ! Ebenso muss die LAN IP Adresse des 2ten Routers außerhalb der DHCP Range des ersten Routers liegen !
Siehe und lese o.a. Tutorial !

Port Forwarding Relevanz hat also NUR dein Router 1 NICHTS SONST !
Voraussetzung ist natürlich du hast alles gemäß Tutorial eingerichtet !

Asymetrisches Routing hast du wenn der geroutete Hinweg eines Paketes zum Ziel ein anderer ist als der Rückweg !
Bitte warten ..
Mitglied: gkn112
14.07.2009 um 15:14 Uhr
Also, ich habe das Tutorial oben gelesen (auch vorher...) Durch deine 2. erklärung erst ist mir aber das mit dem wan-port klargeworden^^ Das ändert aber nichts an der gesamtsituation - das bedeutet nur ich habe extra-arbeit geleistet (welche auch noch unnötig war, denn letzendlich ists egal was ich da mache. ---> das problem liegt wohl an R1.

Habe jetzt mal einen Portscan ausgeführt, und da steht :


UDP:
192.168.1.38 Port: 28960 Protokoll: UDP VERBINDUNG!
Auf dem Port 28960 liegt vermutlich der RFC1060-Service


TCP:
192.168.1.38 Port: 28960 Protokoll: TCP
Connect-error: WSAECONNREFUSED
Auf dem Port 28960 liegt vermutlich der RFC1060-Service


Kennt sich jemand damit aus? was ist das, kann ich den service ausschalten? (Aber auch wenn ich andere Ports freischalte (jede x-beliebige) gibt es kein signal beim port check auf canyouseeme.org)

Ich habe übrigens tatsächlich 2 verschiedene SSIDs, ich verbinde mich je nach bedarf mit dem einen oder mit dem anderen Router... und es klappt bisher einwandfrei.


Edit:
Laut Google:
Im RFC1060 (Assigned numbers) befinden sich die Herstellercodes der Ethernet-Adressen.

Und Winsock Error 10061 (WSAECONNREFUSED) bedeutet:
Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte
Bitte warten ..
Mitglied: LordXearo
14.07.2009 um 16:27 Uhr
#1

Hast du mal bei Router #1 die Firewall eingeschaltet und getestet?

#2

Hast du die Firewall bei Router #1 eingeschaltet und ne weiterleitungsregel eingerichtet?

Oder tausch die Router mal aus.....alles was bisher gepostet wurde ist so aufjedenfall korrekt.....
Bitte warten ..
Mitglied: gkn112
14.07.2009 um 18:19 Uhr
So, hab es gerade mit der Firewall des R1 versucht. Wieder nichts... Ich bin nun nicht mehr zuhause, also muss ich alle weiteren versuche auf morgen Nachmittag vertagen.
Ich wäre trotzdem über alle theorethischen Gedankengänge und Vorschläge erfreut.

Werde Morgen auch versuchen, die Router untereinander auszutauschen, wobei ich aber nicht denke dass der Fehler daran liegt. (Alles andere funktioniert ja wunderbar).

Danke schonmal für die bisherigen Vorschläge

gkn112
Bitte warten ..
Mitglied: aqui
14.07.2009 um 22:04 Uhr
Der Port TCP/UDP 28960 wird vom Spiel "Call of Duty 4" benutzt im Netz. Was der auf dem LAN Port deines Routers (Sofern der die 192.168.1.38 hat ??) zu suchen hat ist schleierhaft. Schaden kann er aber vermutlich nicht anrichten.
Der RFC 1060 beschreibt nur die Nummenr der registrierten Applikations Ports TCP/UDP.

Canuseeme.org kann dir nur einen aktiven offenen Port anzeigen wenn dahinter auch ein aktiver Host ist.
Canuseeme.org schickt ein TCP Syn Paket raus auf diesen Dienst und wenn ein ACK zurückkommt dann zeigt er ihn als offen an.
Wenn du nur eine Port Forwardest dahinter an der angegeben IP Adresse aber keinen Dienst hast der antwortet dann kann Canuseeme.org auch nix anzeigen....logisch !

Hast du also eine funktionierenden Webserver im internen Netz z.B. auf der 192.168.1.100 und ist im Router Eingehend Port TCP 80 auf lokal 192.168.1.38 Port TCP 80 in der Port Weiterleitung eingestellt dann zeigt Canuseeme.org dir auch einen offenen Port TCP 80 an.
Wenn der Webserver ausgeschaltet ist dann ist der Port obwohl als Forward eingtragen aber unter Canuseeme.org nicht offen !!
Hoffentlich reicht dir das als Erklärung !!
Aktiviere also einen Dienst hinter dem PFW und dann klappt das auch !!

Du solltest ggf. mal "Shields up" probieren, das scannt dir gleich mehrere Ports und ist etwas komfortabler:
https://www.grc.com/x/ne.dll?bh0bkyd2

Thema WLAN:
Ich habe übrigens tatsächlich 2 verschiedene SSIDs, ich verbinde mich je nach bedarf mit dem einen oder mit dem anderen Router... und es klappt bisher einwandfrei.

Das ist Blödsinn und umständlich zugleich. Konfigurier auf beiden APs die gleiche SSID ! Damit kannst du frei roamen im WLAN und ersparst dir das umständliche Anmelden bei der einen und anderen SSID...das muss nicht sein.
WPA Verschlüsselung und Schlüssel sollten auch auf beiden APs gleich sein.
Der Funkkanal muss 5 Kanäle Unterschied haben damit die WLANs sich nicht stören !!! Also z.B. einer auf Kanal 6 der andere auf Kanal 11 im Setup einstellen.
Ggf. nochmal mit einem WLAN Scanner wie WLANINFO checken das Nachbar WLANs deine Kanäle nicht überlagern !
Auch hier gilt 5 Kanäle Abstand damit alles störungsfrei bleibt !
Bitte warten ..
Mitglied: gkn112
15.07.2009 um 17:33 Uhr
@ Aqui,

danke für deine qualifizierten Antworten, dass ein Dienst hinter einem Port stehen muss habe ich nicht gewusst und dadurch mich verrückt gemacht......
Ich habe jetzt einen Dienst gestartet, aber auf canyouseeme stand immer noch refused, aber bei shieldsup war der Status "Stealth - Unknown Protocol / Application for this port"

Mein Problem ist damit gelöst, vielen Dank nochmal an alle für die Hilfe!

Ach ja, das mit den SSIDs war einfach aus Unwissenheit, natürlich hats nur Vorteile wenn man nur ein WLAN-Netz hat, danke auch dafür.

Mit freundlichen Grüßen, gkn112
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Router & Routing
Routing und Port Forwarding für FTP-Transfer (2)

Frage von steff911 zum Thema Router & Routing ...

Firewall
gelöst Wie richte ich Port Forwarding auf der Sonicwall ein? (7)

Frage von Azubine zum Thema Firewall ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...