Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Port Forwarding und DynDNS

Frage Netzwerke Router & Routing

Mitglied: rene76

rene76 (Level 1) - Jetzt verbinden

10.04.2007, aktualisiert 12.04.2007, 4309 Aufrufe, 10 Kommentare

Hallo

Ich betreibe ein Netzwerk mit einem Windwos SBS 2003 SP2 (IP: XXX.XXX.XX.5). Auf dem Server läuft neben dem Webmail (über https) auch ein Apache-Webserver auf dem Port 81. Im LAN ist der Apache auf dem Port 81 erreichbar (XXX.XXX.XX.5:81).

Die Verbindung nach aussen erfolgt über ein Linksys RV42. Auf dem Router wird der Port für das Webmail weitergeleitet und das Webmail funktioniert von aussen auch problemlos (mit DynDNS).

Nun habe ich den Port 81 vom Apache auch weitergeleitet. Die Seite wird aber nicht angezeigt. Die Verbindung stelle ich über http://musterdomain.dyndns.org:81 her.

Wo könnte das Problem liegen. Beim Router habe ich die Einstellungen analog vom Webmail übernommen. Muss ich beim Server noch einen Port feigeben? Die Firewall ist auf dem Server nicht aktiviert.

gruss rene76
Mitglied: aqui
10.04.2007 um 11:33 Uhr
Da bleibt als mögliche Erklärung eigentlich nur das der TCP Port 81 laut IANA fest für einen anderen Dienst reserviert ist und der Linksys ihn deshalb nicht für HTTP nutzt also alle sog. "well known" Ports bis 1024 nicht nutzt für einen Redirect. Wäre etwas exotisch aber denkbar....
Besser ist es dann den Server z.B. mal auf einen der freien Ports über 1024 also z.B. TCP 8080 oder TCP 8088 laufen zu lassen und das mal zu checken. Funktioniert das auch nicht ist da noch ein Fehler in der NAT Firewall mit dem IP Forwarding !
Bitte warten ..
Mitglied: TheOllie
10.04.2007 um 12:58 Uhr
Hallo,

wenn Du auf den DynDNS gehst mit der Portnummer 81, dann weiss der aber nicht das Du dann auch auf DEINEN Server mit der 81 willst - denn er hat ja kein Forwarding dazu.

Teste doch mal mit der aufgelösten IP und dem Port 81 was passiert, wenns klappt musste bei DynDNS noch was einstellen.


Ollie
Bitte warten ..
Mitglied: rene76
10.04.2007 um 13:38 Uhr
Und wie soll ich das bei DynDNS konfigurieren? Beim Webmail auf Port 442 (oder so) musste ich das ja auch nicht machen.
Bitte warten ..
Mitglied: aqui
10.04.2007 um 14:31 Uhr
Das ist auch Unsinn was oben steht ! Mit :81 gibst du ja dediziert den TCP Port mit ! DynDNS ist lediglich ein Name Server Dienst der natürlich nicht port spezifisch arbeitet was nicht DNS Ports anbetrifft ! Das ist völlig transparent.
Wenn du dir mit ping musterdomain.dyndns.org einmal die IP Adresse ausgeben lässt dann kannst du das ja auch schnell mit http://<meine_aktuelle_DynDNS_IP>:81 nur mit der nackten IP Adresse sofort ausprobieren bzw. querchecken !
Auch das sollte dann fehlschlagen was dann den DynDNS Dienst sicher ausschliesst. Der hat de facto damit auch nichts zu tun !
Bitte warten ..
Mitglied: rene76
10.04.2007 um 14:38 Uhr
Ich habe den Port nun auf 1080 geändert. Das Problem besteht immer noch.

Über http://meineIP:1080 erreiche ich die Seite auch nicht. Das Problem liegt also beim Router.
Bitte warten ..
Mitglied: aqui
10.04.2007 um 15:02 Uhr
OK, dann ist der Fehler noch in der Port Forwarding Konfig. Kannst du auf dem Router einen Debug Modus laufen lassen oder ins Log (Syslog) sehen ob dort ggf. eine Fehlermeldung zu sehen ist.
Ist die Seite ggf. eine HTTPS Seite (SSL) oder kommt https darin vor ?? Dann musst du natürlich auch noch https forwarden !!!
Bitte warten ..
Mitglied: rene76
10.04.2007 um 15:22 Uhr
Debug-Modus hat er nicht. In der Logdatei ist auch kein Fehler zu sehen.
Die Seite ist nicht https. Über das LAN läuft die Seite ohne https.
Bitte warten ..
Mitglied: aqui
12.04.2007 um 15:44 Uhr
Das ist dann schlicht noch ein Konfig Fehler oder die Firmware hat einen Bug was sich mit einem Update ggf. korrigieren liesse.
Meisst wird auch HTTP nicht geforwardet solange der Webzugang über das externe Interface noch aktiviert ist. Das sollte natürlich so oder so immer abgeschaltet werden aus Sicherheitsgründen.
Bitte warten ..
Mitglied: rene76
12.04.2007 um 16:09 Uhr
das versuche ich es mal mit einem firmware update.

am server selbst kann das problem ja nicht liegen, da es über das LAN geht, oder sehe ich das falsch?
Bitte warten ..
Mitglied: rene76
12.04.2007 um 16:19 Uhr
es ist die aktuellste firmware drauf.

Konfiguriert habe ich den Router wie folgt:

Setup => Forwardung = MAX [TCP/1080~1080]->XXX.XXX.XX.5

Dazu habe ich bei der Firewall => Access Rules folgende Einstellungen gemacht:

MAX :: Allow :: MAX [1080] :: WLAN1 :: Any :: XXX.XXX.XX.5 ~ XXX.XXX.XX.5 :: Alway
MAX2 :: Allow :: MAX [1080] :: LAN :: XXX.XXX.XX.5 ~ XXX.XXX.XX.5 :: Any :: Alway
(Name :: Action :: Service :: Source Int. :: Source :: Destination :: Time
Bitte warten ..
Neuester Wissensbeitrag
Festplatten, SSD, Raid

12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Ähnliche Inhalte
Router & Routing
Routing und Port Forwarding für FTP-Transfer (2)

Frage von steff911 zum Thema Router & Routing ...

Firewall
gelöst Wie richte ich Port Forwarding auf der Sonicwall ein? (7)

Frage von Azubine zum Thema Firewall ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...