Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Port-forwarding funktioniert im WAN aber nicht im LAN

Frage Microsoft Windows Netzwerk

Mitglied: Tscheburaschka

Tscheburaschka (Level 1) - Jetzt verbinden

07.05.2007, aktualisiert 08.05.2007, 4880 Aufrufe, 13 Kommentare

Hi,

ich habe einen Router (Win Server 2003) mit öffentlicher IP auf dem Port-Forwarding eingerichtet ist welches auf 2 WEBserver verlinkt ist warum funktioniert der zugriff mit der öffentlichen IP von WAN aber nicht aus dem LAN. Kann mir das einer erklären?

Danke
Mitglied: Bandit600
07.05.2007 um 13:12 Uhr
kannst du das genauer erklären?? vlt mal noch ne ip oder so?? und was von wo nicht klappt..
Bitte warten ..
Mitglied: dfritz
07.05.2007 um 13:24 Uhr
Hi,

das ist ein typisches Problem. Der Grund liegt am NATing deines Netzwerkverkehrs. Da die Packete ja im Prinzip ins Internet gehen und dann wieder zurück müssen. Funktioniert einfach nicht.

Am einfachsten ist es wohl, wenn Du einen internen DNS aufsetzt und ggf. so webserver1.de auf die entsprechende interne IP umroutest.

Gruß Daniel
Bitte warten ..
Mitglied: 45877
07.05.2007 um 13:36 Uhr
Hi,

das ist ein typisches Problem. Der Grund
liegt am NATing deines Netzwerkverkehrs. Da
die Packete ja im Prinzip ins Internet gehen
und dann wieder zurück müssen.
Funktioniert einfach nicht.

Am einfachsten ist es wohl, wenn Du einen
internen DNS aufsetzt und ggf. so
webserver1.de auf die entsprechende interne
IP umroutest.

Gruß Daniel

oder einfach die host datei ändern, je nachdem wieviele clients es sind.
Bitte warten ..
Mitglied: Tscheburaschka
07.05.2007 um 13:58 Uhr
Danke schon mal!!!

Also etwas genauer:

Adressen:
Router ---> 1. ip (öffentlich) 213.221.xxx.xxx
---> 2. ip (lokal) 192.168.1.3
Web_Server_1 ---> 1. ip(lokal) 192.168.1.1:80
Web_Server_2 ---> 1. ip(lokal) 192.168.1.2:81

Ip-Routing:
213.221.xxx.xxx:80 ---> 192.168.1.1:80
213.221.xxx.xxx:81 ---> 192.168.1.2:81

Dann wird das ganze mit http://213.221.xxx.xxx:80 oder 213.221.xxx.xxx:81 aufgeruffen.


@ dfritz
wie meinst du das "Am einfachsten ist es wohl, wenn Du einen internen DNS aufsetzt und ggf. so webserver1.de auf die entsprechende interne IP umroutest."

ich hab doch DNS schon laufen
Bitte warten ..
Mitglied: dfritz
07.05.2007 um 14:04 Uhr
Ja, aber nur einen externe DNS Server.

Du sprichst ja nun immer wasweisich.dyndns.org:80 oder 81 an, die dann auf die IP 213.xxx.xxx gehen.

Wenn Du nun einen hauseigenen hast, kannst du wasweissich.dyndns.org auf 192.1681.1 bzw .2 direkt legen und dann klappt das auch.

ggf. auch mit der Hosts Datei, wenn es nicht zuviele Clients sind (Siehe vorredner)
Bitte warten ..
Mitglied: 45877
07.05.2007 um 14:08 Uhr
du kommst also mit der öffentlichen_ip:81 nicht auf webserver 2 vom LAN aus?
Bitte warten ..
Mitglied: Bandit600
07.05.2007 um 14:16 Uhr
hast du eine domäne?? wenn ja, hast du sicher auch einen dns-server für diese domäne. Problem, nochmal anders ausgedrückt ist folgendes:

wenn du von einem client innerhalb des LAN die öffentliche Adresse des Webserver2 angibst, wandelt der NAT-Mechanismus die lokale Adresse in eine globale Adresse um, um die globale Adresse an per Forwarding und NAT wieder in eine lokale Adresse umzuwandeln und an den Webserver 2 weiterzuleiten. Bei diesem ganzen Vorgang verschluckt sich der Router, da er, vereinfacht ausgedrückt, eine Anfrage an sich selbst stellt.... Und (meiner Meinung nach) hängt man auch keinen Server an eine öffentliche Leitung.. Oder stuft einen w2k3 zu nem router runter. Hardware-Router, die das können, gibt es bereits ab 50,00€.

Der Lösngsvorschlag jetz ist, dass du für dein LAN einen DNS-Server einträgst (dieser wird den Clients über die IP-Konfiguration unter Primärer DNS mitgeteilt), welcher alle Anfragen an Webserver2 DIREKT an diesen, und ohne Umwege über das Internet weiterleitet.... Der w2k3 ist z.B. ein solcher DNS-Server...
Bitte warten ..
Mitglied: Tscheburaschka
07.05.2007 um 14:19 Uhr
@45877

"du kommst also mit der öffentlichen_ip:81 nicht auf webserver 2 vom LAN aus?"

ja
Bitte warten ..
Mitglied: Tscheburaschka
07.05.2007 um 14:31 Uhr
@Bandit600

Also jetzt ganz genau:

Router (Hardware) Cisco vom Isp
Ip:213.xxx.xxx.xx1

Router (Win2003 Standard r2)
NIC1. Ip: 213.xxx.xxx.xx2
gw:213.xxx.xxx.xx1

NIC2. 192.168.1.3
Ip-Routing
213.221.xxx.xxx:80 ---> 192.168.1.1:80
213.221.xxx.xxx:81 ---> 192.168.1.2:81
DC (Win2003 Standard r2) [DHCP],[DNS]
NIC1. Ip:192.168.1.4
WebServer_1:80 (Win2003 Standard r2)
NIC1. Ip:192.168.1.1
WebServer_2:81 (Win2003 Standard r2)
NIC1. Ip:192.168.1.2
Bitte warten ..
Mitglied: Bandit600
07.05.2007 um 14:41 Uhr
am Domain-Controller einen Host-Eintrag für die beiden Webserver-einfügen und schon geht's....

PS: Über den Cisco-Router habt ihr keine Befehlsgewalt, oder wieso hängt hinter dem route rnoch ein Router?? und der router (cisco von isp).. wieso hat der nur eine ip?? was ist dessen daseinsberechtigung?? )
Bitte warten ..
Mitglied: Tscheburaschka
07.05.2007 um 14:47 Uhr
Ne wir haben keine Befehlsgewalt über den cisco der ist für die standleitung da. Und der Router hat noch 2 Ip Adressen. aber die sollen noch nicht benutz werden.
Bitte warten ..
Mitglied: Tscheburaschka
07.05.2007 um 15:27 Uhr
Man davor hatten wir nen kleinen DSL Router damit ging es ohen problemme und jetzt sowas ich raff das einfach nicht
Bitte warten ..
Mitglied: Tscheburaschka
08.05.2007 um 10:00 Uhr
Hi ich hab jetzt beim DNS Server eine neue zone angelegt meineoeffentliche.domain und da drinne die hosts und kann jetzt auch lokal auf die server zu greifen aber nur über den namen. Ich würde gerne es noch hinkriegen über die öffentliche ip.


aber trotzdem schon mal danke an eucht
Bitte warten ..
Neuester Wissensbeitrag
Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (29)

Frage von patz223 zum Thema Windows Userverwaltung ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (20)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...