Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Portforwarding kommt nicht beim Server an?

Frage Linux

Mitglied: tobi83

tobi83 (Level 1) - Jetzt verbinden

23.11.2012 um 23:07 Uhr, 2720 Aufrufe, 7 Kommentare

Hi,

ich habe hier einen Ubuntu Server 12.04 64Bit laufen. Intern funktioniert so weit alles wunderbar. Doch, wenn ich jetzt z.B. per SSH von außen auf meinen Server zugreifen will geht das nicht. Ich habe im Router ein Forward vom SSH Port auf den Server eingerichtet, doch leider erhalte ich ein Time out. Wenn ich jedoch die IP des Servers gegen die IP einen anderen internen Rechners tausche so funktionier SSH wunderbar. Und ja SSH läuft auf dem Server und funktioniert auch. Die Ubuntu-Firewall ist auch deaktiviert.


Hat jemand eine Idee woran das liegen kann?

Danke schon mal für die Hilfe
Mitglied: Hitman4021
24.11.2012, aktualisiert um 01:36 Uhr
Hallo,

welche Firewall setzt du ein?
Ist ssh in der Config auf bestimmte Hosts beschränkt?
Hast du die ausgehenden Ports auch erlaubt?
Hast du in den Logs am Server eine Connection?
Logge mal Port 22 auf der Firewall mit.

Gruß
Bitte warten ..
Mitglied: RobertTischler
24.11.2012 um 10:01 Uhr
Hallo

Du hast in deinem router eine Weiter leitung eingerichtet auf deinen server? Wie versuchst du in dein netzwerk zu kommen? nur als tip um eine port weiter leitung testen zu können darfst du keine ip haben von deinem Router. dann solltest du auch dyndns eingerichtet haben um überhaupt zu deinem rechner zu kommen.
wenn das alles stimmt solte " ssh root@haumichblau.dyndns.org" funktionieren

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: ChrisIO
24.11.2012, aktualisiert um 21:46 Uhr
Zitat von RobertTischler:
Hallo

Du hast in deinem router eine Weiter leitung eingerichtet auf deinen server? Wie versuchst du in dein netzwerk zu kommen? nur als
tip um eine port weiter leitung testen zu können darfst du keine ip haben von deinem Router. dann solltest du auch dyndns
eingerichtet haben um überhaupt zu deinem rechner zu kommen.

Hey,

Dem kann ich nun nicht zustimmen.
Setzen wir uns mit dem Szenario mal auseinander.

Bspw.:

Router: 192.168.100.1 | öffentliche IP: 31.17.45.50
Dein SSH-Client: 192.168.100.20
Dein SSH-Server: 192.168.100.100

Du forwardest also im Router den öffentlichen Port 22 an den lokalen Port 22 des SSH-Servers(192.168.100.100).
Nun startest Du deinen SSH-Client(bspw. Putty) und connectest auf die öffentliche IP deines Routers(31.17.45.50) am Port 22.
Fertig ist der Lack.
Um dem Problem deiner dynamischen öffentlichen IP vorzugreifen ist ein DynDNS-Account natürlich gut, aber zum Testen vor/nach der Zwangstrennung brauchst Du Den nicht.

Gruß,
Chris
Bitte warten ..
Mitglied: RobertTischler
25.11.2012 um 08:40 Uhr
Hallo ChrisIO

Und genau das Funktioniert bei manchen routern nicht, weil die routing tabele nicht für den internen daten verker genutzt wird. Wenn ich von x.x.x.20 zu x.x.x.100 will hat der router damit nichts mehr zu tun auser eventuell der ip vergabe. der Router bekommt die pakete nicht mal zu gesicht.

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: ChrisIO
25.11.2012 um 09:50 Uhr
Zitat von RobertTischler:
Hallo ChrisIO

Und genau das Funktioniert bei manchen routern nicht, weil die routing tabele nicht für den internen daten verker genutzt
wird. Wenn ich von x.x.x.20 zu x.x.x.100 will hat der router damit nichts mehr zu tun auser eventuell der ip vergabe. der Router
bekommt die pakete nicht mal zu gesicht.

Mit freundlichen Grüßen

Hey,

hast Du meinen Beitrag gelesen und auch verstanden?
Niemand will von x.x.x.20 zu x.x.x.100, sondern die Kommunikation von Außen soll getestet werden.
Also will man die Verbindung vom internen Client 192.168.100.20 zu 31.17.45.50 testen.

Gruß,
Chris
Bitte warten ..
Mitglied: RobertTischler
25.11.2012 um 11:10 Uhr
hallo ja dann lies dein beitrag mal durch du kannst nicht intern auf die externe it und dann wieder nach intern das geht nur wenn du auch eine externe ip hast.
Bitte warten ..
Mitglied: Hitman4021
25.11.2012 um 23:25 Uhr
Hallo,

ohne externe IP macht Portforwarding keinen Sinn.

Und ich kann ein NAT Fallback machen von dem du sagst es geht nicht.

Aver ich habe keine Ahnung was du erreichen willst.

Gruß
Bitte warten ..
Neuester Wissensbeitrag
DSL, VDSL

Telekom blockiert immer noch den Port 7547 in ihrem Netz

(3)

Erfahrungsbericht von joachim57 zum Thema DSL, VDSL ...

Ähnliche Inhalte
Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Windows Server 2012 R2 Benutzerkonto für Zugriff auf AD Benutzer (1)

Frage von JulianOhm zum Thema Windows Server ...

Windows Server
gelöst Problem nach DC-Installation unter Server 2012 R2 (9)

Frage von manuel1985 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...