Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Ports werden nicht sauber durch Netzwerkbrücke geleitet

Frage Netzwerke

Mitglied: deuceman

deuceman (Level 1) - Jetzt verbinden

28.05.2007, aktualisiert 04.06.2007, 6040 Aufrufe, 7 Kommentare

Hallo, ich habe folgendes Problem:

Ich Besitze eine FRITZ!Box Fon WLAN 7050 die als Modem/Router/WDS Master fungiert. Mein PC (WinXP SP2) hängt am LAN1 Port. Im entfernten Wohnzimmer steht ein speedtouch 585i der als WDS Slave eingerichtet ist.

So weit so gut.

Das Speedtouch 585i hat 4 Lan-Ports, an denen meine PS2 und meine DBOX2 hängt.

Beide Geräte sind durch die Brücke von meinem PC erreichbar und kommen auch ins Internet.

Doch wenn ich auf den WebServer (yWeb Port 80) meiner Linux DBOX2 zugreifen möchte kommt es zwar Anfangs zu einer Verbindung (laut Netzwerkmitschnitt mit Wireshark) doch das Web Interface baut sich nicht auf.

Auch der Zugriff auf den FTP Server meider DBOX2 funktioniert nicht richtig. Ich kann mich zwar verbinden und ein paar Verzeichnisse wechseln, doch irgendwann friert die Verbindung ein. Auch der Dateitransfer funktioniert nicht.

Habe die DBOX direkt an den LAN2 Port der Fritzbox gesteckt und alles lief wie geschmiert (Web und FTP).
Es muss also daran liegen das die Brücke sich nicht transparent verhällt.

Die Ports sind laut Portscanner vom PC zur DBOX alle offen. Ich weiß nicht wie ich den Fehler weiter eingrenzen soll. Hoffe Ihr habt eine Idee
Mitglied: Torsten72
28.05.2007 um 11:29 Uhr
änder die einstellung von bridge-mode in repeater-mode
Bitte warten ..
Mitglied: deuceman
28.05.2007 um 19:49 Uhr
Danke für deine Antwort aber das kann ich am Speedport 585i nicht einstellen.

Der Bridge Mode muss doch alles transparent weiterleiten und ist doch in diesem Fall genau das richtige oder liege ich da falsch ?

Ich sehe ja auch dass die Anfragen und die Antworten von PC und dbox2 jeweils ankommen.
(Netzwerkmitschnitt) doch irgendwann ist schluss.

Vielleicht ein Zeitproblem? / MTU? / dbox kann nur 10MB half dublex, Verbindung von Bridge zu Fritzbox hat 11MBit konstant / Verbindung von PC zu Fritzbox 100MBit Full Dublex. Übrigens habe ich sogar die verschlüselung von Fritzbox zu repeater deaktiviert um Verschlüsselungsprobleme auszuschließen.
Bitte warten ..
Mitglied: aqui
29.05.2007 um 19:23 Uhr
Normalerweise kann so ein Szenario wie du es beschreibst so gar nicht funktionieren. Torsten72 war da schon auf dem richtigen Weg hat aber die Modi verwechselt.

Erstmal musst du strickt trennen zwischen WDS Repeater Mode und dem Bridge Mode. beide haben nichts miteinander zu tun und sind 2 völlig verschiedene Verfahren !!!

WDS Repeating bedeutet das ein 2ter AP einfach wie ein Papagei WLAN Packete auf der gleichen Funkfrequenz mit ein und derselben SSID nur zeitversetzt wiederholt. Er funktioniert also als Relaisstation für die Packete und erweitert so die Reichweite eines WLANs.
Wichtig zu wissen ist in diesem Modus das jeder Hop die verfügbare WLAN Bandbreite halbiert (WDS ist ein Half Duplex Verfahren) und die Verschlüsselungstechnik WPA(2) ist in einem WDS Szenario nicht supported !
WDS Verfahren beziehen sich einzig und allein auf WLAN Clients und niemals auf Kupfer Endgeräte die an einem WDS AP angesteckt sind. die nehmen gar nicht am WDS WLAN Verkehr teil !

Der WLAN Bridge Mode ist etwas völlig anderes. Hier gebt es wiederum 2 Modi. Einmal
a.) den Client Modus
und
b.) den LAN Modus

Bei a. wir ein einzelner Kupfer Client mit einer WLAN Bridge wie z.B. dem Siemens 108 Repeater von Kupfer in WLAN mediengewandelt.
Dies Verfahren funktioniert aber ausschliesslich NUR für einzelne Clients ! Niemals für ganze LANs. Es sei denn der AP supported auch den unter b. beschriebene LAN Bridge Modus. Dann kann man ein komplettes LAN bridgen über eine WLAN Brücke. Hier ist dann zwingend auch auf dem anderen Ende eine WLAN - LAN Bridge erforderlich.
Solche WLAN - LAN Bridges können dann aber nicht mehr im AP Modus arbeiten und WLAN Clients bedienen.

Nimmt man diese Fakten als Basis ist es überhaupt fraglich WAS für ein Konstrukt du da oben zusammenkonfiguriert hast.
WDS kann niemals so funktionieren, da nur WLAN Clients damit arbeiten, was deine dbox nicht ist !
Im Bridge Mode brauchst du kein WDS sondern da reicht ein zur Bridge umkonfigurierter AP sofern er diesen Modus supported. Dann kann dort aber kein 2ter LAN Client dranhängen.

Also etwas Kraut und Rüben was du da konfiguriert hast und somit ist es nicht verwunderlich das das Konstrukt so nicht rennt.

Für die DBOX und die PS-2 brauchst du einen dedizierten Client Adapter. Wie z.B.:

http://www.dlink.de/?go=gNTyP9CgrdFOIC4AStFCF834mptYKO9ZTdvhLPG3yV3oWIp ...

oder

http://gigaset.siemens.com/shc/0,1935,de_de_0_88569_rArNrNrNrN,00.html

oder

http://www.buffalo-technology.de/products/product-detail.php?productid= ...

Damit kannst du dann mit diesen Geräten transparent auf einen normalen ADP oder einen AP um WDS Modus zugreifen. Beide an einen WDS AP zu stecken funktioniert definitiv nicht !

Mit Duplex Modi und MTU hat das nichts zu tun, da die Frames nicht encapsuliert werden.
Bitte warten ..
Mitglied: deuceman
29.05.2007 um 20:15 Uhr
Ersteinmal danke für die Superschnellen Antworten!

Ich fasse also zusammen:

um die Kupfergebundenen Geräte wie die DBOX2 an meinem WLAN einzubinden benötige ich sogenannte "Ethernet Wireless Client Converter". Was ich in meinem Fall nicht "simuliert" habe.

Ein Wireless Router der im Bridge Modus läuft und an einer Fritzbox mit WDS verbunden ist leitet die Packete also normalerweise NICHT an die Physikalische LAN Schnittstelle (integrierter 4-fach Switch)weiter.

Es gibt also keinen Weg mit der vorhandenen Hardware die ich verwende 2 Kupfernetzwerke über die Luft zu verbinden. (Fritzbox als Modem/Router/Wlan AP und Speedport 585i als Ethernet Wireless Client Converter ) zu verwenden.

Das die entfernten Geräte also ins Internet können und ich zum Beispiel von meider DBOX2 Streams über Port 4000 auf meiner Platte am PC auf der anderen Seite aufnehmen kann oder von meinem PC (VLC) Streams auf die DBOX über Port 8080 sende ist also kein Definierter Zustand und läuft nur aus Zufall.

Vielleicht hab ich mich nicht richtig ausgedrückt, doch dieser Speedport Router im entfernten Netz soll gar nicht als AP fungieren, sondern nur das WLAN "auffangen" und auf die physikalischen Ports bringen.

Seltsamerweise funktioniert das auch, bis auf den beschriebenen Fehler.

So, ich glaub ich hab alles. Na gut, dann muss ich mir halt einen Ethernet Wireless Client Converter kaufen. Schade hab gedacht das geht auch so. Ich kann es aber nicht glauben das meine Konfiguration nur aus Zufall läuft, das geht mir irgendwie nicht ganz rein

Wie gesagt, vielleicht hab ich mich ja nur falsch ausgedrückt.
Bitte warten ..
Mitglied: aqui
30.05.2007 um 12:17 Uhr
Vielleicht hab ich mich nicht richtig ausgedrückt, doch dieser Speedport Router im entfernten Netz soll gar nicht als AP fungieren, sondern nur das WLAN "auffangen" und auf die physikalischen Ports bringen.....

Wenn man ihn als Bridge und nur als Bridge konfigurieren kann dann ist das möglich. WDS darf dann allerdings nicht aktiv sein weder auf dem einen noch anderen System !!!
Der Speedport wird aber vermutlich nur einen einzigen Client im Bridgemodus bedienen können und kein gesamtes Netz (mehrere MAC Adressen) das wird dein Problem sein.
Wenn du also der PS-2 noch einen der o.a. Clients verpasst und die Dbox mit dem Speedport im Bridge Modus als WLAN Client an der FB arbeiten lässt, die normal im AP Infrastructure Modus arbeitet, sollte alles problemlos klappen. Voraussetzung ist natürlich der Speedport supportet den Bridge Modus ! WDS nützt dir da gar nix !
Bitte warten ..
Mitglied: deuceman
30.05.2007 um 14:29 Uhr
Vielen Danke für deine Hilfe.
Bitte warten ..
Mitglied: aqui
04.06.2007 um 22:21 Uhr
Keine Ursache...dafür ist ein Forum da
Bitte den Thread dann oben als gelöst markieren !!
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Netzwerkprotokolle
Nachsehen ob Ports generell gesperrt sind (2)

Frage von staybb zum Thema Netzwerkprotokolle ...

Windows Server
Benutzerprofile nach AD-Umzug nicht mehr sauber funktionsfähig (3)

Frage von diemilz zum Thema Windows Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (13)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...