Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Portweiterleitung für Webbasierte Anwendung

Frage Internet Informationsdienste

Mitglied: m.reeger

m.reeger (Level 2) - Jetzt verbinden

22.01.2013 um 19:15 Uhr, 2935 Aufrufe, 7 Kommentare

Hallo,
gegeben ist eine feste IP-Adresse und ein Windows Server, sowie ein OpenSuse 11.2 Server.

Ich versuche über eine IPhone App auf den Linux Server zuzugreifen.
(Geht um myPortal für die HiPath 3800. Die App soll auf einen Open Scape Office LX Server zugreifen)

Ich habe nun intern die IP : 192.168.115.2, die Verwaltung des Servers erreiche ich über : https://192.168.115.2

Nun wollte ich gerne das der Server von außen erreichbar ist, um das IPhone anzubinden...

Also in den Bintec Rs232 eingeloggt und eine Portweiterleitung geschaltet. (Port 99 der Festen IP auf die https://192.168.115.2.

Wenn ich nun von extern versuche die Adresse : xx.xxx.xxx.xxx:99 aufzurufen, lädt der Browser die Seite nicht...

Lediglich die "URL bzw. IP-Adresse" wird verändert. Es steht dann statt : xx.xxx.xxx.xxx:99 https://xx.xxx.xxx.xxx:99/osolx/MainPage.jsp

Im Browser selbst wird die Seite nicht aufgebaut, sondern es kommt die Meldung, dass die Website nicht gefunden wurde...

Was machte ich falsch? WO ist der DENKFEHLER?
Ja in der FW. ist der Port frei.

Mit freundlichen Grüßen
Mitglied: aqui
22.01.2013, aktualisiert um 19:33 Uhr
Generell machst du es richtig. man sollte aber niemals weltweit registrierte IANA Ports verwenden wie die 99. Für freie Anwendungen ist es besser die sog. "Ephemeral Ports" zu verwende die nicht registriert sind.
Diese liegen zwischen 49152 und 65535.
Um den Router nicht zu verwirren solltest du erstmal einen Test mit dem HTTPS Standardport TCP 443 machen also mit der Forwarding Regel:
Incoming Port TCP 443 auf outgoing IP 192.168.115.2 Port TCP 443

Das muss sicher klappen.
Dann kannst du die Port Verschleierung machen:
Incoming Port TCP 50443 auf outgoing IP 192.168.115.2 Port TCP 443

Du solltest immer explizit die Ports in den Weiterleitungsregeln angeben ! Mit https://<router_ip>:50443 kommst du dann auf den Server.
Was noch wichtig ist, ist eine ggf. vorhandene lokale Firewall (iptables) die generell alles blockt was NICHT vom lokalen IP Netz kommt. Da du ja kein VPN nutzt mit dem iPhone sondern nur Port Forwarding machst kommst du mit einer öffentlichen IP Adresse als Absender IP am Webserver an !
Normalerweise schlägt die lokale FW dann gnadenlos zu wenn man sie nicht vom Gegenteil überzeugt !
Sollte es dennoch wider Erwarten nicht funktionieren starte tcpdump auf dem Linux Server und checke ob dort überhaupt Pakete per Port Forwarding vom Router ankommen !
Bitte warten ..
Mitglied: m.reeger
23.01.2013 um 17:10 Uhr
Erst mal vielen, dank.

Das mit Port 99 war nur reinweg getestet, da wir den port 25789 verwenden wollten, haben wir diesen zuerst auch genutzt. Leider hat das nicht funktioniert...also Port 99 zum testen und es geht immer noch nicht...

Nun wollte ich wie du beschrieben denn https port 443 auf den Linux weiterleiten, puste kuchen port 443 ist bereits an server 1 für exchange weitergeleitet.

Ich habe nun die Firewall beim Linux komplett tot gelegt, da unser Router die Funktion der FW übernimmt.
Leider brachte das auch keinen Fortschritt. Ich werde morgen mal tcpdump starten und checken ob da was durchkommt.
Bitte warten ..
Mitglied: m.reeger
24.01.2013, aktualisiert um 10:11 Uhr
HTTPS weiterleitung geht nun, doch wenn ich den Port 8443 oder 50443 für die Weiterleitung nutzen möchte streikt er.
Wieso auch immer...

Also so habe ich die Config im Moment

Dienst: Benutzerdefiniert
Protokoll : Beliebig
Externe IP-Adresse: Auto
Port: 8443

Weiterleiten an:
Host IP: 192.168.115.2 - 255.255.255.255
Zielport orginal : 443
Bitte warten ..
Mitglied: aqui
24.01.2013 um 10:15 Uhr
Vermutlich ein Bug in der Firmware !! Bist du da auf dem aktuellen Stand ?
Bitte warten ..
Mitglied: m.reeger
24.01.2013 um 11:00 Uhr
habe gerade ein Update gemacht von 7.08 auf 7.10

bringt leider auch kein Erfolg.
Bitte warten ..
Mitglied: aqui
24.01.2013 um 12:24 Uhr
Bug reporten an den Hersteller (Hotline / Support) und auf einen Fix warten...
Bitte warten ..
Mitglied: m.reeger
24.01.2013 um 14:21 Uhr
Bin gerade dabei zu versuchen ob es möglich ist eine HTTP Umleitung einzurichten...

heisst https://externe.ip/oso und man soll auf die 192.168.115.2 weitergeleitet werden.
Intern geht das super, versuche ich es von extern-kein Erfolg. Liegt bestimmt daran dass er versucht auf die interne IP zu Connecten oder? IIS 7- Server 2008
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
DSL, VDSL
gelöst IP6 Portweiterleitung Fritzbox Provider myQuix Saarland (8)

Frage von Re-Animator zum Thema DSL, VDSL ...

Router & Routing
gelöst Zwei DSL Leitungen, Zwei Fritzboxen, Zwei Dyndns Accounts - Portweiterleitung klappt nicht (4)

Frage von caravandriver zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (22)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...