Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Postfix bringt Internetverbindung zum Stillstand

Frage Linux Linux Tools

Mitglied: Wingmaker

Wingmaker (Level 1) - Jetzt verbinden

04.05.2006, aktualisiert 12.05.2006, 5624 Aufrufe, 15 Kommentare

Hallo!

Kurz und ich hoffe gezielt:

Ich bin Linux-Nicht-Insider, also nicht gaaanz so inside dem Linux Stoff, administriere jedoch mit einen Linuxgateway, welcher die Grenze bildet zwischen Firmennetzwerk mit Windows 2003 Exchange Server und Internet.
Auf dem Gateway ist Postfix installiert. Folgendes Problem was auftritt seit heute früh:

Ist Postfix aktiv (postfix start) dann kann ich kurz nach Aufruf dessen noch ins Internet pingen, welches von 20ms Antwortzeit langsam aber sicher nach 10 Pings auf 20sek zieht. Folge: Keine Verbindung mehr zum Internet für das gesamte Netzwerk! Unhaltbar.

Postfix stop bringt wieder fast alles zum Laufen, allerdings können keine Mails versandt und empfangen werden. Ich kann den Gateway Rechner neustarten wie ich will (allein/ohne netzinternen Anschluss, ohne dahinterliegenden ExchangeServer)... stets rötelt er aber das Netz tot. Laut mail.log verschickt er oder/und empfängt er Mails. Im syslog steht sowas wie

postfix/qmgr[7836]: EA7C0A554: from=<email@address.de>.....

wie lösche ich die queue von postfix? vielleicht hilft das?!

prob also: wie bekomme ich postfix wieder zum laufen und zwar ordentlich?

als ursache des gesamten spektakels denke ich, war meine änderung im exchange system manager, durch welche ich größere emails verschicken lassen wollte. allerdings steht ja noch in der master.cf vom postfix der alte wert (von 10MB auf 20MB erhöht gehabt). habe aber alles wieder rückgängig gemacht, bin mir aber nicht sich, ob gestern da noch mails versandt wurden von usern, die nun für den trouble verantwortlich sind.

Jedenfalls HILFE und für nachfragen stehe ich gerne zur Verfügung!!

DANKE!
wm
Mitglied: BigWumpus
04.05.2006 um 23:09 Uhr
Hallo,

ich denke mal, daß Du richtig viel SPAM-Mails von außerhalb gefüttert bekommst, die Dein Postfix dann weiterleitet. Hast Du die Annahmeregeln nur für Deine Domains eingerichtet ?
Bitte warten ..
Mitglied: VoSp
04.05.2006 um 23:25 Uhr
Hallo,

also mit

mailq

solltest Du Dir die Mailqueu anzeigen lassen.

Dann kannst Du mit

postsuper -d <MAILID>

einzelne Mails löschen.

Ich weiss nicht ob Du mit

postsuper -d ALL

alle Mail auf einmal löschen kannst.

MIt

postsuper -r ALL

Kannst Du Sie auf jeden Fall alle nochmal requen.

Bis dann

VoSp
Bitte warten ..
Mitglied: cykes
05.05.2006 um 11:40 Uhr
Hi,

so ohne die Konfiguration zu sehen, ist das etwas schwierig zu beantworten.
Ich würde aber mal tippen, daß Du ein Open Relay hast, und irgendwelche Spammmer
dies schon missbrauchen, das würde das Verhalten erklären.
Gibt es denn irgendwelche Fehlermeldungen in den Logfiles oder in der Ereignisanzeige/Log
des Exchange Servers?

Gruß

cykes
Bitte warten ..
Mitglied: Wingmaker
08.05.2006 um 09:28 Uhr
Hallo, danke für die schnelle Hilfe, Verständnis bitte für die späte Antwort.

Also: postsuper -d ALL funktionierte und löste das Problem!

Wahrscheinliche Fehelrursache:
Ich habe am Vortag die zugelassene Größe für die Anhänge in Mails im Exchange System Manager von 10MB auf 20MB erhöht ohne zu bedenken, dass im Postfix immernoch nur 10MB konfiguriert waren/sind. Zwar habe ich das im Exchange zurückgesetzt, aber da waren wohl (aber kleinere!) Mails im Queue von Postfix, die Trouble machten. Ein Löschen des Queues war erfolgreich!

Hmmm....
Bitte warten ..
Mitglied: Wingmaker
11.05.2006 um 08:55 Uhr
Hey Ihr,

also es funktioniert wieder nicht. Das hängt wohl irgendwoanders der HAken. Auch mag ich den Queue nicht löschen von postfix, da 58 Mails da drin sind und ich weiß nicht, ob sie der Exchange Server dahinter als schon weggesandt markiert hat. sie sollen nicht verloren gehen. aber jedesmal wenn ich postfix stoppe läuft alles wieder normal. woran liegt das? ich brauche dringend unterstützung!
Bitte warten ..
Mitglied: Wingmaker
11.05.2006 um 08:57 Uhr
Auch wird der queue nicht kleiner. bleibt eher gleich. auch schwer vorstellbar, da eigentlich fließender mailverkehr herrscht

auszug aus postqueue -p

-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------

03BD5A84A 480616 Thu May 11 07:10:27 kbarth@xxxx.xx
(Host or domain name not found. Name service error for name=ukd80.xxxxx.de type=MX: Host not found, try again)
roesen-wolff@xxx.xxx
05AF2A751 476005 Thu May 11 07:02:26 dxxx@xxxx
(Host or domain name not found. Name service error for name=urzxxxx.de type=MX: Host not found, try again)
schach@xxxxx
Bitte warten ..
Mitglied: VoSp
11.05.2006 um 08:59 Uhr
Hallo,

poste doch mal ein Stück aus deinem maillog, mal sehen was er da sagt.

Bis dann

VoSp
Bitte warten ..
Mitglied: VoSp
11.05.2006 um 09:40 Uhr
Hallo Wingmaker,

liefert der postfix direkt per DNS aus? Er kann die MX Einträge zu den Domänen per DNS nicht finden. Habt Ihr eine feste IP? Du solltest besser den Smarthost deines Providers in die Config des Postfix eintragen und alle ausgehenden Mails über den laufen lassen. Die direkte Zustellung an die anderen Mailserver klappt bei dial in Umgebunge mit dyn. IP oft nicht.

Dazu musst Du folgendes in die main.cf Eintragen

relayhost = mailserver.deinesproviders.de

Ichz weiss aber nicht ob dein Provider da eine Autentifizierung braucht. Die meissten machen das.

Dann mal nach "postfix smt auth" googgeln und die Daten deines Providers eintragen.

Bis dann

VoSp
Bitte warten ..
Mitglied: Wingmaker
11.05.2006 um 09:45 Uhr
feste IP: ja

nun, danke vorerst, aber ich benötige unbedingt eine schnelle hilfe.

bisher ging es doch auch!! :/

ja, die nameserver sind anpingbar....

nun habe ich den mailqueue gelöscht und glaube die 60mails sind dahin. muss ich mich später an die user wenden, dass sie nochmal senden sollen

aber das problem besteht weiterhin!!!
Bitte warten ..
Mitglied: cykes
11.05.2006 um 10:04 Uhr
Hi,

nenn doch bitte einfach mal Deinen Provider, an den die Mails weitergeleitet werden.
Eventuell hilft es nämlich (bei einigen Providern) die DNS Auflösung abzuschalten, dazu muss man den Namen des SMTP Servers bzw. der eigenen Domain in eckige Klammern in der
Postfix Konfiguration setzen. Also statt z.B. relayhost=deinedoamin.de folgendes
relayhost=[deinedomain.de]

Gruß

cykes
Bitte warten ..
Mitglied: Wingmaker
11.05.2006 um 10:20 Uhr
Also in der main.cf steht
relayhost=
drin.

Hm, im generellen dient der postfix dazu, über den gateway mails durchzulassen, wahr? (glaub da kann man auch noch spam filtern?)

quasi: exchange server -> linux/postfix -> smtp.1und1.de (=Provider)
Bitte warten ..
Mitglied: Wingmaker
11.05.2006 um 10:31 Uhr
hm, cykes, was kannst du daraus machen?: auszug aus dem mail-log:


May 11 09:52:37 gatetest postfix/smtpd[10255]: connect from moutng.kundenserver.de[212.227.126.183]
May 11 09:52:37 gatetest postfix/smtpd[10255]: 6A225A09B: client=moutng.kundenserver.de[212.227.126.183]
May 11 09:52:38 gatetest postfix/cleanup[10256]: 6A225A09B: message-id=<ACECKEOFGOLBPDEPKFEBAECGCAAA.adinsmore@mydomain.xy>
May 11 09:52:38 gatetest postfix/qmgr[10220]: 6A225A09B: from=<adinsmore@mydomain.xy>, size=2106, nrcpt=1 (queue active)
May 11 09:52:38 gatetest postfix/smtp[10253]: 6A225A09B: to=<kstevens@mail.mydomain.xy>, relay=192.168.150.10[192.168.150.10], delay=1, status=sent (250 2.6.0 <ACECKEOFGOLBPDEPKFEBAECGCAAA.adinsmore@mydomain.xy> Queued mail for delivery)
May 11 09:52:38 gatetest postfix/qmgr[10220]: 6A225A09B: removed
May 11 09:52:39 gatetest postfix/smtpd[10255]: disconnect from moutng.kundenserver.de[212.227.126.183]
May 11 09:52:44 gatetest postfix/smtpd[10250]: connect from unknown[192.168.150.10]
May 11 09:52:44 gatetest postfix/smtpd[10250]: E8405A09B: client=unknown[192.168.150.10]
May 11 09:52:44 gatetest postfix/cleanup[10251]: E8405A09B: message-id=<6A15C49110CB4E4CAF875AED39E9D0C9099279@gondor.dresden-is.local>
May 11 09:52:44 gatetest postfix/smtpd[10250]: disconnect from unknown[192.168.150.10]
May 11 09:52:44 gatetest postfix/qmgr[10220]: E8405A09B: from=<kbarth@mydomain.xy>, size=856, nrcpt=1 (queue active)
May 11 09:52:48 gatetest postfix/smtp[10252]: E8405A09B: to=<uthomas@mydomain.xy>, relay=mx00.schlund.de[212.227.15.150], delay=4, status=sent (250 Message 0ML3Dg-1Fe5yc0JjC-0000aN accepted by mxeu14.kundenserver.de)
May 11 09:52:48 gatetest postfix/qmgr[10220]: E8405A09B: removed
May 11 09:53:02 gatetest postfix/smtpd[10255]: connect from unknown[192.168.150.122]
May 11 09:53:02 gatetest postfix/smtpd[10255]: E43B1A09B: client=unknown[192.168.150.122]
May 11 09:53:06 gatetest postfix/smtpd[10255]: A3BCAA09B: client=unknown[192.168.150.122]
May 11 09:53:08 gatetest postfix/smtpd[10255]: 7A787A09B: client=unknown[192.168.150.122]
May 11 09:53:08 gatetest postfix/cleanup[10256]: 7A787A09B: message-id=<ANEIKGILFNBLGINFJFJKKELLCGAA.sgillespie@mydomain.xy>
May 11 09:53:08 gatetest postfix/qmgr[10220]: 7A787A09B: from=<sgillespie@mydomain.xy>, size=6775, nrcpt=1 (queue active)
May 11 09:53:08 gatetest postfix/smtpd[10255]: 958EDA713: client=unknown[192.168.150.122]
May 11 09:53:08 gatetest postfix/cleanup[10251]: 958EDA713: message-id=<ANEIKGILFNBLGINFJFJKMELLCGAA.sgillespie@mydomain.xy>
May 11 09:53:08 gatetest postfix/qmgr[10220]: 958EDA713: from=<sgillespie@mydomain.xy>, size=3448, nrcpt=1 (queue active)
May 11 09:53:09 gatetest postfix/smtpd[10255]: disconnect from unknown[192.168.150.122]
May 11 09:53:17 gatetest postfix/smtp[10253]: 7A787A09B: to=<karndt@mydomain.xy>, relay=mx01.schlund.de[212.227.15.186], delay=9, status=sent (250 Message 0MKqIe-1Fe5z02pYy-0000xm accepted by mxeu3.kundenserver.de)
May 11 09:53:17 gatetest postfix/qmgr[10220]: 7A787A09B: removed




du meintest vorhin den moutng.kundenserver.de[212.227.126.183], richtig?

aha, so arbeitet postfix also mit einem connect zu dem server (steht in der /etc/hosts?), schickt ab und disconnected wieder. was bedeutet dann das removed? ah, aus der queue gelöscht. nun frag ich mich wo vorher die verstopfung herkam, dass ich 60 mails im queue hatte. nach dem löschen und warten einiger minuten ging's dann wieder. bis jetzt. wann nur läuft das ding wieder zu? und ich weiß immer noch nicht, ob die mails wirklich versandt wurden. herje.... aber ich beginne, besser zu verstehen
Bitte warten ..
Mitglied: cykes
12.05.2006 um 06:32 Uhr
Hi,

von der Postfix-Seite sieht das eigentlich OK aus. Könnte halt sein, dass der "Stau" aufgrund
eines Fehlers bei Eurem Provider aufgetreten ist, z.B. könnte der Mailserver des Providers
nicht erreichbar gewesen sein oder die DSL Verbindung hatte eine Störung und dann
haben sich einige Mails angesammelt.

Existiert das Maillog von dem zeitraum noch?

Gruß

cykes
Bitte warten ..
Mitglied: BigWumpus
12.05.2006 um 09:27 Uhr
Wenn Du direkt an Server auslieferst, kann es sein, daß bestimmte Gegenstellen diese Mails nicht annehmen, weil sie aus dem DSL-Netz kommt. (Blacklisted)
Bitte warten ..
Mitglied: Wingmaker
12.05.2006 um 09:37 Uhr
Nun die Maillogs sind vorhanden. Allerdings weniger aussagekräftig, sprich okay soweit. sobald nix geht steht halt disconnected im log und somit unversandt. timeout. und dieses timeout wirkt sich ja im gesamten netzverbindungsbereich nach außen aus. sprich da stockt alles und zwar richtig. die mails somit auch. was auch seltsam ist: gestern habe ich es zum laufen gebracht durch queue löschen. seitdem werden fröhlich mails versandt aber ich sehe nie eine einzige im queue. entweder gehen die gleich so schnell heraus... dann ist es mir unerklärbar, wieso da gestern 59 mails drin steckten. die logs sind einfach zu wenig aussagekräftig
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
DSL, VDSL
OpenWRT VDSL VOIP Internetverbindung herstellen (3)

Frage von danielr1996 zum Thema DSL, VDSL ...

Router & Routing
Neue Top Level Domain .box bringt manche Netze durcheinander (1)

Link von magicteddy zum Thema Router & Routing ...

Router & Routing
Neue Top Level Domain .box bringt manche Fritzbox-Netze durcheinander (3)

Link von mikrotik zum Thema Router & Routing ...

Webbrowser
Mozilla: Firefox 50 startet schnell und bringt Emoji (3)

Link von Frank zum Thema Webbrowser ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (22)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...