Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

postfix kann nicht auf Datenbank zugreifen

Frage Linux Linux Netzwerk

Mitglied: carpe-diem

carpe-diem (Level 1) - Jetzt verbinden

01.08.2008, aktualisiert 11.08.2008, 6569 Aufrufe, 9 Kommentare

Postfix liefert bei Aufruf von mail einen DB-Fehler

Wenn ich eine Testverbindung über telnet zu meinem Webserver aufbaue, kann ich mich mit ehlo verbinden. Nach der eingabe von mail reagiert telnet nicht mehr.
In der Log kommt folgende Meldung:
Aug 1 18:20:13 v24939 postfix/trivial-rewrite[29592]: warning: connect to mysql server unix:/opt/lampp/var/mysql/mysql.sock: Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (2)
Aug 1 18:20:13 v24939 postfix/trivial-rewrite[29592]: fatal: mysql:/etc/postfix/mysql-virtual-alias-maps.cf(0,lock|fold_fix): table lookup problem

Ich habe postfix nach der Anleitung von http://workaround.org/articles/ispmail-etch/index.html.de konfiguriert und alle Schritte (vor allem die "postmap -q example.com mysql:/etc/postfix/mysql-virtual-mailbox-domains.cf"-Prüfungen liefern eine 1 zurück) gehen auch soweit, nur das große ganze harmonisiert noch nicht.
Als Datenbank läuft MySQL in Verbindung mit XAMPP.

Zudem kann ich nur über domain.de und nicht über mail.domain.de zugreifen.

Vielen Dank für eure Hilfe
Manuel



Meine main.cf:
  1. See /usr/share/postfix/main.cf.dist for a commented, more complete version


  1. Debian specific: Specifying a file name will cause the first
  2. line of that file to be used as the name. The Debian default
  3. is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

  1. appending .domain is the MUA's job.
append_dot_mydomain = no

  1. Uncomment the next line to generate "delayed mail" warnings
delay_warning_time = 4h

  1. TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

  1. See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
  2. information on enabling SSL in the smtp client.

myhostname = mail.domain.de
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = mail.domain.de, localhost.domain.de, , localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual-mailbox-domains.cf
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual-mailbox-maps.cf
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual-alias-maps.cf,mysql:/etc/postfix/mysql-email2email.cf
virtual_transport = dovecot
dovecot_destination_recipient_limit = 1
Mitglied: theton
02.08.2008 um 00:10 Uhr
Existiert die Socket-Datei denn oder liegt diese evtl. an einer anderen Stelle? Evtl. mal den DB-Zugriff nicht über localhost/127.0.0.1 machen sondern über die IP des Rechners machen. Dann sucht er nämlich nicht nach einem Socket.

Und wegen dem Zugriff... verweist denn ein DNS-Eintrag für mail.domain.de auf die richtige IP des Rechners?
Bitte warten ..
Mitglied: carpe-diem
02.08.2008 um 12:26 Uhr
Die Socketdatei existiert. Wenn ich über localhost oder externe IP darauf zugreifen will, dann bekomme ich auch bei postmap einen Fehler.

Ein DNS-Eintrag auf mail.domain.de ist vorhanden.

Vielen Dank
Manuel
Bitte warten ..
Mitglied: 16568
02.08.2008 um 15:47 Uhr
Kann das "so rein zufällig" sein, daß lokale Zugriffe nicht erfolgen können, weil entweder in der MySQL-Config was verbogen ist (is der MySQL-Server gestartet?), oder daß evtl. ein Pwd verlangt wird, welches nicht gegeben ist...?


Lonesome Walker
Bitte warten ..
Mitglied: carpe-diem
02.08.2008 um 18:12 Uhr
In der Anleitung wird ja hier ( http://workaround.org/articles/ispmail-etch/index.html.de#schritt-4-ers ... ) eine Datei mit dem Passwort und allem angelegt, welche ja auch mit postmap aufgerufen wird und soweit funktioniert. Ich habe auch an der Datenbank nichts geändert, sie ist noch so konfiguriert wie sie von Haus aus bei XAMPP kommt (außer Passwort gesetzt und solche Sicherheitseinstellungen).
Bitte warten ..
Mitglied: theton
02.08.2008 um 20:25 Uhr
Hat der Mailserver-User ausreichend Rechte auf den Ordner /opt/lampp/var/mysql/ und die darin liegende Socket-Datei? Einfach mal in der /etc/passwd eine Shell für den User eintragen, mittels 'su - mailserverbenutzer' sein UID annehmen und dann mal probieren, ob du via 'mysql -u benutzername -p' zur Datenbank verbinden kannst.
Bitte warten ..
Mitglied: carpe-diem
03.08.2008 um 14:40 Uhr
Ich denke mit Mailserveruser ist der User postfix gemeint. Habe aber auch mal den Benutzer vmail probiert und mit beiden bin ich auf den mysql-prompt gekommen.
Bitte warten ..
Mitglied: carpe-diem
10.08.2008 um 22:58 Uhr
Nach etwas rumprobieren ging es nun einen Schritt weiter. Ich kann jetzt eine Email über telnet senden.
Jedoch kommt der Fehler:
451 4.3.0 Error: queue file write error

Zudem habe ich noch warning: /usr/lib/postfix/trivial-rewrite: bad command startup -- throttling in meine Logfile.

Vielen dank euch schonmal
manuel
Bitte warten ..
Mitglied: theton
11.08.2008 um 04:58 Uhr
"queue file write error" tritt meist auf, wenn Amavis eine Email nicht korrekt verarbeiten kann. Einfach mal in die Logs vom Amavis schauen ob es da irgendwelche Probleme gibt.

Woran lag denn nun das DB-Problem? Würde mich mal interessieren, falls man mal vor einem ähnlichen Problem hängt.
Bitte warten ..
Mitglied: carpe-diem
11.08.2008 um 09:23 Uhr
Das DB-Problem ist noch nicht ganz überstanden, aber es lag an den Optionen chroot in der master.cf. Dort habe ich smtp und rewrite auf n gesetzt.
Amavis ist noch gar nicht konfiguriert. Bin ja bei dem Tutorial bei Schritt 7 stehen geblieben. Höchstens es ist ein Problem mit dovecot.
Bitte warten ..
Ähnliche Inhalte
Datenbanken
MySQL unter OpenSuse - mit Workbench auf Datenbank zugreifen nicht möglich
gelöst Frage von AndyAhDatenbanken11 Kommentare

Hi NG, beim Versuch mit MySQL-Workbench auf einen MySQL (Mariadb) Server zuzugreifen erhielt ich folgende Fehlermeldung: your connection attempt ...

Verschlüsselung & Zertifikate
Postfix und RC4
gelöst Frage von agowa338Verschlüsselung & Zertifikate2 Kommentare

Hallo, wie deaktiviert man RC4 bei einem Postfix mail server? Ich habe folgendes in der Konfiguration: Aber der Server ...

E-Mail
Exchange + Postfix
Frage von hash2k2E-Mail4 Kommentare

Hallo, ich möchte folgendes einrichten: Einen Exchange 2007 Server mit Postfächern und möchte zusätzlich einen Postfixserver aufsetzten, der alle ...

Debian
Fehler beim Senden mit Postfix
Frage von roland123Debian11 Kommentare

Guten Abend, ich habe auf meinem Debian 7 32bit einen Postfix installiert. Der Postfix soll über ein externes Postfach ...

Neue Wissensbeiträge
Verschlüsselung & Zertifikate

Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows

Information von ticuta1 vor 30 MinutenVerschlüsselung & Zertifikate

Interessant SSH-Kommando in CMD.exe und PowerShell

Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 1 TagApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Heiß diskutierte Inhalte
Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement17 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...