Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Postfix (Lokale Mails werden ohne Authentifizierung gesendet)

Frage Linux Linux Netzwerk

Mitglied: hanspeter

hanspeter (Level 1) - Jetzt verbinden

13.02.2007, aktualisiert 21.02.2007, 5533 Aufrufe, 1 Kommentar

Hallo,
ich habe ein kleines Problem. Ich verwende auf einem Server Postfix und den Cyrus.
Bei einer ausgehenden Mail über den Server wird nach einer Authorisierung gefragt. Klappt alles wunderbar. Ein problem tritt nur auf, wenn ich eine email an <user>@<meinhost> sende. Postfix verlangt nun nicht nach einer Authentifizierung, er sendet die E-Mail ohne irgendwelche Beanstandigungen. Er fragt lediglich bei <user>@<anderer host z.b. web.de> nach einer Authentifizierung. Wo liegt der Einstellungsfehler? Weiß jemand darüber etwas?


Hier die main.cf von Postfix

command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
myhostname = <mein host>
inet_interfaces = $myhostname
mydestination = $myhostname, localhost.$mydomain, localhost
unknown_local_recipient_reject_code = 550
mail_spool_directory = /var/spool/imap/user
mailbox_transport = cyrus
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5

sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
setgid_group = maildrop
html_directory = /usr/share/doc/packages/postfix/html
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/packages/postfix/samples
readme_directory = /usr/share/doc/packages/postfix/README_FILES
biff = no
message_size_limit = 31457280
smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_authenticated_header = yes
Mitglied: flo84
21.02.2007 um 16:47 Uhr
Serwus,
auch ich hab' Postfix und Cyrus unter Debian am Werkeln. Zudem wurden die notwendigen Pakete installiert, damit Cyrus auch als POP3-Server arbeiten kann.
Zu deinem Problem: zunächst hab' ich das mal bei mir getestet und festgestellt, dass ich in keinem Fall nach eine Passwort beim Versand gefragt werde
Da ich mich ja gerne mit solchen Sachen rumspiele bin ich auf folgendes Ergebnis gekommen: ergänze bzw. ändere mal deine main.cf um diese Einträge:

01.
smtpd_sasl_auth_enable = yes 
02.
smtpd_sender_restrictions = permit_sasl_authenticated, reject_non_fqdn_sender,reject_unknown_sender_domain,permit 
03.
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_auth_destination, reject_unauth_destination,permit 
Diese Zeilen haben bei mir geholfen, damit ich beim Versenden der Mail auch nach dem Passwort gefragt werde - hoffe, dass dir das weiterhilft.


Flo
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Outlook & Mail
Outlook 2010 Mails im Entwürfeordner sind als "gesendet" markiert

Frage von staybb zum Thema Outlook & Mail ...

Windows Server
gelöst MS-SQL Server lokale Authentifizierung - Logging (5)

Frage von ThomasAnderson zum Thema Windows Server ...

E-Mail
Mails von Mailserver werden als SPAM eingestuft (12)

Frage von ClepToManix zum Thema E-Mail ...

Windows Server
gelöst Zertifikate nur für die lokale Domäne ausstellen (3)

Frage von backslash zum Thema Windows Server ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (32)

Frage von Maik82 zum Thema Linux Netzwerk ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Hardware
gelöst PCI-Express-Adapterfrage (14)

Frage von DerWoWusste zum Thema Hardware ...