Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Postfix Routet keine Mails mehr nach Änderung in amavisd.conf

Frage Internet E-Mail

Mitglied: Burschi

Burschi (Level 1) - Jetzt verbinden

20.04.2006, aktualisiert 24.04.2006, 5117 Aufrufe, 4 Kommentare

Nach Änderung der amavisd.conf nimmt...

... Postfix die Mail aus dem Internet zwar noch an, beim Weiterleiten an 127.0.0.1 (Virenscanner) wird die Mail dann aber rejected. Die von mir vorgenommende Änderung sollte bewirken, dass Empfänger von Virenverseuchten Mails darüber informiert werden, dass Sie die Mail nicht bekommen haben.

  1. SOME OTHER VARIABLES WORTH CONSIDERING (see amavisd.conf-default for all)

  1. $warnbadhsender,
  2. $warnvirusrecip, <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<---------- den Eintrag hier hatte ich aktiviert.
  3. $warnbannedrecip, $warnbadhrecip, (or @warn*recip_maps)
  1. @bypass_virus_checks_maps, @bypass_spam_checks_maps,
  2. @bypass_banned_checks_maps, @bypass_header_checks_maps,
  1. @VIRUS_lovers_maps, @spam_lovers_maps,


Das Problem sieht dann im LOG so aus:

Apr 20 15:24:13 mail1 postfix/smtp[16579]: 29A8E81E044: to=<LXXXXX@gmx.de>, relay=none, delay=588, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)


So. Ich hoffe, dass jemand eine Idee hat, ich bin grad mit meinem Latein am Ende und gehe erst aml eine Runde Radeln.

Vielen Dank für sinnige Beiträge
Mitglied: justinp
20.04.2006 um 16:21 Uhr
Hallo,

jetzt mal ungeachtet deiner Änderungen an der .conf...Hast du überprüft ob der Amavisd läuft
(ps -ef|grep amavis)
und die Ports entsprechend der master.cf offen sind (default 10024 + 10025)
(netstat -anp|grep 10024)?

Gruß
justin
Bitte warten ..
Mitglied: Burschi
20.04.2006 um 16:39 Uhr
Hallo,

also das mit dem Port könnte sein:


Apr 20 16:34:03 mail1 postfix/smtpd[22722]: connect from pdxxxxxx4.dip0.t-ipconnect.de[2xx.91.x.xxx]
Apr 20 16:34:03 mail1 postfix/smtpd[22722]: DE33481E044: client=pdxxxxxxx.dip0.t-ipconnect.de[217.91.8.228], sasl_method=LOGIN, sasl_username=lixxxxxxx
Apr 20 16:34:04 mail1 postfix/cleanup[23523]: DE33481E044: message-id=<20060420143403.DE33481E044@mail1.xxxxxxx.de>
Apr 20 16:34:04 mail1 postfix/qmgr[9060]: DE33481E044: from=<lixxxx.xxxxx@xxxxx.de>, size=474, nrcpt=1 (queue active)
Apr 20 16:34:04 mail1 postfix/smtp[23651]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
Apr 20 16:34:04 mail1 postfix/smtpd[22722]: disconnect from pxxxxxxe4.dip0.t-ipconnect.de[x17.xx.8.xx8]
Apr 20 16:34:04 mail1 postfix/smtp[23651]: DE33481E044: to=<lixxxx.xxxxx@xxxxx.de>, relay=none, delay=1, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)

Nur wieso ist der Port aufgrund des geänderten parameters nicht mehr aktiv? Das hat doch damit garnichts zu tun!????
Bitte warten ..
Mitglied: justinp
24.04.2006 um 12:08 Uhr
Das hat doch damit garnichts zu tun!????


So ist es.
Du solltest daher erstmal sicherstellen, dass Amavis läuft und die Ports 10024 _und_ 10025 offen sind. Falls es nicht läuft starte Amavis:
/etc/init.d/amavis start
Falls es sich nicht starten lässt prüfe in den logs warum.


Weiterhin hast du jetzt vermutlich jede Menge alte E-Mails in der Warteschlange. Check das mit postqueue -p

Mit einem postqueue -f werden die E-Mails zugestellt.

Gruß
Justin
Bitte warten ..
Mitglied: Burschi
24.04.2006 um 13:07 Uhr
Okay... ich seh schon, so kommen wir nicht weiter. Also eine mailq gabs zum glück nicht, denn wenn ich den Parameter wieder entferne (was ich auch getan habe) dann funktioniert alles in alter Güte. Nach einem restart.

Aber ums auf den Punkt zu bringen, meine Absicht war ja, dass Amavis nicht nur erfolgreich verseuchte Nachrichten blockt, löscht und mir als Admin einen Nachricht zukommen lässt, sondern dem Empfänger auch noch mitteilt, dass er was aus dem o.a. Grund nicht bekommen hat.

Alles funtkioniert, nur nicht die Nachricht an den ursprünglichen Empfänger.

Kannst Du mir damit helfen? Danke jedenfalls schon jetzt für Deine Bemühungen!
Bitte warten ..
Ähnliche Inhalte
Linux
Postfix: Annahme von Mails
Frage von schneerunzelLinux

Hallo zusammen, ich habe seit über eine Jahr ein Zarafa Server mit einem Postfix dadrunter. Bisher hatten wir nur ...

Linux
Ankommende Mails mit Postfix nicht weiterleiten
Frage von todestoasterLinux6 Kommentare

Hi, Ich habe das Problem, dass mein Mailserver eingehende Mails immer weiterleitet. Im Netz finde ich nur Anleitungen, wie ...

Exchange Server
Exchange 2016 routet E-Mails in falsches Postfach
Frage von MasterPhilExchange Server13 Kommentare

Hallo Zusammen, ein etwas komischer Fehler, der seit einiger Zeit auftaucht und ich mich zum Verzweifeln bringt: Installiert ist ...

E-Mail
Alle E-Mails in einer Postfix Mailqueue löschen
Tipp von FrankE-Mail2 Kommentare

Hallo Administratoren, So löscht man alle Mails die noch in der Postfix Mailqueue hängen: P.S. ich weiß, dass ist ...

Neue Wissensbeiträge
Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 6 StundenInternet3 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registierunf von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 13 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 1 TagWindows 103 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 1 TagSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless17 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement16 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...