Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Postgresql Failed to Start

Frage Linux

Mitglied: itproject

itproject (Level 1) - Jetzt verbinden

25.01.2011 um 10:51 Uhr, 4052 Aufrufe, 2 Kommentare

Hallo zusammen,

habe ein kleines Problem hier...

hab mir per:

"yum install postgresql postgresql-server postgresql-contrib"

PostgreSQL 8.4 auf meinen Fendora 8 Server installiert.

Nun möchte ich den Datenbankserver allerdings gerne starten bekomme jedoch einige Fehlermeldungen:

[root@meinserver]# /etc/init.d/postgresql start
/var/lib/pgsql/data is missing. Use "service postgresql initdb" to initialize the cluster first.

--> Daraufhin....

[root@meinserver]# service postgresql initdb
Initializing database: mkdir: cannot create directory `/var/lib/pgsql/data/pg_log': File exists

--> Daraufhin...

rm -R /var/lib/pgsql/data/pg_log


--> Leider beginnt nun die ganze Sache wieder von vorne
Hat jemand vielleicht eine Idee?

Viele Grüße

Itproject
Mitglied: Listo
25.01.2011 um 10:58 Uhr
Hallo ltproject,

versuche mal folgendes:

1. Lösche alle Dateien und Verzeichnisse unterhalb von /var/lib/pgsql

2. Führe dann service postgresql initdb erneut aus.

Dann sollte das hoffentlich klappen.

Gruß
Listo
Bitte warten ..
Mitglied: itproject
25.01.2011 um 15:36 Uhr
Hi,

danke für die Antwort
War allerdings ein blöder Fehler von mir....

postgres -D /usr/local/pgsql/data/ hat es getan^^




--> habe allerdings nun ein anderes Problemchen... gehoert eigentlich wo anderst rein, vielleicht weiss jemand aber bescheid

.... habe 2 Webhosted Server.....

der eine bereits konfiguriert und lauffähig.

der andere wird gerade konfiguriert... und natürlich noch nicht lauffähig

Mein Problem ist, ich kann beide Server Pingen, per SSH drauf und habe für den Tomcat den Port 8180 eingestellt...

Jedoch wenn ich den server über http://publicdns:8180/tomcatproject öffnen möchte klappt das beim einen server super ... beim anderen nicht...

habe die vermutung das NAT schuld sein könnte.... nun fragt sich wo ich NAT konfigurationen bei Fendora 8 einstellen kann o.O


Vielleicht weiss ja jemand bescheid.

Danke u Gruß

ITproject
Bitte warten ..
Ähnliche Inhalte
Debian
gelöst Debian Wheezy Postgresql installation (5)

Frage von Thomas91 zum Thema Debian ...

Exchange Server
gelöst Exchange2013 ContexIndexState Failed (5)

Frage von Florian86 zum Thema Exchange Server ...

Apple
TL-R470T+ Online Detection failed (1)

Frage von Mein.Lan zum Thema Apple ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
CNC Maschinen verlieren Netzwerkverbindung (kurioser Fehler) (22)

Frage von NoHopeNoFear zum Thema LAN, WAN, Wireless ...

Drucker und Scanner
Erfahrungen mit Enterprise-Tintenstrahldruckern A4 und A3 (14)

Frage von User1000 zum Thema Drucker und Scanner ...

Webentwicklung
Aktuellen Mitarbeiter auf Homepage anzeigen (13)

Frage von alemanne21 zum Thema Webentwicklung ...