Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Powershell 4.0 und Exchange 2010 SP3 RU6?

Frage Microsoft Exchange Server

Mitglied: AdminKnecht

AdminKnecht (Level 1) - Jetzt verbinden

25.07.2014 um 09:46 Uhr, 3894 Aufrufe, 7 Kommentare

Hallo zusammen,

in letzter Zeit stolpere ich immer öfter über die Powershell 4.0, die für viele cmdlets hier aus dem Forum und andere nette Dinge (Report-Skript von frankysweb.de...) vorausgesetzt wird!

An unserem Exchange 2010 mit SP3 und RU6 (also top-aktuell) mit installiertem .NET-Framework 4.5.1 lasse ich zwar regelmäßig die MS-Updates ran, halte die Kiste aber ansonsten sauber von irgendwelchen optionalen Updates, daher läuft das bisher auch reibungslos

Die Powershell / EMS ist daher immer noch auf der Version 2.0

Mit der EMS lasse ich direkt am Server ab und an einige cmdlets auf den Exchange los, um Statistiken zu Postfächern, Mailfluss etc. zu generieren

Meine Frage ist nun, was ich beachten muss, wenn ich das auf die 4.0 hochziehen möchte, mit welchen Seiteneffekten muss ich rechnen, was sagt die EMS dazu, usw. usw....

Schon mal besten Dank für Tipps und Infos und auch ein schönes Wochenende

Marcus
Mitglied: Dani
25.07.2014 um 09:53 Uhr
Moin Marcus,
auf unseren Exchange 2010 ist Powershell 4.0 seit einigen Wochen installiert und konnten keine Fehler / Probleme ausmachen.
Allerdings ist seitdem kein RU mehr erschienen. Mit WMF 3.0 gibt es ein Altbekanntes Problem bei der Installation von RU-Packs. Laut Microsoft Support ist WMF 3.0 auf Exchange 2010 nicht empfohlen. Den Blogartikel reiche nach, wenn ich wieder Boden unter den Füßen habe.


Grüße,
Dani
Bitte warten ..
Mitglied: colinardo
25.07.2014, aktualisiert um 10:05 Uhr
Hallo Marcus,
also in den zahlreichen Installationen die ich bisher auf PS 4.0 vorgenommen habe, konnte ich bisher keine groben Fehler feststellen, und ich mache sehr viel mit Powershell. Außerdem steht dir bei aktualisiertem Management Framework die Powershell Version 2.0 trotzdem weiterhin zur Verfügung, was auch die EMS Defaultmäßig weiternutzt wenn du es nicht explizit in der Verknüpfung mit dem Parameter -version umstellst.
Das kannst du nachvollziehen wenn du mal auf einem System mit installierter Powershell 4.0 "powershell -version 2" in eine Konsole eintippst und dann $psversiontable eingibst.

Sei dir aber auch im klaren das nicht alle CMDLets aus Powershell 4.0 wirklich verfügbar sind. Denn die meisten neuen CMDLets laufen erst ab Windows Server 2012R2!

Grüße Uwe
Bitte warten ..
Mitglied: AdminKnecht
25.07.2014 um 13:41 Uhr
Hallo Dani & Uwe,

danke erstmal für die Infos, ich bin bei weiteren Recherchen noch über diese Info gestolpert

http://social.technet.microsoft.com/Forums/exchange/en-US/bcde2ca6-cb63 ...

in den beiden Links zu den MS-Blogs wird doch eigentlich ausdrücklich abgeraten, WMF/PS4 (selbst WMF/PS3 !) an einem MSX2010 einzusetzen?

Das verwirrt mich jetzt etwas....

Viele Grüße

Marcus
Bitte warten ..
Mitglied: Dani
25.07.2014 um 13:44 Uhr
Moin,
in den beiden Links zu den MS-Blogs wird doch eigentlich ausdrücklich abgeraten, WMF/PS4 (selbst WMF/PS3 !) an einem MSX2010 einzusetzen?
Hab nix anderes geschrieben. hier noch der Blogeintrag.


Grüße,
Dani
Bitte warten ..
Mitglied: Dani
13.12.2014, aktualisiert um 12:33 Uhr
Kleines Update seitens Microsoft:
WMF 4.0 kann jetzt auf Servern ausgeführt werden, auf denen die folgenden Serveranwendungen ausgeführt werden. Um WMF 4.0 ausführen zu können, sind mindestens die angegebenen Versionen erforderlich. 
- Microsoft Exchange Server 2013 Service Pack 1 
- Microsoft Exchange Server 2010 SP3 mit Updaterollup 5 
 
WMF 4.0 kann nur unter folgenden Betriebssystemen installiert werden.  
- Windows 7 mit Service Pack 1 
- Windows Server 2008 R2 mit Service Pack 1 
- Windows Server 2012
Gruß,
Dani
Bitte warten ..
Mitglied: AdminKnecht
15.12.2014 um 11:25 Uhr
...wow, danke, das du das noch im Fokus hattest!

Einen schönen Wochenstart wünsche ich!

Marcus
Bitte warten ..
Mitglied: Dani
15.12.2014 um 13:21 Uhr
Kein Problem... wenn's das war, bitte Beitrag auf gelöst setzen.


Gruß,
Dani
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
Installation aktuelles Rollup für Exchange 2010 SP3 - Schwierigkeiten? (4)

Frage von Excaliburx zum Thema Exchange Server ...

Exchange Server
Exchange 2010 SP3 Default Limits (3)

Frage von Excaliburx zum Thema Exchange Server ...

Exchange Server
Exchange 2010 SP3 UR14 Outlook 2010 Cache Mode (2)

Frage von maxpoint zum Thema Exchange Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...