Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Powershell Abfrage funktioniert nicht richtig

Frage Microsoft Windows Userverwaltung

Mitglied: SMHAMK1985

SMHAMK1985 (Level 1) - Jetzt verbinden

18.03.2013 um 16:40 Uhr, 2141 Aufrufe, 5 Kommentare

Hallo,

wenn ich folgende Abfrage mache:

get-aduser -Filter * -Properties * | where {$_.UserAccountControl -eq "66082" -and $_.msExchHideFromAddressLists -eq "False"} | FT Name

werden mir nur die deaktivierten Konten angezeigt, jedoch die abfrage "-and $_.msExchHideFromAddressLists -eq "False"}" funktioniert irgendwie nicht. Egal ob ich True oder False mache kommt immer das gleiche raus.

Habe einen Exchange 2010 und Windows 2008 Server AD.

Diese abfrage habe ich auf dem AD sowie Exchange ausgeführt, immer das selbe.

Was ist hier falsch!?

Danke für eure Hilfe.

Mfg
Mitglied: 76109
18.03.2013 um 17:25 Uhr
Hallo SMHAMK1985!

Und wenn Du die Stringzeichen (") bei False weglässt?

Gruß Dieter
Bitte warten ..
Mitglied: SMHAMK1985
19.03.2013 um 08:06 Uhr
Hallo,

danke für die Antwort. Bekomme die Fehlermeldung:

Sie müssen auf der rechten Seite des Operators "-eq" einen Wertausdruck angeben.

funktioniert leider nicht so!

Mfg
Bitte warten ..
Mitglied: B4DschK4Pp
19.03.2013 um 10:04 Uhr
Hi SMHAMK1985,

weiß nicht ob es am "False" liegt, aber probier's mal statt "False" mit $false .

Gruß
Bitte warten ..
Mitglied: SMHAMK1985
19.03.2013 um 10:26 Uhr
Joo das war es

Danke
Bitte warten ..
Mitglied: B4DschK4Pp
19.03.2013 um 10:49 Uhr
Klasse,

kannst die Frage als gelöst markieren.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
C und C++
gelöst IF Abfrage funktioniert nicht mehr (2)

Frage von pablovic zum Thema C und C ...

Windows Server
Powershell Skript funktioniert im Task Scheduler nicht (4)

Frage von winlin zum Thema Windows Server ...

Batch & Shell
gelöst Powershell funktioniert nicht richtig beim Auslesen der letzten Zeile (5)

Frage von Peter32 zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...