Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

PowerShell Active Directory

Frage Microsoft Windows Server

Mitglied: makaroni

makaroni (Level 1) - Jetzt verbinden

02.01.2015, aktualisiert 15:30 Uhr, 1070 Aufrufe, 8 Kommentare

Ganz kurz und knapp:

ALLE Nutzer einer OU inklusive Benutzer von Unterordnern klappt soweit, außer, dass wenn die OU Domain Users vorhanden ist, die Benutzer nicht angezeigt werden...

Wo muss ich ne Pipe oder sonstiges setzen?
Mitglied: colinardo
02.01.2015, aktualisiert um 17:08 Uhr
Hallo makaroni,
außer, dass wenn die OU Domain Users vorhanden ist, die Benutzer nicht angezeigt werden...
Erkläre mal was du meinst, das versteht man so leider nicht.

Grüße @colinardo
Bitte warten ..
Mitglied: makaroni
02.01.2015 um 14:46 Uhr
Hallo zusammen :-P

Also ich habe eine Gruppe z.B. "Internet". In dieser Gruppe befinden sich alle Nutzer die Zugriff aufs Internet haben sollen. Nun gibt es Kunden bei uns, die in die Gruppe, einfach die "Domain Users" hinzufügen, sodass alle Nutzer Zugriff bekommen. Diese kann ich mir aber nicht über Get-ADGroupMember anzeigen lassen. Nur wenn ich expliziert nach den "Domain Users" suche...

Grüße makaroni
Bitte warten ..
Mitglied: colinardo
02.01.2015, aktualisiert um 14:53 Uhr
Dafür gibt es den Parameter -Recursive der alle Gruppen rekursiv auflöst...
Get-AdGroupMember Internet -Recursive
Bitte warten ..
Mitglied: makaroni
02.01.2015 um 14:54 Uhr
Ja den nutze ich bereits, allerdings bleibt dabei trotzdem die Gruppe "Domain Users" unberührt
Bitte warten ..
Mitglied: colinardo
LÖSUNG 02.01.2015, aktualisiert um 15:30 Uhr
Zitat von makaroni:
allerdings bleibt dabei trotzdem die Gruppe "Domain Users" unberührt
In der Tat, das scheint ein Bug zu sein ... werde dem mal nachgehen...
Vorübergehend kannst du es so lösen:
01.
$gruppe = "Internet" 
02.
$all = @() 
03.
$all += Get-ADGroupMember $gruppe -Recursive 
04.
$all += Get-ADGroupMember $gruppe | ?{$_.objectClass -eq "group"} | Get-ADGroupMember -Recursive 
05.
$all = $all | select -Unique 
06.
$all
Grüße Uwe
Bitte warten ..
Mitglied: makaroni
02.01.2015 um 15:36 Uhr
Meldest Du Dich dann hier wenn du was neues weißt ?
Bitte warten ..
Mitglied: colinardo
02.01.2015, aktualisiert um 17:04 Uhr
Hab das mal ins Technet gepostet ... mal sehen ob dort einer Bescheid weiß, im Web finde ich zumindest absolut nichts zum Thema.

-edit- Thema wird hier ebenfalls diskutiert: http://community.spiceworks.com/topic/487473-recursive-query-in-active- ...
Bitte warten ..
Mitglied: colinardo
LÖSUNG 21.01.2015, aktualisiert 22.01.2015
Also,so wie es aussieht ist das von MS so vorgesehen, warum das Frag mal die aus Redmond. Zumindest steht in der Shell in der Eigenschaft Members der UserGroup Domain Users kein User, das ist wohl die Ursache.

Siehe meinen Technet-Post

Grüße Uwe
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Powershell Vergleichen Name u Vorname mit Active Directory (5)

Frage von pixel0815 zum Thema Batch & Shell ...

Windows Server
gelöst Active Directory Zertifikatdienste - Dienst kann nicht gestartet werden (1)

Frage von chb1982 zum Thema Windows Server ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(5)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Statische Routen mit Shorewall, ISC-DHCP Server konfigurieren für Android Devices (24)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

Hardware
16-20 Port POE Switch mit VLAN (16)

Frage von thomasreischer zum Thema Hardware ...

Windows Server
Exchange HyperV Prozessorlast (16)

Frage von theoberlin zum Thema Windows Server ...