Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

PPTP site-to-site zwischen zwei Mikrotik Routern

Frage Netzwerke Router & Routing

Mitglied: FeuerTeufel

FeuerTeufel (Level 1) - Jetzt verbinden

09.06.2013 um 16:08 Uhr, 2328 Aufrufe, 4 Kommentare, 1 Danke

Hallo zusammen,

Ich bin seit mehreren Tagen dabei eine site-to-site Verbindung zwischen zwei Mikrotik Routern aufzubauen.
Anfangs habe ich auf L2TP / IPsec gesetzt doch als das nicht klappen wollte bin ich auf PPTP zurück gestiegen.

Ich habe beides nach den folgenden Anleitungen wie beschrieben konfiguriert:

http://wiki.mikrotik.com/wiki/L2TP_%2B_IPSEC_between_2_Mikrotik_routers
http://wiki.mikrotik.com/wiki/Manual:Interface/PPTP

Doch komme ich bei beiden immer auf das selbe Problem:

Die Verbindung zwischen den beiden Routern wurde aufgebaut egal ob L2TP/IPsec oder PPTP.
Wenn ich den jeweilig anderen Router mit seiner internen IP-Adresse anpinge bekomme ich auch eine Antwort, jedoch kann ich mich nicht per Winbox einloggen es kommt die Fehlermeldung: "Could not get index: fatal error!"
Der ping an die restlichen PC´s im entfernten Netzwerk funkioniert überhaupt nicht.


Netzwerk 1: 192.168.111.0/24

- Router: 192.168.111.2
- PPTP-Server: 172.17.0.1

Netzwerk 2: 192.168.222.0/24

- Router: 192.168.222.2
- PPTP-Client: 172.17.0.2


479ec83622c8209d21085c6c5a09d115 - Klicke auf das Bild, um es zu vergrößern93d97088ec6a3edb1215dcb63d4bce39 - Klicke auf das Bild, um es zu vergrößern


Falls noch Bilder bennötigt werden bitte bescheid geben.

Gruß
Niklas
Mitglied: orcape
09.06.2013 um 21:01 Uhr
Hi Niklas,

wenn der Tunnel funktioniert und die Verbindung im 172.17.0.0/24 Netz besteht, wird wohl das Routing zum LAN nicht funktionieren.
PPTP ist trotzdem keine Alternative, was den sicherheitstechnischen Aspekt betrifft.
Ich würde dann lieber auf OpenVPN umsteigen.

Gruß orcape
Bitte warten ..
Mitglied: aqui
09.06.2013, aktualisiert 10.06.2013
Oha, PPTP kann man nur von abraten. Siehe:
http://www.heise.de/security/artikel/Der-Todesstoss-fuer-PPTP-1701365.h ...

Hier findest du eine lauffähige Konfig für IPsec auf den Mikrotiks zum einfachen Abtippen:
http://www.administrator.de/contentid/115798 --> Kapitel "Praxisbeispiel Mikrotik"

Du bist vermutlich in 2 mögliche Fallen am Mikrotik gelaufen:
1.) Die Mikrotik IPsec Konfigs im Internet wie z.B. hier:
http://wiki.mikrotik.com/wiki/Manual:IP/IPsec
Haben alle einen entscheidenden Nachteil: Sie funktionieren wunderbar gelten aber ausschliesslich immer nur für Router die kein NAT (AdressTranslation) machen an Port 5 wie es default ist im Default Setup des Mikrotik.
Damit scheitern aber eingehende IPsec Zugriffe (und auch PPTP) an der NAT Firewall !
Hier musst du unbedingt diese Protokolle erlauben, dann klappt es auf Anhieb !
Das o.a. Tutorial beschreibt wie.
2.) Du hast vermutlich auch vergessen den Site to Site Traffic aus dem NAT Prozess auzuschliessen in der Konfig. Das ist zwingend notwendig, denn sonst wird dieser Traffic ebenfalls geNATet was er aber nicht darf !

Wenn man die beiden Punkte beachtet funktioniert es wunderbar.
Das o.a. Administrator Tutorial hat alle Details dazu.
Wichtig ist noch zu beachten das die Rechner auf der jeweiligen remoten Seite eine angepasste Firewall haben. Da du dort mit der Absender IP Adresse des jeweilig anderen IP Netzes auftauchst muss dort zwingend eine Ausnahme konfiguriert werden damit diese IP nicht geblockt wird wie es üblich ist. Beachte das.
Testweise kannst du die FW temporär deaktivieren !
Mit PPTP funktioniert es auch wunderbar allerdings wegen der massiven Unsicherheit bei PPTP sollte man das Protokoll besser nicht mehr verwenden. Jedenfalls nicht mehr im Firmenumfeld. Privat ist es sicher noch tolerabel, ein richtiges Passwort (mindestens 12 Stellen) vorausgesetzt.
Bitte warten ..
Mitglied: aqui
11.06.2013 um 08:51 Uhr
War es das denn nun ??
Wenn ja bitte dann auch
http://www.administrator.de/faq/32
nicht vergessen !!
Bitte warten ..
Mitglied: FeuerTeufel
11.06.2013 um 12:13 Uhr
PPTP war nur eine Notlösung um zu probieren ob es vielleicht an der Config liegt.

Meine Config des L2TP/IPsec Tunnels war vollkommen korrekt, nur leider hat meine Firewall auf dem Rechner den ping blockiert.
Und der Zugriff auf den Router, war vom Router aus auf das lokale Netz beschränkt.
Das auschließen des NAT´s hatte ich von Anfang an mit eingerichtet.

Ich danke für dich schnelle Hilfe.


Gruß Niklas
Bitte warten ..
Ähnliche Inhalte
Firewall
gelöst VPN Site to Site von IPFire zu Sophos UTM (19)

Frage von touro411 zum Thema Firewall ...

Router & Routing
Site-to-Site VPN hinter Routern - Verbindungsabbrüche (5)

Frage von Vincor zum Thema Router & Routing ...

UMTS, EDGE & GPRS
Site-to-site VPN halbiert de up- und downlink von LTE (4)

Frage von Kathy92 zum Thema UMTS, EDGE & GPRS ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Server
Bilder aus dem Web mit CSV runterladen (30)

Frage von Yannosch zum Thema Server ...

Server-Hardware
Bestehendes Raid erweitern um 4 gleiche Platten! (Verständnis Fragen) (12)

Frage von Hendrik2586 zum Thema Server-Hardware ...

Windows Update
WSUS 4 (Server 2012 R2) - Windows 10 Updates nicht möglich (12)

Frage von c0d3.r3d zum Thema Windows Update ...