Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

PPTP-Tunnel - WinXP-Client gibt keine Antwort

Frage Netzwerke

Mitglied: hijacker99

hijacker99 (Level 1) - Jetzt verbinden

10.03.2011 um 18:46 Uhr, 3684 Aufrufe, 3 Kommentare

Hallo

Hoffe, ich bin hier am richtigen Ort.

Folgende Topologie:
LAN mit DSL-Verbindung nach aussen. Auf dem internen Server (Linux) ist ein PPTP-Server installiert.
Die Einwahl funktioniert ohne Probleme. Auch kann ich den Server und andere Geräte pingen, ich kann via SMB auf den Server zugreifen und Drucken.
Jedoch habe ich im definierten Range auch einen WinXP-Client, auf dem eine Software läuft, auf die zugegriffen werden muss (via RDP).
Ich kann aber keine Verbindung zum Windows-Client via VPN aufbauen. Ping geht auch nicht. Firewall ist deaktiviert.

Der Zugriff funktioniert von intern, via Port-Forwarding auf den XP-Client ebenfalls.

Ich vermute, dass XP irgend was mit den Datenpaketen macht.

Achtung: Der Router ist NICHT der VPN-Server! Das übernimmt der interne Server, der VPN-Anfragen via Port 1723 entgegennimmt und den Tunnel aufbaut.

Wäre froh um jeden Tipp. Danke!
Mitglied: aqui
10.03.2011 um 20:24 Uhr
....und genau DAS ist auch dein Problem ! Der Client über den Tunnel wird auf dem Linux Server terminiert und der routet das VPN Paket mit der externen Client IP Adresse auf den lokalen XP Client im Netz !
Der XP Client wiederum kennt die externe VPN IP Adresse nicht und sendet Antwortpakete an sein Default gateway was der Router im Netz ist.
Vermutlich wi immer bei solchen Problemen hast du hier auf dem Router die statische Route ins VPN Netz via Linux PPTP Server vergessen und der DSL Router schickt das Antwortpaket dann zum Provider wo es dann im Nirwana versandet mit dem Ergebnis was du siehst !
Trage also im lokalen DSL Router eine statische Route nach ala:
Zielnetz: <vpn_ip_netz>, Maske: <vpn_ip_maske>, Gateway: <lokale_ip_linux>
Dann kommt das sofort zum Fliegen ! Traceroute und Pathping sind deine Freunde !
P.S.: PPTP ist nicht nur TCP1723 sondern auch noch das GRE Protokoll mit der IP Nummer 47 was die Produktivdaten transportiert !!
Bitte warten ..
Mitglied: hijacker99
10.03.2011 um 21:04 Uhr
Jetzt habe ich aber ein Verständnisproblem:

1. Der Client, der sich via PPTP einwählt, bekommt ja eine "interne" IP. Sollte also im gleichen Subnetz sein. Wie geschrieben, Geräte, die nicht auf WinXP laufen, geben eine Antwort zurück. Nur WinXP ist das Problem!

2. Eine Route habe ich auf dem Router bereits erstellt, wobei die nichts gebracht hat.

Vielleicht gebe ich hier rasch die Konfig durch (natürlich gefakt):

IP Router 192.168.44.1 >> Ping via PPTP geht
IP Server (VPN-Concentrator): 192.168.44.11 >> Ping via PPTP geht
IP Drucker: 192.168.44.12 >> Ping via PPTP geht
IP WinXP: 192.168.44.13 >> Ping via PPTP geht NICHT

Der Netzwerk-Range des PPTP-Tunnels (also der IPs, die zugelassen sind): 192.168.44.1-50
Client IP-Range: 192.168.44.200-240

Mein Client bekommt also bei der Einwahl die IP 192.168.44.200 (oder höher, je nachdem, was frei ist).

Wo also muss da was geroutet werden? Klar, beim VPN-Server. Aber der übernimmt das ja schon, sonst kämen von den anderen Geräten im Netz auch keine Antworten zurück.

Nachtrag: Alle Geräte im Netz haben als Default-GW die Adresse 192.168.44.1 des Routers hinterlegt.
Bitte warten ..
Mitglied: aqui
11.03.2011 um 10:27 Uhr
ad 1.) Ist dem wirklich so ?? Poste besser mal ein ipconfig -all wenn die PPTP Verbindung aktiv ist. Dort kannst du genau die vergebene IP sehen. In der Regel ist das eine Hosteroute mit einer /32 Maske ?!

ad 2.) WAS hast du denn für eine Route erstellt ?? Eine mit korrekter /32er Maske oder wie ? Was sagt denn ein Traceroute oder Pathping auf diese Ziel IP

Letztlich sieht es aber gut aus, denn wenn du den Drucker pingen kannst und der hat den Router als Gateway ist das ein eindeutiges Indiz das IP technisch alles sauber und korrekt ist ! Wenn du IP unnumbered benutzt im PPTP muss auch nix geroutet werden, richtig. Allerdings sind deine Informationen dazu mehr als spärlich und oberflächlich...sorry
Das Problem liegt dann lediglich am XP Rechner selber.
Was sagt dort denn ein route print ??
Was sagt ein Traceroute von dort auf die PPTP remote IP ??
Vermutlich ist hier wie immer die lokale Firewall aktiv oder ICMP (Ping) nicht zugelassen (Haken bei //Auf eingehende Echos antworten").
Du solltest also deine Suche rein auf den verwursteten XP Rechner konzentrieren !
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...